summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-03 23:45:42 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-04 00:12:20 +0200
commita474d68ae2db8b0500b08e8d54bc13dd1fc4ba73 (patch)
tree56aad2747bc4fb0ac63e6af264b1f809d4b0a755 /net-dialup
parentmedia-plugins/vdr-skinnopacity: Remove last-rited pkg (diff)
downloadgentoo-a474d68ae2db8b0500b08e8d54bc13dd1fc4ba73.tar.gz
gentoo-a474d68ae2db8b0500b08e8d54bc13dd1fc4ba73.tar.bz2
gentoo-a474d68ae2db8b0500b08e8d54bc13dd1fc4ba73.zip
net-dialup/gtkterm: Remove last-rited pkg
Closes: https://bugs.gentoo.org/622010
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/gtkterm/Manifest1
-rw-r--r--net-dialup/gtkterm/files/gtkterm-0.99.7_rc1-configure.patch14
-rw-r--r--net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild70
-rw-r--r--net-dialup/gtkterm/metadata.xml6
4 files changed, 0 insertions, 91 deletions
diff --git a/net-dialup/gtkterm/Manifest b/net-dialup/gtkterm/Manifest
deleted file mode 100644
index b95cdbe5afb..00000000000
--- a/net-dialup/gtkterm/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST gtkterm-0.99.7-rc1.tar.gz 172866 SHA256 91f555af0e0e8bf1fd73744a5486587a8a743ac7e6111e462763cf43def623d0 SHA512 9d629bb9b4700a9976f9bfc8c6bdfb170e06d38828e24747e2cb4cb7ab4908e030b3ba175ca7376929955c892843b6a6dae4e0cd4d67c80a6d959e4f6614424d WHIRLPOOL b6afaca868c1147c44d099202f82ee4222a8635019e5a633f964d76cb4ef0343e16acef9c86b217f0fbb2d3388cd653cd7e1fa1ccc8f41b2cce891dbeb42b411
diff --git a/net-dialup/gtkterm/files/gtkterm-0.99.7_rc1-configure.patch b/net-dialup/gtkterm/files/gtkterm-0.99.7_rc1-configure.patch
deleted file mode 100644
index 795025623ac..00000000000
--- a/net-dialup/gtkterm/files/gtkterm-0.99.7_rc1-configure.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN gtkterm-0.99.7-rc1.old/configure.in gtkterm-0.99.7-rc1/configure.in
---- gtkterm-0.99.7-rc1.old/configure.in 2012-03-02 14:05:29.842885142 -0800
-+++ gtkterm-0.99.7-rc1/configure.in 2012-03-02 14:11:20.242419122 -0800
-@@ -32,8 +32,8 @@
- dnl Checks for GTK+ and Imlib and libvte
- PKG_CHECK_MODULES(VTE, vte >= 0.20, , AC_MSG_ERROR([*** vte >= 0.20 not installed ***]))
-
--AC_SUBST(VTE_CFLAGS)
--AC_SUBST(VTE_LIBS)
-+AC_SUBST(TERMINAL_WIDGET_CFLAGS)
-+AC_SUBST(TERMINAL_WIDGET_LIBS)
-
- PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.16, , AC_MSG_ERROR([*** GTK >= 2.16 not installed ***]))
-
diff --git a/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild b/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild
deleted file mode 100644
index 24c9ad49b31..00000000000
--- a/net-dialup/gtkterm/gtkterm-0.99.7_rc1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils
-
-MY_P="${P/_/-}"
-DESCRIPTION="A serial port terminal written in GTK+, similar to Windows' HyperTerminal"
-HOMEPAGE="https://fedorahosted.org/gtkterm/"
-SRC_URI="https://fedorahosted.org/released/gtkterm/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="nls"
-
-inherit eutils autotools
-
-RDEPEND=">=x11-libs/gtk+-2.16:2
- >=x11-libs/vte-0.20:0"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-# Supported languages and translated documentation
-# Be sure all languages are prefixed with a single space!
-MY_AVAILABLE_LINGUAS=" fr hu"
-IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
-
-S=${WORKDIR}/${P/_/-}
-
-src_prepare() {
- # Fix test
- echo "src/term_config.c" >> po/POTFILES.in || die
-
- epatch "${FILESDIR}/${P}-configure.patch"
- sed -i -e "s/AM_SYS_POSIX_TERMIOS/AC_SYS_POSIX_TERMIOS/" \
- configure.in || die #bug #483346
-
- eautoreconf
-}
-
-src_install() {
- default
- make_desktop_entry "${PN}"
-
- if use nls; then
- cd "${S}/po"
- local MY_LINGUAS="" lang
-
- for lang in ${MY_AVAILABLE_LINGUAS} ; do
- if use linguas_${lang} ; then
- MY_LINGUAS="${MY_LINGUAS} ${lang}"
- fi
- done
- if [[ "${MY_LINGUAS}" ]] ; then
-
- elog "Locale messages will be installed for following languages:"
- elog " ${MY_LINGUAS}"
-
- for lang in ${MY_LINGUAS}; do
- msgfmt -o ${lang}.mo ${lang}.po && \
- insinto /usr/share/locale/${lang}/LC_MESSAGES && \
- newins ${lang}.mo gtkterm.mo || \
- die "failed to install locale messages for ${lang} language"
- done
- fi
- fi
-}
diff --git a/net-dialup/gtkterm/metadata.xml b/net-dialup/gtkterm/metadata.xml
deleted file mode 100644
index b8577cf1394..00000000000
--- a/net-dialup/gtkterm/metadata.xml
+++ /dev/null
@@ -1,6 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>A simplified "clone" of the famous Hyperterminal, without support for X/Y/ZMODEM protocols.</longdescription>
-</pkgmetadata>