summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 17:47:25 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 17:47:25 -0500
commitd6199160ccda34719b5a35e0896870a1dfb61b19 (patch)
tree83cd2fa2e9371a1ad2efe678d8c42609e7f45f45 /net-dns/mydns
parentnet-dns/maradns: remove maradns-2.0.09 (diff)
downloadgentoo-d6199160ccda34719b5a35e0896870a1dfb61b19.tar.gz
gentoo-d6199160ccda34719b5a35e0896870a1dfb61b19.tar.bz2
gentoo-d6199160ccda34719b5a35e0896870a1dfb61b19.zip
net-dns/mydns: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-dns/mydns')
-rw-r--r--net-dns/mydns/files/mydns.initd4
-rw-r--r--net-dns/mydns/mydns-1.2.8.31-r1.ebuild85
2 files changed, 87 insertions, 2 deletions
diff --git a/net-dns/mydns/files/mydns.initd b/net-dns/mydns/files/mydns.initd
index 970876191731..d78d1df91cb0 100644
--- a/net-dns/mydns/files/mydns.initd
+++ b/net-dns/mydns/files/mydns.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
MYDNS_CHECKCONF="/usr/bin/mydnscheck"
diff --git a/net-dns/mydns/mydns-1.2.8.31-r1.ebuild b/net-dns/mydns/mydns-1.2.8.31-r1.ebuild
new file mode 100644
index 000000000000..21949bb358a7
--- /dev/null
+++ b/net-dns/mydns/mydns-1.2.8.31-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A DNS-Server which gets its data from a MySQL-/PostgreSQL-database"
+HOMEPAGE="http://www.mydns.pl/"
+SRC_URI="mirror://sourceforge/mydns-ng/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~ppc sparc x86"
+IUSE="alias debug nls mysql postgres ssl static status"
+
+RDEPEND="mysql? ( virtual/mysql )
+ nls? ( virtual/libintl )
+ postgres? ( dev-db/postgresql )
+ ssl? ( dev-libs/openssl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.12 )
+ sys-devel/bison"
+
+REQUIRED_USE="^^ ( mysql postgres )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.8.27-m4.patch"
+ eautoreconf
+ epatch "${FILESDIR}/${P}-texinfo.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable alias) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_enable static) \
+ $(use_enable static static-build) \
+ $(use_enable status) \
+ $(use_with ssl openssl) \
+ --without-included-gettext
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS BUGS ChangeLog QUICKSTART* NEWS README* TODO
+ docinto contrib
+ dodoc contrib/*.php contrib/*.pl contrib/*.pm contrib/README*
+
+ newinitd "${FILESDIR}/mydns.initd" mydns
+ newconfd "${FILESDIR}/mydns.confd" mydns
+
+ ## Avoid file collision
+ rm -f "${ED}/usr/share/locale/locale.alias"
+
+ # Install config file
+ insinto /etc
+ newins mydns.conf mydns.conf
+ fowners root:root /etc/mydns.conf
+ fperms 0600 /etc/mydns.conf
+}
+
+pkg_postinst() {
+ if use postgres; then
+ elog "# createdb mydns"
+ elog "# /usr/sbin/mydns --create-tables | psql mydns"
+ elog
+ elog "to create the tables in the PostgreSQL-Database."
+ elog "For more info see QUICKSTART.postgres."
+ fi
+ if use mysql; then
+ elog "# mysqladmin -u <useruname> -p create mydns"
+ elog "# /usr/sbin/mydns --create-tables | mysql -u <username> -p mydns"
+ elog
+ elog "to create the tables in the MySQL-Database."
+ elog "For more info see QUICKSTART.mysql."
+ fi
+ elog
+}