summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-09-09 10:54:42 -0400
committerMichael Orlitzky <mjo@gentoo.org>2019-09-09 11:00:09 -0400
commitfba7038a466caec0068b064e8cb0210cafde8f3e (patch)
tree2c7523fd75b036b64d36d1eec204eb833ab51d66 /net-dns/rbldnsd
parentprefix.eclass: minor @USAGE fix (diff)
downloadgentoo-fba7038a466caec0068b064e8cb0210cafde8f3e.tar.gz
gentoo-fba7038a466caec0068b064e8cb0210cafde8f3e.tar.bz2
gentoo-fba7038a466caec0068b064e8cb0210cafde8f3e.zip
net-dns/rbldnsd: new version 0.998b.
This new version doesn't offer any new features or bug fixes, since our 0.998-r2 contains the two important patches from the upstream v0.998a and v0.998b. However, this release does let us drop those patches, and brings the Gentoo version in line with the latest upstream one, preventing some confusion. In addition, EAPI=7 is now used, and the dependencies have thus been reorganized. The "rbldns" user now also has its home directory set to the default (/dev/null) rather than /var/db/rbldnsd. This change is in preparation for a GLEP 81 user package that will use the default home directory, and allows us to test the new setting for a bit before making it permanent. Closes: https://bugs.gentoo.org/693148 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-dns/rbldnsd')
-rw-r--r--net-dns/rbldnsd/Manifest1
-rw-r--r--net-dns/rbldnsd/rbldnsd-0.998b.ebuild (renamed from net-dns/rbldnsd/rbldnsd-0.998-r2.ebuild)14
2 files changed, 8 insertions, 7 deletions
diff --git a/net-dns/rbldnsd/Manifest b/net-dns/rbldnsd/Manifest
index 05cc3765924c..667a95cc3920 100644
--- a/net-dns/rbldnsd/Manifest
+++ b/net-dns/rbldnsd/Manifest
@@ -1 +1,2 @@
DIST rbldnsd-0.998.tar.gz 145363 BLAKE2B e698f5b99ed1deae1aedda1952c19eb6189cbdcc71ecfa043faada966d30eee93e158dfeb059603dc493a665a7c56c84ff6ee636fc9eec7de38eb0bc73ed26db SHA512 7b6fb106f8188b2ce6e05b622cf90a393a4642f00faa5bddc184ce02dbd2beee9d8de22cb09ae53a25c475f28f99d13fbf6252f0d4c1d72bf47ba23f769e7074
+DIST rbldnsd-0.998b.tar.gz 154022 BLAKE2B f0bf03bef69853d45c3546c6fd3e58ffb95e76192ecb64f71f6799c6041749b1d117bed2bb21edbf1dec81d1684334b3af7d60b35d49089efb3a5e28752be6db SHA512 9b9c8694824a99b4ad120a22dbe4b05351867434e43ed0d8137990d3ece90ed67349965b6ed0450066d6663c1858545774c733b0d7afff304095de500ba30175
diff --git a/net-dns/rbldnsd/rbldnsd-0.998-r2.ebuild b/net-dns/rbldnsd/rbldnsd-0.998b.ebuild
index 04537f305756..27c112013d70 100644
--- a/net-dns/rbldnsd/rbldnsd-0.998-r2.ebuild
+++ b/net-dns/rbldnsd/rbldnsd-0.998b.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
inherit toolchain-funcs user python-any-r1
@@ -16,16 +16,16 @@ KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~x86-fbsd"
IUSE="ipv6 test zlib"
RDEPEND="zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
+ ${RDEPEND}
${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]')
)"
PATCHES=(
"${FILESDIR}/rbldnsd-0.997a-robust-ipv6-test-support.patch"
- "${FILESDIR}/rbldnsd-0.997a-format-security-compile-fix.patch"
- "${FILESDIR}/rbldnsd-0.998-fix-huge-zone-OOM.patch"
)
src_configure() {
@@ -60,8 +60,8 @@ src_install() {
newconfd "${FILESDIR}"/confd-0.997a rbldnsd
}
-pkg_postinst() {
+pkg_preinst() {
enewgroup rbldns
- enewuser rbldns -1 -1 /var/db/rbldnsd rbldns
+ enewuser rbldns -1 -1 -1 rbldns
fowners rbldns:rbldns /var/db/rbldnsd
}