summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-05-24 19:25:24 +0200
committerAaron Bauman <bman@gentoo.org>2018-05-24 16:34:57 -0400
commit917a50ae42e00b42457a3dd8e2283fddd70cc7c6 (patch)
tree0e733d3b4cb11db8efdd175d673b9e9014b6fd86 /net-dns
parentsys-freebsd/freebsd-mk-defs: remove unused patches (diff)
downloadgentoo-917a50ae42e00b42457a3dd8e2283fddd70cc7c6.tar.gz
gentoo-917a50ae42e00b42457a3dd8e2283fddd70cc7c6.tar.bz2
gentoo-917a50ae42e00b42457a3dd8e2283fddd70cc7c6.zip
net-dns/avahi: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/8552
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/avahi/files/avahi-0.6.31-build-client-without-daemon.patch27
-rw-r--r--net-dns/avahi/files/avahi-0.6.31-host-name-from-machine-id.patch85
-rw-r--r--net-dns/avahi/files/avahi-0.6.31-install-exec-hook.patch11
-rw-r--r--net-dns/avahi/files/avahi-0.6.31-invalid_packet.patch21
-rw-r--r--net-dns/avahi/files/avahi-0.6.31-so_reuseport-may-not-exist-in-running-kernel.patch30
-rw-r--r--net-dns/avahi/files/avahi-0.6.32-mocqt4.patch12
-rw-r--r--net-dns/avahi/files/avahi-0.6.32-openrc-0.21.7-fix-init-scripts.patch18
-rw-r--r--net-dns/avahi/files/avahi-0.6.x-openrc-0.9.x-init-scripts-fixes.patch22
8 files changed, 0 insertions, 226 deletions
diff --git a/net-dns/avahi/files/avahi-0.6.31-build-client-without-daemon.patch b/net-dns/avahi/files/avahi-0.6.31-build-client-without-daemon.patch
deleted file mode 100644
index df0c420fa62a..000000000000
--- a/net-dns/avahi/files/avahi-0.6.31-build-client-without-daemon.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From ce3b83de6aa689c0cefe0b1e85c03a627b537099 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Mon, 12 May 2014 19:46:22 +0200
-Subject: [PATCH] Allow building client without the daemon.
-
-There's no good reason to disallow that, and that's what we specifically
-want to do for multilib.
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 0e190ba..c56cf01 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1185,7 +1185,7 @@ fi
-
- BUILD_CLIENT="no (You need avahi-daemon and D-Bus!)"
-
--if test "x$BUILD_DAEMON" = "xyes" -a "x$HAVE_DBUS" = "xyes" ; then
-+if "x$HAVE_DBUS" = "xyes" ; then
- BUILD_CLIENT=yes
- fi
-
---
-1.9.3
-
diff --git a/net-dns/avahi/files/avahi-0.6.31-host-name-from-machine-id.patch b/net-dns/avahi/files/avahi-0.6.31-host-name-from-machine-id.patch
deleted file mode 100644
index 17ecba52534b..000000000000
--- a/net-dns/avahi/files/avahi-0.6.31-host-name-from-machine-id.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From: David Zeuthen <zeuthen@chromium.org>
-Date: Tue, 5 Mar 2013 19:52:38 +0000 (-0800)
-Subject: avahi-daemon: add option "host-name-from-machine-id="
-X-Git-Url: http://git.0pointer.de/?p=avahi.git;a=commitdiff_plain;h=147cdce70b22ae7cee9fb4fe123db40952f31c9e
-
-avahi-daemon: add option "host-name-from-machine-id="
-
-Signed-off-by: David Zeuthen <zeuthen@chromium.org>
----
-
-diff --git a/avahi-daemon/main.c b/avahi-daemon/main.c
-index d46f40a..8c28fd6 100644
---- a/avahi-daemon/main.c
-+++ b/avahi-daemon/main.c
-@@ -65,6 +65,7 @@
- #include <avahi-core/publish.h>
- #include <avahi-core/dns-srv-rr.h>
- #include <avahi-core/log.h>
-+#include <avahi-core/util.h>
-
- #ifdef ENABLE_CHROOT
- #include "chroot.h"
-@@ -576,6 +577,29 @@ static int parse_usec(const char *s, AvahiUsec *u) {
- return 0;
- }
-
-+static char *get_machine_id(void) {
-+ int fd;
-+ char buf[32];
-+
-+ fd = open("/etc/machine-id", O_RDONLY|O_CLOEXEC|O_NOCTTY);
-+ if (fd == -1 && errno == ENOENT)
-+ fd = open("/var/lib/dbus/machine-id", O_RDONLY|O_CLOEXEC|O_NOCTTY);
-+ if (fd == -1)
-+ return NULL;
-+
-+ /* File is on a filesystem so we never get EINTR or partial reads */
-+ if (read(fd, buf, sizeof buf) != sizeof buf) {
-+ close(fd);
-+ return NULL;
-+ }
-+ close(fd);
-+
-+ /* Contents can be lower, upper and even mixed case so normalize */
-+ avahi_strdown(buf);
-+
-+ return avahi_strndup(buf, sizeof buf);
-+}
-+
- static int load_config_file(DaemonConfig *c) {
- int r = -1;
- AvahiIniFile *f;
-@@ -631,6 +655,15 @@ static int load_config_file(DaemonConfig *c) {
- c->server_config.use_iff_running = is_yes(p->value);
- else if (strcasecmp(p->key, "disallow-other-stacks") == 0)
- c->server_config.disallow_other_stacks = is_yes(p->value);
-+ else if (strcasecmp(p->key, "host-name-from-machine-id") == 0) {
-+ if (*(p->value) == 'y' || *(p->value) == 'Y') {
-+ char *machine_id = get_machine_id();
-+ if (machine_id != NULL) {
-+ avahi_free(c->server_config.host_name);
-+ c->server_config.host_name = machine_id;
-+ }
-+ }
-+ }
- #ifdef HAVE_DBUS
- else if (strcasecmp(p->key, "enable-dbus") == 0) {
-
-diff --git a/man/avahi-daemon.conf.5.xml.in b/man/avahi-daemon.conf.5.xml.in
-index bea7ed5..2d15017 100644
---- a/man/avahi-daemon.conf.5.xml.in
-+++ b/man/avahi-daemon.conf.5.xml.in
-@@ -40,6 +40,12 @@
- </option>
-
- <option>
-+ <p><opt>host-name-from-machine-id=</opt> Takes a boolean
-+ value ("yes" or "no"). If set to "yes" avahi-daemon
-+ will use the machine-id as name on the LAN.</p>
-+ </option>
-+
-+ <option>
- <p><opt>domain-name=</opt> Set the default domain name avahi-daemon
- tries to register its host name and services on the LAN in. If
- omitted defaults to ".local".</p>
diff --git a/net-dns/avahi/files/avahi-0.6.31-install-exec-hook.patch b/net-dns/avahi/files/avahi-0.6.31-install-exec-hook.patch
deleted file mode 100644
index d9a7bc3434c7..000000000000
--- a/net-dns/avahi/files/avahi-0.6.31-install-exec-hook.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- avahi-0.6.31/avahi-utils/Makefile.am
-+++ avahi-0.6.31/avahi-utils/Makefile.am
-@@ -53,7 +53,7 @@
- avahi_set_host_name_CFLAGS = $(AM_CFLAGS)
- avahi_set_host_name_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
-
--install-exec-local:
-+install-exec-hook:
- cd $(DESTDIR)/$(bindir) && \
- rm -f avahi-resolve-host-name avahi-resolve-address avahi-browse-domains avahi-publish-address avahi-publish-service && \
- $(LN_S) avahi-resolve avahi-resolve-host-name && \
diff --git a/net-dns/avahi/files/avahi-0.6.31-invalid_packet.patch b/net-dns/avahi/files/avahi-0.6.31-invalid_packet.patch
deleted file mode 100644
index 5cfb4659bee6..000000000000
--- a/net-dns/avahi/files/avahi-0.6.31-invalid_packet.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Fix "Invalid response packet from host". Bug #559408.
-
-See http://pkgs.fedoraproject.org/cgit/avahi.git/plain/avahi-0.6.31-invalid_packet.patch
-
-diff -up avahi-0.6.31/avahi-core/server.c.invalid_packet avahi-0.6.31/avahi-core/server.c
---- avahi-0.6.31/avahi-core/server.c.invalid_packet 2015-09-22 08:12:58.544588701 -0500
-+++ avahi-0.6.31/avahi-core/server.c 2015-09-22 08:13:39.743862403 -0500
-@@ -972,11 +972,9 @@ static void dispatch_packet(AvahiServer
- return;
- }
-
-- if (avahi_dns_packet_get_field(p, AVAHI_DNS_FIELD_QDCOUNT) != 0 ||
-- avahi_dns_packet_get_field(p, AVAHI_DNS_FIELD_ANCOUNT) == 0 ||
-- avahi_dns_packet_get_field(p, AVAHI_DNS_FIELD_NSCOUNT) != 0) {
-+ if (avahi_dns_packet_get_field(p, AVAHI_DNS_FIELD_ANCOUNT) == 0) {
-
-- avahi_log_warn("Invalid response packet from host %s.", avahi_address_snprint(t, sizeof(t), src_address));
-+ avahi_log_debug("Invalid response packet from host %s.", avahi_address_snprint(t, sizeof(t), src_address));
- return;
- }
-
diff --git a/net-dns/avahi/files/avahi-0.6.31-so_reuseport-may-not-exist-in-running-kernel.patch b/net-dns/avahi/files/avahi-0.6.31-so_reuseport-may-not-exist-in-running-kernel.patch
deleted file mode 100644
index 9c23ca5e4554..000000000000
--- a/net-dns/avahi/files/avahi-0.6.31-so_reuseport-may-not-exist-in-running-kernel.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-https://bugs.gentoo.org/484212
-
-Description: SO_REUSEPORT may not exist in running kernel
- When userspace defines SO_REUSEPORT we will attempt to enable socket
- port number reuse. However if the running kernel does not support
- this call it will fail preventing daemon startup. If this call is
- present but fails ENOPROTOOPT then we know that actually the kernel
- does not support it and we should continue as if we did not have the
- call at all. (LP: #1228204)
- .
- This patch could be removed from the debian package after jessie release.
-Author: Andy Whitcroft <apw@canonical.com>
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/1228204
-Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732009
-Last-Update: 2013-09-20
-
-Index: avahi-0.6.31/avahi-core/socket.c
-===================================================================
---- avahi-0.6.31.orig/avahi-core/socket.c 2013-09-20 16:36:50.000000000 +0100
-+++ avahi-0.6.31/avahi-core/socket.c 2013-09-20 16:38:23.781863644 +0100
-@@ -177,7 +177,8 @@
- yes = 1;
- if (setsockopt(fd, SOL_SOCKET, SO_REUSEPORT, &yes, sizeof(yes)) < 0) {
- avahi_log_warn("SO_REUSEPORT failed: %s", strerror(errno));
-- return -1;
-+ if (errno != ENOPROTOOPT)
-+ return -1;
- }
- #endif
-
diff --git a/net-dns/avahi/files/avahi-0.6.32-mocqt4.patch b/net-dns/avahi/files/avahi-0.6.32-mocqt4.patch
deleted file mode 100644
index bba25e971630..000000000000
--- a/net-dns/avahi/files/avahi-0.6.32-mocqt4.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/configure.ac 2018-01-11 23:00:47.503309612 +0100
-+++ b/configure.ac 2018-01-11 23:10:04.373295395 +0100
-@@ -516,8 +516,7 @@
- PKG_CHECK_MODULES( QT4, [ QtCore >= 4.0.0 ])
- AC_SUBST(QT4_CFLAGS)
- AC_SUBST(QT4_LIBS)
-- QT4_PREFIX="`$PKG_CONFIG --variable=prefix QtCore`/bin"
-- AC_PATH_PROGS(MOC_QT4, [moc-qt4 moc], no, [$QT4_PREFIX])
-+ MOC_QT4="`$PKG_CONFIG --variable=moc_location QtCore`"
- if test "$MOC_QT4" = no; then
- AC_MSG_ERROR([Could not find QT4 moc])
- fi
diff --git a/net-dns/avahi/files/avahi-0.6.32-openrc-0.21.7-fix-init-scripts.patch b/net-dns/avahi/files/avahi-0.6.32-openrc-0.21.7-fix-init-scripts.patch
deleted file mode 100644
index 2b91179dd65f..000000000000
--- a/net-dns/avahi/files/avahi-0.6.32-openrc-0.21.7-fix-init-scripts.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -Naur avahi-0.6.32.orig/initscript/gentoo/avahi-daemon.in avahi-0.6.32/initscript/gentoo/avahi-daemon.in
---- avahi-0.6.32.orig/initscript/gentoo/avahi-daemon.in 2016-02-15 21:13:45.000000000 -0500
-+++ avahi-0.6.32/initscript/gentoo/avahi-daemon.in 2016-09-21 20:58:01.999109439 -0400
-@@ -1,4 +1,4 @@
--#!/sbin/runscript
-+#!/sbin/openrc-run
- # Copyright 1999-2007 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
-
-diff -Naur avahi-0.6.32.orig/initscript/gentoo/avahi-dnsconfd.in avahi-0.6.32/initscript/gentoo/avahi-dnsconfd.in
---- avahi-0.6.32.orig/initscript/gentoo/avahi-dnsconfd.in 2016-02-15 21:13:45.000000000 -0500
-+++ avahi-0.6.32/initscript/gentoo/avahi-dnsconfd.in 2016-09-21 20:58:12.683109618 -0400
-@@ -1,4 +1,4 @@
--#!/sbin/runscript
-+#!/sbin/openrc-run
- # Copyright 1999-2007 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
-
diff --git a/net-dns/avahi/files/avahi-0.6.x-openrc-0.9.x-init-scripts-fixes.patch b/net-dns/avahi/files/avahi-0.6.x-openrc-0.9.x-init-scripts-fixes.patch
deleted file mode 100644
index 394f6d34d0f0..000000000000
--- a/net-dns/avahi/files/avahi-0.6.x-openrc-0.9.x-init-scripts-fixes.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- avahi-0.6.30/initscript/gentoo/avahi-daemon.in
-+++ avahi-0.6.30/initscript/gentoo/avahi-daemon.in
-@@ -2,7 +2,7 @@
- # Copyright 1999-2007 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
-
--opts="reload"
-+extra_started_commands="reload"
-
- depend() {
- before netmount nfsmount
---- avahi-0.6.30/initscript/gentoo/avahi-dnsconfd.in
-+++ avahi-0.6.30/initscript/gentoo/avahi-dnsconfd.in
-@@ -2,7 +2,7 @@
- # Copyright 1999-2007 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
-
--opts="reload"
-+extra_started_commands="reload"
-
- depend() {
- need avahi-daemon