summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2019-03-19 22:43:38 +0000
committerSven Wegener <swegener@gentoo.org>2019-03-19 22:43:38 +0000
commit9f798504a95750eacd41148752cd088852bce632 (patch)
tree29c7152cdb6a969cd61ad91eadcab14319fbf3fe /net-dns
parentgnome-base/gdm: add elogind support (diff)
downloadgentoo-9f798504a95750eacd41148752cd088852bce632.tar.gz
gentoo-9f798504a95750eacd41148752cd088852bce632.tar.bz2
gentoo-9f798504a95750eacd41148752cd088852bce632.zip
net-dns/pdns: Cleanup
Signed-off-by: Sven Wegener <swegener@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns/Manifest2
-rw-r--r--net-dns/pdns/pdns-4.1.5.ebuild157
-rw-r--r--net-dns/pdns/pdns-4.1.6.ebuild157
3 files changed, 0 insertions, 316 deletions
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index 15a98f2a0f5c..218f373bb8e4 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,3 +1 @@
-DIST pdns-4.1.5.tar.bz2 1116238 BLAKE2B f67b94881cce988a7ac9f579b3107422aff68d1b4c6d4dc8b3b066ce76abb5a280f8ded0b4640f4ce3f3aec0652bdf544ab4bfc83a2a2e7d2d363ceae0efb7c8 SHA512 c5c42975e6402f17b3cdf947a26c944a462d39c23bef44b6f6e823b8c9459be9e8bd750aa0481f9f707eec8b124c4edc4769a6241c75836583ee0bbe111e33e5
-DIST pdns-4.1.6.tar.bz2 1116100 BLAKE2B 691dc67c28342534dca11dafd786dededce930d39b1ef77670ff6627c175dbb527a3759aae7d3cc2fb56419d67baecc528c812ffee86da57e84c8da103bc991f SHA512 094e532ff50aeb54c8b3e46e3b4a77d1fb2c9d3d0fccce6ccb71b3825f5e53f53af680625ea4e98b5dbc29fbd210bc3b4a47c7f05b4b3ac2cf7537369a7e15b2
DIST pdns-4.1.7.tar.bz2 1116191 BLAKE2B 8c214bff6d1af8354dc0b22c2bed233ec92e217fcfda456f69a665eb615500452f2bea7abfbab506f93abc35d0466a26594734a242e5cfef2b62e789252274d1 SHA512 dc9c693ac2eaf11ddce220e7fedc40f6ae3f9d7a55352643b30db2aad0b2d543ad04a14199a06355275aba2d9dd7873087715a16157b0ff2f7335f1a4a4b96a2
diff --git a/net-dns/pdns/pdns-4.1.5.ebuild b/net-dns/pdns/pdns-4.1.5.ebuild
deleted file mode 100644
index d37fb5d3a775..000000000000
--- a/net-dns/pdns/pdns-4.1.5.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit multilib user
-
-DESCRIPTION="The PowerDNS Daemon"
-HOMEPAGE="https://www.powerdns.com/"
-SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# other possible flags:
-# db2: we lack the dep
-# oracle: dito (need Oracle Client Libraries)
-# xdb: (almost) dead, surely not supported
-
-IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
-
-REQUIRED_USE="mydns? ( mysql )"
-
-RDEPEND="
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:= )
- >=dev-libs/boost-1.35:=
- botan? ( dev-libs/botan:2= )
- lua? (
- !luajit? ( dev-lang/lua:= )
- luajit? ( dev-lang/luajit:= )
- )
- mysql? ( dev-db/mysql-connector-c )
- postgres? ( dev-db/postgresql:= )
- ldap? ( >=net-nds/openldap-2.0.27-r4 app-crypt/mit-krb5 )
- sqlite? ( dev-db/sqlite:3 )
- opendbx? ( dev-db/opendbx )
- geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
- sodium? ( dev-libs/libsodium:= )
- tinydns? ( >=dev-db/tinycdb-0.77 )
- protobuf? ( dev-libs/protobuf )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}"/${P/_/-}
-
-src_configure() {
- local dynmodules="pipe bind" # the default backends, always enabled
-
- #use db2 && dynmodules+=" db2"
- use ldap && dynmodules+=" ldap"
- use lua && dynmodules+=" lua"
- use mydns && dynmodules+=" mydns"
- use mysql && dynmodules+=" gmysql"
- use opendbx && dynmodules+=" opendbx"
- #use oracle && dynmodules+=" goracle oracle"
- use postgres && dynmodules+=" gpgsql"
- use remote && dynmodules+=" remote"
- use sqlite && dynmodules+=" gsqlite3"
- use tinydns && dynmodules+=" tinydns"
- use geoip && dynmodules+=" geoip"
- #use xdb && dynmodules+=" xdb"
-
- econf \
- --disable-static \
- --sysconfdir=/etc/powerdns \
- --libdir=/usr/$(get_libdir)/powerdns \
- --with-modules= \
- --with-dynmodules="${dynmodules}" \
- --with-mysql-lib=/usr/$(get_libdir) \
- $(use_enable botan) \
- $(use_enable debug verbose-logging) \
- $(use_enable test unit-tests) \
- $(use_enable tools) \
- $(use_enable systemd) \
- $(use_enable sodium libsodium) \
- $(usex lua "$(use_with !luajit lua) $(use_with luajit)" \
- '--without-lua --without-luajit') \
- $(use_with protobuf) \
- ${myconf}
-}
-
-src_compile() {
- default
- use doc && emake -C codedocs codedocs
-}
-
-src_install() {
- default
-
- mv "${D}"/etc/powerdns/pdns.conf{-dist,}
-
- fperms 0700 /etc/powerdns
- fperms 0600 /etc/powerdns/pdns.conf
-
- # set defaults: setuid=pdns, setgid=pdns
- sed -i \
- -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
- "${D}"/etc/powerdns/pdns.conf
-
- newinitd "${FILESDIR}"/pdns-r1 pdns
-
- keepdir /var/empty
-
- if use doc; then
- docinto html
- dodoc -r codedocs/html/.
- fi
-
- # Install development headers
- insinto /usr/include/pdns
- doins pdns/*.hh
- insinto /usr/include/pdns/backends/gsql
- doins pdns/backends/gsql/*.hh
-
- if use ldap ; then
- insinto /etc/openldap/schema
- doins "${FILESDIR}"/dnsdomain2.schema
- fi
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_preinst() {
- enewgroup pdns
- enewuser pdns -1 -1 /var/empty pdns
-}
-
-pkg_postinst() {
- elog "PowerDNS provides multiple instances support. You can create more instances"
- elog "by symlinking the pdns init script to another name."
- elog
- elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
- elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
-
- if use ldap ; then
- ewarn "The official LDAP backend module is only compile-tested by upstream."
- ewarn "Try net-dns/pdns-ldap-backend if you have problems with it."
- fi
-
- local old
- for old in ${REPLACING_VERSIONS}; do
- ver_test ${old} -lt 3.2 || continue
-
- ewarn "To fix a security bug (bug #458018) had the following"
- ewarn "files/directories the world-readable bit removed (if set):"
- ewarn " ${EPREFIX}/etc/powerdns"
- ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
- ewarn "Check if this is correct for your setup"
- ewarn "This is a one-time change and will not happen on subsequent updates."
- chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
-
- break
- done
-}
diff --git a/net-dns/pdns/pdns-4.1.6.ebuild b/net-dns/pdns/pdns-4.1.6.ebuild
deleted file mode 100644
index 9c4996e63d3b..000000000000
--- a/net-dns/pdns/pdns-4.1.6.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit multilib user
-
-DESCRIPTION="The PowerDNS Daemon"
-HOMEPAGE="https://www.powerdns.com/"
-SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# other possible flags:
-# db2: we lack the dep
-# oracle: dito (need Oracle Client Libraries)
-# xdb: (almost) dead, surely not supported
-
-IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
-
-REQUIRED_USE="mydns? ( mysql )"
-
-RDEPEND="
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:= )
- >=dev-libs/boost-1.35:=
- botan? ( dev-libs/botan:2= )
- lua? (
- !luajit? ( dev-lang/lua:= )
- luajit? ( dev-lang/luajit:= )
- )
- mysql? ( dev-db/mysql-connector-c )
- postgres? ( dev-db/postgresql:= )
- ldap? ( >=net-nds/openldap-2.0.27-r4 app-crypt/mit-krb5 )
- sqlite? ( dev-db/sqlite:3 )
- opendbx? ( dev-db/opendbx )
- geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
- sodium? ( dev-libs/libsodium:= )
- tinydns? ( >=dev-db/tinycdb-0.77 )
- protobuf? ( dev-libs/protobuf )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}"/${P/_/-}
-
-src_configure() {
- local dynmodules="pipe bind" # the default backends, always enabled
-
- #use db2 && dynmodules+=" db2"
- use ldap && dynmodules+=" ldap"
- use lua && dynmodules+=" lua"
- use mydns && dynmodules+=" mydns"
- use mysql && dynmodules+=" gmysql"
- use opendbx && dynmodules+=" opendbx"
- #use oracle && dynmodules+=" goracle oracle"
- use postgres && dynmodules+=" gpgsql"
- use remote && dynmodules+=" remote"
- use sqlite && dynmodules+=" gsqlite3"
- use tinydns && dynmodules+=" tinydns"
- use geoip && dynmodules+=" geoip"
- #use xdb && dynmodules+=" xdb"
-
- econf \
- --disable-static \
- --sysconfdir=/etc/powerdns \
- --libdir=/usr/$(get_libdir)/powerdns \
- --with-modules= \
- --with-dynmodules="${dynmodules}" \
- --with-mysql-lib=/usr/$(get_libdir) \
- $(use_enable botan) \
- $(use_enable debug verbose-logging) \
- $(use_enable test unit-tests) \
- $(use_enable tools) \
- $(use_enable systemd) \
- $(use_enable sodium libsodium) \
- $(usex lua "$(use_with !luajit lua) $(use_with luajit)" \
- '--without-lua --without-luajit') \
- $(use_with protobuf) \
- ${myconf}
-}
-
-src_compile() {
- default
- use doc && emake -C codedocs codedocs
-}
-
-src_install() {
- default
-
- mv "${D}"/etc/powerdns/pdns.conf{-dist,}
-
- fperms 0700 /etc/powerdns
- fperms 0600 /etc/powerdns/pdns.conf
-
- # set defaults: setuid=pdns, setgid=pdns
- sed -i \
- -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
- "${D}"/etc/powerdns/pdns.conf
-
- newinitd "${FILESDIR}"/pdns-r1 pdns
-
- keepdir /var/empty
-
- if use doc; then
- docinto html
- dodoc -r codedocs/html/.
- fi
-
- # Install development headers
- insinto /usr/include/pdns
- doins pdns/*.hh
- insinto /usr/include/pdns/backends/gsql
- doins pdns/backends/gsql/*.hh
-
- if use ldap ; then
- insinto /etc/openldap/schema
- doins "${FILESDIR}"/dnsdomain2.schema
- fi
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_preinst() {
- enewgroup pdns
- enewuser pdns -1 -1 /var/empty pdns
-}
-
-pkg_postinst() {
- elog "PowerDNS provides multiple instances support. You can create more instances"
- elog "by symlinking the pdns init script to another name."
- elog
- elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
- elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
-
- if use ldap ; then
- ewarn "The official LDAP backend module is only compile-tested by upstream."
- ewarn "Try net-dns/pdns-ldap-backend if you have problems with it."
- fi
-
- local old
- for old in ${REPLACING_VERSIONS}; do
- ver_test ${old} -lt 3.2 || continue
-
- ewarn "To fix a security bug (bug #458018) had the following"
- ewarn "files/directories the world-readable bit removed (if set):"
- ewarn " ${EPREFIX}/etc/powerdns"
- ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
- ewarn "Check if this is correct for your setup"
- ewarn "This is a one-time change and will not happen on subsequent updates."
- chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
-
- break
- done
-}