summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Chvátal <scarabeus@gentoo.org>2016-02-08 11:16:04 +0100
committerTomáš Chvátal <scarabeus@gentoo.org>2016-02-08 11:16:22 +0100
commitbf4c3059da8c7cdf703e980534b89beb05e40a31 (patch)
treef650557818b7c968a5fa2aaacb27b08fd36d99d5 /net-dns
parentdev-lua/luaossl: Fix tags in metadata.xml. (diff)
downloadgentoo-bf4c3059da8c7cdf703e980534b89beb05e40a31.tar.gz
gentoo-bf4c3059da8c7cdf703e980534b89beb05e40a31.tar.bz2
gentoo-bf4c3059da8c7cdf703e980534b89beb05e40a31.zip
[net-dns/knot] Version update to 1.6.6 bug#553782 and version update to 2.1.0 with nettle patch bug#573866.
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/files/knot-2.1.0-nettle.patch26
-rw-r--r--net-dns/knot/knot-1.5.3.ebuild61
-rw-r--r--net-dns/knot/knot-1.6.6.ebuild (renamed from net-dns/knot/knot-1.6.3.ebuild)2
-rw-r--r--net-dns/knot/knot-2.1.0.ebuild (renamed from net-dns/knot/knot-2.0.2.ebuild)1
4 files changed, 28 insertions, 62 deletions
diff --git a/net-dns/knot/files/knot-2.1.0-nettle.patch b/net-dns/knot/files/knot-2.1.0-nettle.patch
new file mode 100644
index 000000000000..8f89ae85067f
--- /dev/null
+++ b/net-dns/knot/files/knot-2.1.0-nettle.patch
@@ -0,0 +1,26 @@
+diff --git a/src/dnssec/lib/binary.c b/src/dnssec/lib/binary.c
+index 454dc5a..8d642be 100644
+--- a/src/dnssec/lib/binary.c
++++ b/src/dnssec/lib/binary.c
+@@ -15,16 +15,18 @@
+ */
+
+ #include <assert.h>
+-#include <nettle/base64.h>
+ #include <string.h>
++#include <nettle/base64.h>
++#ifdef HAVE_NETTLE_VERSION_H
++#include <nettle/version.h>
++#endif
+
+ #include "binary.h"
+ #include "error.h"
+ #include "shared.h"
+
+ typedef
+-#ifdef HAVE_NETTLE_VERSION_H
+- #include <nettle/version.h>
++#ifdef NETTLE_VERSION_MAJOR
+ #if NETTLE_VERSION_MAJOR >= 3
+ size_t
+ #else
diff --git a/net-dns/knot/knot-1.5.3.ebuild b/net-dns/knot/knot-1.5.3.ebuild
deleted file mode 100644
index 77b523f63892..000000000000
--- a/net-dns/knot/knot-1.5.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-EGIT_REPO_URI="https://gitlab.labs.nic.cz/labs/${PN}.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-inherit eutils user
-
-DESCRIPTION="High-performance authoritative-only DNS server"
-HOMEPAGE="http://www.knot-dns.cz/"
-[[ ${PV} == 9999 ]] || SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~x86"
-IUSE="debug caps +fastparser idn"
-
-RDEPEND="
- dev-libs/openssl
- dev-libs/userspace-rcu
- caps? ( sys-libs/libcap-ng )
- idn? ( net-dns/libidn )
-"
-# sys-libs/glibc
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/flex
- virtual/yacc
- fastparser? ( dev-util/ragel )
-"
-
-S="${WORKDIR}/${P/_/-}"
-
-src_prepare() {
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- econf \
- --with-storage="${EPREFIX}/var/lib/${PN}" \
- --with-rundir="${EPREFIX}/var/run/${PN}" \
- --disable-lto \
- --enable-recvmmsg \
- $(use_enable fastparser) \
- $(use_enable debug debug server,zones,xfr,packet,dname,rr,ns,hash,compiler) \
- $(use_enable debug debuglevel details) \
- $(use_with idn libidn)
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}/knot.init" knot
-}
-
-pkg_postinst() {
- enewgroup knot 53
- enewuser knot 53 -1 /var/lib/knot knot
-}
diff --git a/net-dns/knot/knot-1.6.3.ebuild b/net-dns/knot/knot-1.6.6.ebuild
index 9b45a0ef6952..44bb39fbe737 100644
--- a/net-dns/knot/knot-1.6.3.ebuild
+++ b/net-dns/knot/knot-1.6.6.ebuild
@@ -35,7 +35,7 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P/_/-}"
src_prepare() {
- epatch "${FILESDIR}/${PV}-dont-create-extra-directories.patch"
+ epatch "${FILESDIR}/1.6.3-dont-create-extra-directories.patch"
}
src_configure() {
diff --git a/net-dns/knot/knot-2.0.2.ebuild b/net-dns/knot/knot-2.1.0.ebuild
index deb9f031be80..5e244eae6b31 100644
--- a/net-dns/knot/knot-2.0.2.ebuild
+++ b/net-dns/knot/knot-2.1.0.ebuild
@@ -35,6 +35,7 @@ S="${WORKDIR}/${P/_/-}"
src_prepare() {
epatch "${FILESDIR}/2.0.2-dont-create-extra-directories.patch"
+ epatch "${FILESDIR}/knot-2.1.0-nettle.patch"
}
src_configure() {