summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-07-28 14:14:44 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-07-28 14:37:53 -0500
commit462148526c28d28f20a393b30adf565d9c91308a (patch)
tree86ff245da7bcab2c6a258f43953a414449242bfa /net-firewall/firewalld
parentnet-misc/spice-gtk: update live ebuild (diff)
downloadgentoo-462148526c28d28f20a393b30adf565d9c91308a.tar.gz
gentoo-462148526c28d28f20a393b30adf565d9c91308a.tar.bz2
gentoo-462148526c28d28f20a393b30adf565d9c91308a.zip
net-firewall/firewalld: version bump to 0.7.1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'net-firewall/firewalld')
-rw-r--r--net-firewall/firewalld/Manifest1
-rw-r--r--net-firewall/firewalld/firewalld-0.7.1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-firewall/firewalld/Manifest b/net-firewall/firewalld/Manifest
index ab80ac826572..e3eec6989bfa 100644
--- a/net-firewall/firewalld/Manifest
+++ b/net-firewall/firewalld/Manifest
@@ -1,2 +1,3 @@
DIST firewalld-0.5.1.tar.gz 1155989 BLAKE2B 8e5f67dc74738cec178715b0e3713afa7296be61b376a8d545b1ae1c01c0f0df78ec48222b6926bdce1d93c58f7d02fad14bc46c1ddd24840e8853e5e76b73ff SHA512 8c8ea1a07fc81b12f53fbc84112d18c65c4332e8f7b7d575dc1ccba8a12418c874f8503b0062b49990f8bcfdf5fdaa7c0e4e3ddc0e9b1d0a91f49eff284b22be
DIST firewalld-0.6.3.tar.gz 2294470 BLAKE2B 09bb971d8142e5d28b6a085527e7f5275090f15e5dc4ccf2b16b6ed837049ed75443b09a54db76e37c6f0c5db6524ba85cf34c5117c1139bba0e3b223f289d57 SHA512 ea9e8bad34d3608257ef2a38851855974eff97b21dbab93ca3d8cfad90339734a8124447ed531a978b41546ab4040135bb61c8fdc9677ba0df9188d7ee4422ee
+DIST firewalld-0.7.1.tar.gz 2326020 BLAKE2B 1ab435bfd97608ce246657a24daebe6ca83f72560a627c702e940de64bf4fb34f26ebe9abf62468972fd8cd9394c5e885acd6882ec3cad112dfe62bca3905c7a SHA512 6be842d4c2849f56fc0e6c13219aed7d767635a3b190ef41f1516cecf51de71ad9af77ccc96b699d11bed56407abf9837cdbd0cfbf93ab716b5de5e4c2f94c68
diff --git a/net-firewall/firewalld/firewalld-0.7.1.ebuild b/net-firewall/firewalld/firewalld-0.7.1.ebuild
new file mode 100644
index 000000000000..275e832e3802
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-0.7.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit autotools bash-completion-r1 gnome2-utils linux-info python-single-r1 systemd xdg-utils
+
+DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
+HOMEPAGE="http://www.firewalld.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="gui"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !!net-firewall/gshield
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/python-slip-0.2.7[dbus,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-firewall/iptables[ipv6]
+ || ( net-firewall/iptables[nftables] net-firewall/ebtables )
+ net-firewall/ipset
+ net-firewall/nftables
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ gui? (
+ x11-libs/gtk+:3
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext"
+
+RESTRICT="test" # bug 650760
+
+pkg_setup() {
+ local CONFIG_CHECK="~NF_CONNTRACK ~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_IPV6 ~NETFILTER_XT_MATCH_CONNTRACK"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ python_setup
+
+ econf \
+ --enable-systemd \
+ --with-iptables="${EPREFIX}/sbin/iptables" \
+ --with-ip6tables="${EPREFIX}/sbin/ip6tables" \
+ --with-iptables_restore="${EPREFIX}/sbin/iptables-restore" \
+ --with-ip6tables_restore="${EPREFIX}/sbin/ip6tables-restore" \
+ --with-ebtables="${EPREFIX}/sbin/ebtables" \
+ --with-ebtables_restore="${EPREFIX}/sbin/ebtables-restore" \
+ --with-nft="${EPREFIX}/sbin/nft" \
+ --with-systemd-unitdir="$(systemd_get_systemunitdir)" \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ # Get rid of junk
+ rm -rf "${D}/etc/rc.d/" || die
+ rm -rf "${D}/etc/sysconfig/" || die
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -rf "${D}/etc/xdg/autostart" || die
+ rm -f "${D}/usr/bin/firewall-applet" || die
+ rm -f "${D}/usr/bin/firewall-config" || die
+ rm -rf "${D}/usr/share/applications" || die
+ rm -rf "${D}/usr/share/icons" || die
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}