summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-09 12:44:39 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-09 14:58:51 -0400
commitbefd2cd68c99dff9d2b060c1ffcaa96976a1949b (patch)
treeecd614aad9b353d11917832081f5d5ba1597b5a3 /net-fs/btfs/btfs-2.15.ebuild
parentnet-fs/cifs-utils: add patch to fix building when talloc is not installed (diff)
downloadgentoo-befd2cd68c99dff9d2b060c1ffcaa96976a1949b.tar.gz
gentoo-befd2cd68c99dff9d2b060c1ffcaa96976a1949b.tar.bz2
gentoo-befd2cd68c99dff9d2b060c1ffcaa96976a1949b.zip
net-fs/btfs: version bump to 2.15
Diffstat (limited to 'net-fs/btfs/btfs-2.15.ebuild')
-rw-r--r--net-fs/btfs/btfs-2.15.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-fs/btfs/btfs-2.15.ebuild b/net-fs/btfs/btfs-2.15.ebuild
new file mode 100644
index 000000000000..62a37b110eb3
--- /dev/null
+++ b/net-fs/btfs/btfs-2.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit autotools python-r1
+
+DESCRIPTION="a bittorrent filesystem based on FUSE"
+HOMEPAGE="https://github.com/johang/btfs"
+SRC_URI="https://github.com/johang/btfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND=">=sys-fs/fuse-2.8.0
+ >=net-misc/curl-7.22.0
+ dev-libs/boost:=
+ >=net-libs/libtorrent-rasterbar-0.16.0:="
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # don't install btplay via make
+ sed -i '/^SUBDIRS =/s/scripts//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript scripts/btplay
+}