summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-03-27 09:57:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-03-27 09:58:11 +0200
commitaf61a8bd9c0484d04fafc560236c8eacc890c2fa (patch)
treeadb7f09922178a8d6e5f96eed12a70a90025e1d0 /net-fs/cifs-utils
parentx11-misc/synergy: Version bump. (diff)
downloadgentoo-af61a8bd9c0484d04fafc560236c8eacc890c2fa.tar.gz
gentoo-af61a8bd9c0484d04fafc560236c8eacc890c2fa.tar.bz2
gentoo-af61a8bd9c0484d04fafc560236c8eacc890c2fa.zip
net-fs/cifs-utils: Fixed compilation with app-crypt/heimdal (# 612584).
Thanks to Igor Poboiko for providing a patch. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-fs/cifs-utils')
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.7.ebuild6
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.7-heimdal.patch27
2 files changed, 33 insertions, 0 deletions
diff --git a/net-fs/cifs-utils/cifs-utils-6.7.ebuild b/net-fs/cifs-utils/cifs-utils-6.7.ebuild
index ee8b16e1ecde..d008076005ab 100644
--- a/net-fs/cifs-utils/cifs-utils-6.7.ebuild
+++ b/net-fs/cifs-utils/cifs-utils-6.7.ebuild
@@ -52,6 +52,12 @@ pkg_setup() {
src_prepare() {
default
+
+ if has app-crypt/heimdal ; then
+ # https://bugs.gentoo.org/612584
+ eapply "${FILESDIR}/${PN}-6.7-heimdal.patch"
+ fi
+
eautoreconf
}
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.7-heimdal.patch b/net-fs/cifs-utils/files/cifs-utils-6.7-heimdal.patch
new file mode 100644
index 000000000000..f8fea48fb4b4
--- /dev/null
+++ b/net-fs/cifs-utils/files/cifs-utils-6.7-heimdal.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/612584
+
+--- cifs-utils-6.7/cifs.upcall.c
++++ cifs-utils-6.7/cifs.upcall.c
+@@ -75,11 +75,13 @@
+ #define KRB5_KEY_LENGTH(k) ((k)->keyvalue.length)
+ #define KRB5_KEY_DATA(k) ((k)->keyvalue.data)
+ #define KRB5_KEY_DATA_CAST void
++#define KRB5_FREE_STRING(c,k) krb5_xfree(k)
+ #else /* MIT */
+ #define KRB5_KEY_TYPE(k) ((k)->enctype)
+ #define KRB5_KEY_LENGTH(k) ((k)->length)
+ #define KRB5_KEY_DATA(k) ((k)->contents)
+ #define KRB5_KEY_DATA_CAST krb5_octet
++#define KRB5_FREE_STRING(c,k) krb5_free_string(c,k)
+ #endif
+
+ #ifdef HAVE_LIBCAP_NG
+@@ -358,7 +360,7 @@
+ syslog(LOG_DEBUG, "%s: krb5_cc_get_full_name failed: %d\n", __func__, ret);
+ } else {
+ syslog(LOG_DEBUG, "%s: default ccache is %s\n", __func__, cachename);
+- krb5_free_string(context, cachename);
++ KRB5_FREE_STRING(context, cachename);
+ }
+
+ if (!get_tgt_time(cc)) {