summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGokturk Yuksek <gokturk@binghamton.edu>2015-10-04 23:49:06 -0400
committerGokturk Yuksek <gokturk@binghamton.edu>2015-10-15 01:48:39 -0400
commit109922a4af0285b7e562374311ed6862060d2404 (patch)
tree40c98d0bf50254123e71e75e3d9ccaa87f1097c4 /net-fs/davfs2/davfs2-1.5.2.ebuild
parentnet-analyzer/fping: Version bump. (diff)
downloadgentoo-109922a4af0285b7e562374311ed6862060d2404.tar.gz
gentoo-109922a4af0285b7e562374311ed6862060d2404.tar.bz2
gentoo-109922a4af0285b7e562374311ed6862060d2404.zip
net-fs/davfs2: version bump to 1.5.2 #517732
Bump davfs2 to version 1.5.2. The ebuild has submitted via the bug 517732 and the original author is Chema Alonso <nimiux@gentoo.org>. Gentoo-Bug: https://bugs.gentoo.org/517732 Github-PR: https://github.com/gentoo/gentoo/pull/155 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-fs/davfs2/davfs2-1.5.2.ebuild')
-rw-r--r--net-fs/davfs2/davfs2-1.5.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-fs/davfs2/davfs2-1.5.2.ebuild b/net-fs/davfs2/davfs2-1.5.2.ebuild
new file mode 100644
index 000000000000..0dc857eaf28a
--- /dev/null
+++ b/net-fs/davfs2/davfs2-1.5.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit user
+
+DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
+HOMEPAGE="http://savannah.nongnu.org/projects/davfs2"
+SRC_URI="http://mirror.lihnidos.org/GNU/savannah/davfs2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="dev-libs/libxml2
+ net-libs/neon
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup davfs2
+}
+
+src_configure() {
+ econf dav_user=nobody --enable-largefile --docdir=/usr/share/doc/${P}
+}
+
+pkg_postinst() {
+ elog
+ elog "Quick setup:"
+ elog " (as root)"
+ elog " # gpasswd -a \${your_user} davfs2"
+ elog " # echo 'http://path/to/dav /home/\${your_user}/dav davfs rw,user,noauto 0 0' >> /etc/fstab"
+ elog " (as user)"
+ elog " # mkdir -p ~/dav"
+ elog " \$ mount ~/dav"
+ elog
+}