summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2019-10-08 21:39:41 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-10 08:50:57 +0100
commit52169845353af75b474217ad8799d8e7d846761f (patch)
treee3262f6f32d2871f347544bdcb49a8c0eca11f46 /net-fs
parentdev-db/etcd: Version bump to 3.4.2 (diff)
downloadgentoo-52169845353af75b474217ad8799d8e7d846761f.tar.gz
gentoo-52169845353af75b474217ad8799d8e7d846761f.tar.bz2
gentoo-52169845353af75b474217ad8799d8e7d846761f.zip
net-fs/smbnetfs: revbump, fix sys-fs/fuse SLOT
Closes: https://bugs.gentoo.org/697020 Signed-off-by: David Heidelberg <david@ixit.cz> Closes: https://github.com/gentoo/gentoo/pull/13220 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/smbnetfs/smbnetfs-0.6.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-fs/smbnetfs/smbnetfs-0.6.1-r1.ebuild b/net-fs/smbnetfs/smbnetfs-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..91ae91c3900f
--- /dev/null
+++ b/net-fs/smbnetfs/smbnetfs-0.6.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="FUSE filesystem for SMB shares"
+HOMEPAGE="https://sourceforge.net/projects/smbnetfs"
+SRC_URI="mirror://sourceforge/smbnetfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="gnome-keyring"
+
+RDEPEND=">=sys-fs/fuse-2.3:0=
+ >=net-fs/samba-4.2
+ >=dev-libs/glib-2.30
+ gnome-keyring? ( app-crypt/libsecret )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=("${FILESDIR}"/${P}-use-proper-xattr.patch)
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS="
+For quick usage, exec:
+'modprobe fuse'
+'smbnetfs -oallow_other /mnt/samba'
+"
+
+src_configure() {
+ econf $(use_with gnome-keyring libsecret)
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+ dodoc AUTHORS ChangeLog
+}