summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2018-01-30 13:48:34 +0800
committerYixun Lan <dlan@gentoo.org>2018-01-30 22:10:56 +0800
commit71ef9141d8a6b1d0383aeaac7c4bed9c5f690dfa (patch)
treeeced5ee135c69fad54f6c18ffb7ae3884ad28f52 /net-fs
parentwww-client/vivaldi-snapshot: Old. (diff)
downloadgentoo-71ef9141d8a6b1d0383aeaac7c4bed9c5f690dfa.tar.gz
gentoo-71ef9141d8a6b1d0383aeaac7c4bed9c5f690dfa.tar.bz2
gentoo-71ef9141d8a6b1d0383aeaac7c4bed9c5f690dfa.zip
net-fs/autofs: drop old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/Manifest5
-rw-r--r--net-fs/autofs/autofs-5.0.10.ebuild116
-rw-r--r--net-fs/autofs/autofs-5.0.7-r4.ebuild134
-rw-r--r--net-fs/autofs/autofs-5.0.7-r5.ebuild135
-rw-r--r--net-fs/autofs/autofs-5.1.1-r1.ebuild116
5 files changed, 0 insertions, 506 deletions
diff --git a/net-fs/autofs/Manifest b/net-fs/autofs/Manifest
index 7930bd660ec..14baaa843e1 100644
--- a/net-fs/autofs/Manifest
+++ b/net-fs/autofs/Manifest
@@ -1,7 +1,2 @@
-DIST autofs-5.0.10.tar.xz 258480 BLAKE2B a8b5656be4e7fe7330f56c5d6c3337f59e12c743ddf6421eda793eb933de5ffd9955239e4fd446d8a45cef86054ad9647bb93af300ed4286376b3e56ace77f05 SHA512 899d3b7040d1162312f9d595df0fd6c40489e4aefb7086893b51993446da78f10707d7e8caf8440ff24000d54794faca869aaf8564e5622caf8bb046af6fcf3b
-DIST autofs-5.0.7-patches-3.tar.lzma 37967 BLAKE2B 2aec4974f83bd15f1de4fd2a039a9cca177de71c9b0ff70d2aa0e3b994f547e43a7b6c723edbf49a5209f794850c67afe4ea41961aab7b9fe7039068af599117 SHA512 8cbb683a82d2cdc5e3c97921ba3a5bc5af5ab9fb45e4802de021a6161eaeaebb192790a351d281d48b68ed0f8ea6e3a0c0514a4f4a1c546191d8acca9e856ca7
-DIST autofs-5.0.7.tar.bz2 319117 BLAKE2B 7c5dcdd701740756abe25ef7a83c5de438676b981242ad983d15ebcfbd13b481df18edabfbcb3f0d675db85be983b3694982a790ea46ee3830eb840860f8de0b SHA512 672c53e0a5477097779088d8654edaad4cb01ab68ade2ee175d963c7d4895d1bdeeeabc87057ecca2f4f3a0f08014298dae40e5e8e862c20c0b1477d72431f84
-DIST autofs-5.1.1-patches-0.tar.lzma 41178 BLAKE2B 3e79f8f597b1a6e189d561d69923ff070d79edb1363e3134b28afb61772882d2290ecdf21e90ed09f882fbfaf68a00016e5ef745ee699100c1a5f41d8eff6408 SHA512 5c3ba26711401b3f9dc8cd36d3a85b1a8efce409621efedfc4f1caf2a15536646f6f89a79b8e12c703d3b3a4627ecda8c800386ebff34e20fdfad39041d91aa4
-DIST autofs-5.1.1.tar.xz 290300 BLAKE2B 1350e0c0fa9d8669b68a9ce82a8a5b86017f85dd2c6f7cb1198438aa0a16dc1dcb87a1ee0330c14f9220ed2a6f97994b8a547a9f711d75f4e05656b51658e892 SHA512 37c0f10ee06bbfc76059ff9ae54d9b462f1c2bc39e8779e96dd5bfc2b07055606c0710f1c3de95e6f099edd2c5bb5a6f8a341be989d7554bf80011bfbe90c905
DIST autofs-5.1.2.tar.xz 294792 BLAKE2B eeecac768726a1b2d336908b48222c53b1ffbc9eeff7b7f597ccbf55214d35f0d99eaeaa1c065509fffa31ec86729bdd51be873e003aa1fb7d88a9e2ab04f4c8 SHA512 435bcb41c9d467947c194d879e46692b5976131b8e923793bdeac34f70420ede740c4d70ec393413fff0b1010495ac7fe5fa8b45a59d15a2430ecae9ec3fe7e1
DIST autofs-5.1.3.tar.xz 300632 BLAKE2B 500325ec790304442e896208e94e25cf862621fc2354fa3c31fbf277dcc570d0b2b27894728d9f881efdcca262b1ef6e2c957cd23e2aea1d5b3cd2cd822c813b SHA512 d5363f4442be5258465140920a32cb63340c5da060ef2e66678f003d6a0c00579880837f0a04f59c7bce57d1cbc0f42bdd26546a2195f87e7bd46334c9e32e35
diff --git a/net-fs/autofs/autofs-5.0.10.ebuild b/net-fs/autofs/autofs-5.0.10.ebuild
deleted file mode 100644
index 8dcfbc310b0..00000000000
--- a/net-fs/autofs/autofs-5.0.10.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=true
-AUTOTOOLS_IN_SOURCE_BUILD=true
-
-inherit autotools-utils linux-info multilib systemd toolchain-funcs
-
-PATCH_VER=
-[[ -n ${PATCH_VER} ]] && \
- PATCHSET_URI="https://dev.gentoo.org/~jlec/distfiles/${P}-patches-${PATCH_VER}.tar.lzma"
-
-DESCRIPTION="Kernel based automounter"
-HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
-SRC_URI="
- mirror://kernel/linux/daemons/${PN}/v5/${P}.tar.xz
- ${PATCHSET_URI}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="-dmalloc hesiod ldap +libtirpc mount-locking sasl"
-
-# USE="sasl" adds SASL support to the LDAP module which will not be build. If
-# SASL support should be available, please add "ldap" to the USE flags.
-REQUIRED_USE="sasl? ( ldap )"
-
-# currently, sasl code assumes the presence of kerberosV
-RDEPEND=">=sys-apps/util-linux-2.20
- dmalloc? ( dev-libs/dmalloc[threads] )
- hesiod? ( net-dns/hesiod )
- ldap? ( >=net-nds/openldap-2.0
- sasl? (
- dev-libs/cyrus-sasl
- dev-libs/libxml2
- virtual/krb5
- )
- )
- libtirpc? ( net-libs/libtirpc )
- !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
-"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/yacc"
-
-CONFIG_CHECK="~AUTOFS4_FS"
-
-src_prepare() {
- # Upstream's patchset
- if [[ -n ${PATCH_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}"/patches
- fi
-
- sed -i -e "s:/usr/bin/kill:/bin/kill:" samples/autofs.service.in || die #bug #479492
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # bug #483716
- tc-export AR
- # --with-confdir is for bug #361481
- # --with-mapdir is for bug #385113
- local myeconfargs=(
- --with-confdir=/etc/conf.d
- --with-mapdir=/etc/autofs
- $(use_with dmalloc)
- $(use_with ldap openldap)
- $(use_with libtirpc)
- $(use_with sasl)
- $(use_with hesiod)
- $(use_enable mount-locking)
- --disable-ext-env
- --enable-sloppy-mount # bug #453778
- --enable-force-shutdown
- --enable-ignore-busy
- --with-systemd="$(systemd_get_unitdir)" #bug #479492
- RANLIB="$(type -P $(tc-getRANLIB))" # bug #483716
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile DONTSTRIP=1
-}
-
-src_install() {
- autotools-utils_src_install
-
- if kernel_is -lt 2 6 30; then
- # kernel patches
- docinto patches
- dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch
- fi
- newinitd "${FILESDIR}"/autofs5.initd autofs
- insinto etc/autofs
- newins "${FILESDIR}"/autofs5-auto.master auto.master
-}
-
-pkg_postinst() {
- if kernel_is -lt 2 6 30; then
- elog "This version of ${PN} requires a kernel with autofs4 supporting"
- elog "protocol version 5.00. Patches for kernels older than 2.6.30 have"
- elog "been installed into"
- elog "${EROOT}usr/share/doc/${P}/patches."
- elog "For further instructions how to patch the kernel, please refer to"
- elog "${EROOT}usr/share/doc/${P}/INSTALL."
- elog
- fi
- elog "If you plan on using autofs for automounting remote NFS mounts,"
- elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
- elog "are running."
-}
diff --git a/net-fs/autofs/autofs-5.0.7-r4.ebuild b/net-fs/autofs/autofs-5.0.7-r4.ebuild
deleted file mode 100644
index 89d72705b50..00000000000
--- a/net-fs/autofs/autofs-5.0.7-r4.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils linux-info multilib systemd toolchain-funcs
-
-PATCH_VER=3
-[[ -n ${PATCH_VER} ]] && \
- PATCHSET_URI="https://dev.gentoo.org/~jlec/distfiles/${P}-patches-${PATCH_VER}.tar.lzma"
-
-DESCRIPTION="Kernel based automounter"
-HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
-SRC_URI="
- mirror://kernel/linux/daemons/${PN}/v5/${P}.tar.bz2
- ${PATCHSET_URI}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 sparc x86"
-IUSE="-dmalloc hesiod ldap +libtirpc mount-locking sasl"
-
-# USE="sasl" adds SASL support to the LDAP module which will not be build. If
-# SASL support should be available, please add "ldap" to the USE flags.
-REQUIRED_USE="sasl? ( ldap )"
-
-# currently, sasl code assumes the presence of kerberosV
-RDEPEND=">=sys-apps/util-linux-2.20
- dmalloc? ( dev-libs/dmalloc[threads] )
- hesiod? ( net-dns/hesiod )
- ldap? ( >=net-nds/openldap-2.0
- sasl? (
- dev-libs/cyrus-sasl
- dev-libs/libxml2
- virtual/krb5
- )
- )
- libtirpc? ( net-libs/libtirpc )
- !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
-"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/yacc"
-
-CONFIG_CHECK="~AUTOFS4_FS"
-
-PATCHES=(
- # Fix for bug #210762
- # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/4203
- "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
-
- # Accumulated fixes for bugs
- # #154797: Respect CC and CFLAGS
- # #253412: Respect LDFLAGS
- # #247969: Link order for --as-needed
- "${FILESDIR}"/${PN}-5.0.7-respect-user-flags-and-fix-asneeded-r3.patch
-
- # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/5371
- "${FILESDIR}"/${PN}-5.0.5-fix-install-deadlink.patch
-
- "${FILESDIR}"/${P}-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch #361899, #468606
- "${FILESDIR}"/${PN}-5.0.6-revert-ldap.patch #381315
- "${FILESDIR}"/${PN}-5.0.7-sasl-def.patch #469324
- "${FILESDIR}"/${PN}-5.0.7-libtirpc-link.patch #464120
- "${FILESDIR}"/${PN}-5.0.7-parallel-make.patch
- )
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-src_prepare() {
- # Upstream's patchset
- if [[ -n ${PATCH_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}"/patches
- fi
- sed -i -e "s:/usr/bin/kill:/bin/kill:" samples/autofs.service.in || die #bug #479492
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # bug #483716
- tc-export AR
- # --with-confdir is for bug #361481
- # --with-mapdir is for bug #385113
- local myeconfargs=(
- --with-confdir=/etc/conf.d
- --with-mapdir=/etc/autofs
- $(use_with dmalloc)
- $(use_with ldap openldap)
- $(use_with libtirpc)
- $(use_with sasl)
- $(use_with hesiod)
- $(use_enable mount-locking)
- --disable-ext-env
- --enable-sloppy-mount # bug #453778
- --enable-forced-shutdown
- --enable-ignore-busy
- --with-systemd
- systemddir="$(systemd_get_unitdir)" #bug #479492
- RANLIB="$(type -P $(tc-getRANLIB))" # bug #483716
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- if kernel_is -lt 2 6 30; then
- # kernel patches
- docinto patches
- dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch
- fi
- newinitd "${FILESDIR}"/autofs5.initd autofs
- insinto etc/autofs
- newins "${FILESDIR}"/autofs5-auto.master auto.master
-}
-
-pkg_postinst() {
- if kernel_is -lt 2 6 30; then
- elog "This version of ${PN} requires a kernel with autofs4 supporting"
- elog "protocol version 5.00. Patches for kernels older than 2.6.30 have"
- elog "been installed into"
- elog "${EROOT}usr/share/doc/${P}/patches."
- elog "For further instructions how to patch the kernel, please refer to"
- elog "${EROOT}usr/share/doc/${P}/INSTALL."
- elog
- fi
- elog "If you plan on using autofs for automounting remote NFS mounts,"
- elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
- elog "are running."
-}
diff --git a/net-fs/autofs/autofs-5.0.7-r5.ebuild b/net-fs/autofs/autofs-5.0.7-r5.ebuild
deleted file mode 100644
index 21e1bfc9c98..00000000000
--- a/net-fs/autofs/autofs-5.0.7-r5.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils linux-info multilib systemd toolchain-funcs
-
-PATCH_VER=3
-[[ -n ${PATCH_VER} ]] && \
- PATCHSET_URI="https://dev.gentoo.org/~jlec/distfiles/${P}-patches-${PATCH_VER}.tar.lzma"
-
-DESCRIPTION="Kernel based automounter"
-HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
-SRC_URI="
- mirror://kernel/linux/daemons/${PN}/v5/${P}.tar.bz2
- ${PATCHSET_URI}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="-dmalloc hesiod ldap +libtirpc mount-locking sasl"
-
-# USE="sasl" adds SASL support to the LDAP module which will not be build. If
-# SASL support should be available, please add "ldap" to the USE flags.
-REQUIRED_USE="sasl? ( ldap )"
-
-# currently, sasl code assumes the presence of kerberosV
-RDEPEND=">=sys-apps/util-linux-2.20
- dmalloc? ( dev-libs/dmalloc[threads] )
- hesiod? ( net-dns/hesiod )
- ldap? ( >=net-nds/openldap-2.0
- sasl? (
- dev-libs/cyrus-sasl
- dev-libs/libxml2
- virtual/krb5
- )
- )
- libtirpc? ( net-libs/libtirpc )
- !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
-"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/yacc"
-
-CONFIG_CHECK="~AUTOFS4_FS"
-
-PATCHES=(
- # Fix for bug #210762
- # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/4203
- "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
-
- # Accumulated fixes for bugs
- # #154797: Respect CC and CFLAGS
- # #253412: Respect LDFLAGS
- # #247969: Link order for --as-needed
- "${FILESDIR}"/${PN}-5.0.7-respect-user-flags-and-fix-asneeded-r3.patch
-
- # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/5371
- "${FILESDIR}"/${PN}-5.0.5-fix-install-deadlink.patch
-
- "${FILESDIR}"/${P}-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch #361899, #468606
- "${FILESDIR}"/${PN}-5.0.6-revert-ldap.patch #381315
- "${FILESDIR}"/${PN}-5.0.7-sasl-def.patch #469324
- "${FILESDIR}"/${PN}-5.0.7-libtirpc-link.patch #464120
- "${FILESDIR}"/${PN}-5.0.7-parallel-make.patch
- "${FILESDIR}"/${PN}-5.0.7-sloppy-mount.patch #545258
- )
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-src_prepare() {
- # Upstream's patchset
- if [[ -n ${PATCH_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}"/patches
- fi
- sed -i -e "s:/usr/bin/kill:/bin/kill:" samples/autofs.service.in || die #bug #479492
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # bug #483716
- tc-export AR
- # --with-confdir is for bug #361481
- # --with-mapdir is for bug #385113
- local myeconfargs=(
- --with-confdir=/etc/conf.d
- --with-mapdir=/etc/autofs
- $(use_with dmalloc)
- $(use_with ldap openldap)
- $(use_with libtirpc)
- $(use_with sasl)
- $(use_with hesiod)
- $(use_enable mount-locking)
- --disable-ext-env
- --enable-sloppy-mount # bug #453778
- --enable-forced-shutdown
- --enable-ignore-busy
- --with-systemd
- systemddir="$(systemd_get_unitdir)" #bug #479492
- RANLIB="$(type -P $(tc-getRANLIB))" # bug #483716
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- if kernel_is -lt 2 6 30; then
- # kernel patches
- docinto patches
- dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch
- fi
- newinitd "${FILESDIR}"/autofs5.initd autofs
- insinto etc/autofs
- newins "${FILESDIR}"/autofs5-auto.master auto.master
-}
-
-pkg_postinst() {
- if kernel_is -lt 2 6 30; then
- elog "This version of ${PN} requires a kernel with autofs4 supporting"
- elog "protocol version 5.00. Patches for kernels older than 2.6.30 have"
- elog "been installed into"
- elog "${EROOT}usr/share/doc/${P}/patches."
- elog "For further instructions how to patch the kernel, please refer to"
- elog "${EROOT}usr/share/doc/${P}/INSTALL."
- elog
- fi
- elog "If you plan on using autofs for automounting remote NFS mounts,"
- elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
- elog "are running."
-}
diff --git a/net-fs/autofs/autofs-5.1.1-r1.ebuild b/net-fs/autofs/autofs-5.1.1-r1.ebuild
deleted file mode 100644
index e19da04a290..00000000000
--- a/net-fs/autofs/autofs-5.1.1-r1.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=true
-AUTOTOOLS_IN_SOURCE_BUILD=true
-
-inherit autotools-utils linux-info multilib systemd toolchain-funcs
-
-PATCH_VER=0
-[[ -n ${PATCH_VER} ]] && \
- PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-patches-${PATCH_VER}.tar.lzma"
-
-DESCRIPTION="Kernel based automounter"
-HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
-SRC_URI="
- mirror://kernel/linux/daemons/${PN}/v5/${P}.tar.xz
- ${PATCHSET_URI}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="-dmalloc hesiod ldap +libtirpc mount-locking sasl"
-
-# USE="sasl" adds SASL support to the LDAP module which will not be build. If
-# SASL support should be available, please add "ldap" to the USE flags.
-REQUIRED_USE="sasl? ( ldap )"
-
-# currently, sasl code assumes the presence of kerberosV
-RDEPEND=">=sys-apps/util-linux-2.20
- dmalloc? ( dev-libs/dmalloc[threads] )
- hesiod? ( net-dns/hesiod )
- ldap? ( >=net-nds/openldap-2.0
- sasl? (
- dev-libs/cyrus-sasl
- dev-libs/libxml2
- virtual/krb5
- )
- )
- libtirpc? ( net-libs/libtirpc )
- !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
-"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/yacc"
-
-CONFIG_CHECK="~AUTOFS4_FS"
-
-src_prepare() {
- # Upstream's patchset
- if [[ -n ${PATCH_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}"/patches
- fi
-
- sed -i -e "s:/usr/bin/kill:/bin/kill:" samples/autofs.service.in || die #bug #479492
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # bug #483716
- tc-export AR
- # --with-confdir is for bug #361481
- # --with-mapdir is for bug #385113
- local myeconfargs=(
- --with-confdir=/etc/conf.d
- --with-mapdir=/etc/autofs
- $(use_with dmalloc)
- $(use_with ldap openldap)
- $(use_with libtirpc)
- $(use_with sasl)
- $(use_with hesiod)
- $(use_enable mount-locking)
- --disable-ext-env
- --enable-sloppy-mount # bug #453778
- --enable-force-shutdown
- --enable-ignore-busy
- --with-systemd="$(systemd_get_unitdir)" #bug #479492
- RANLIB="$(type -P $(tc-getRANLIB))" # bug #483716
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile DONTSTRIP=1
-}
-
-src_install() {
- autotools-utils_src_install
-
- if kernel_is -lt 2 6 30; then
- # kernel patches
- docinto patches
- dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch
- fi
- newinitd "${FILESDIR}"/autofs5.initd autofs
- insinto etc/autofs
- newins "${FILESDIR}"/autofs5-auto.master auto.master
-}
-
-pkg_postinst() {
- if kernel_is -lt 2 6 30; then
- elog "This version of ${PN} requires a kernel with autofs4 supporting"
- elog "protocol version 5.00. Patches for kernels older than 2.6.30 have"
- elog "been installed into"
- elog "${EROOT}usr/share/doc/${P}/patches."
- elog "For further instructions how to patch the kernel, please refer to"
- elog "${EROOT}usr/share/doc/${P}/INSTALL."
- elog
- fi
- elog "If you plan on using autofs for automounting remote NFS mounts,"
- elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
- elog "are running."
-}