summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-08-08 14:08:40 -0500
committerAustin English <wizardedit@gentoo.org>2017-08-09 13:50:26 -0500
commit82fd27bd179c57ee98732718805eeb11df55b16c (patch)
tree9180c3a6a0829882425a193418370dfd8cdf7ba7 /net-fs
parentwww-client/pybugz: Works with py3_6 (diff)
downloadgentoo-82fd27bd179c57ee98732718805eeb11df55b16c.tar.gz
gentoo-82fd27bd179c57ee98732718805eeb11df55b16c.tar.bz2
gentoo-82fd27bd179c57ee98732718805eeb11df55b16c.zip
net-fs/cifs-utils: add patch to fix building when talloc is not installed
Gentoo-Bug: https://bugs.gentoo.org/612018 Acked-By: axs@gentoo.org Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.7.ebuild4
-rw-r--r--net-fs/cifs-utils/files/cifs-utils-6.7-talloc.patch29
2 files changed, 33 insertions, 0 deletions
diff --git a/net-fs/cifs-utils/cifs-utils-6.7.ebuild b/net-fs/cifs-utils/cifs-utils-6.7.ebuild
index e312ad6cd2ba..b18e773d4607 100644
--- a/net-fs/cifs-utils/cifs-utils-6.7.ebuild
+++ b/net-fs/cifs-utils/cifs-utils-6.7.ebuild
@@ -35,6 +35,10 @@ REQUIRED_USE="acl? ( ads )"
DOCS="doc/linux-cifs-client-guide.odt"
+PATCHES=(
+ "${FILESDIR}/${P}-talloc.patch"
+)
+
pkg_setup() {
linux-info_pkg_setup
diff --git a/net-fs/cifs-utils/files/cifs-utils-6.7-talloc.patch b/net-fs/cifs-utils/files/cifs-utils-6.7-talloc.patch
new file mode 100644
index 000000000000..7e3418631bd4
--- /dev/null
+++ b/net-fs/cifs-utils/files/cifs-utils-6.7-talloc.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/show_bug.cgi?id=612018
+
+From: Thomas Witt <pyromaniac@exherbo.org>
+Date: Wed, 15 Mar 2017 20:20:44 +0000 (+0000)
+Subject: mount.cifs: Remove data_blob.h include
+X-Git-Url: https://git.samba.org/?p=cifs-utils.git;a=commitdiff_plain;h=272d523a57a4e8791d625a479128613be5e401f5
+
+mount.cifs: Remove data_blob.h include
+
+data_blob.h includes talloc.h from libtalloc, but that is only marked as
+a dependency for cifs.upcall. No symbols from that header are used by
+cifs.mount, so remove it to avoid the libtalloc dependency
+
+Signed-off-by: Thomas Witt <pyromaniac@exherbo.org>
+---
+
+diff --git a/mount.cifs.c b/mount.cifs.c
+index 13b71ef..2612feb 100644
+--- a/mount.cifs.c
++++ b/mount.cifs.c
+@@ -61,7 +61,6 @@
+ #include "mount.h"
+ #include "util.h"
+ #include "resolve_host.h"
+-#include "data_blob.h"
+
+ #ifndef MS_MOVE
+ #define MS_MOVE 8192
+