summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2021-10-05 00:57:35 +0200
committerSam James <sam@gentoo.org>2021-10-05 00:12:43 +0100
commit8d3af136164ed42f4dce8e0e0265bb21d4a2e3a7 (patch)
tree7f9dd9ec546e0ff29daf4b9c37a29abb72395da3 /net-fs
parentdev-python/jsonschema: Keyword 4.0.1 arm, #815403 (diff)
downloadgentoo-8d3af136164ed42f4dce8e0e0265bb21d4a2e3a7.tar.gz
gentoo-8d3af136164ed42f4dce8e0e0265bb21d4a2e3a7.tar.bz2
gentoo-8d3af136164ed42f4dce8e0e0265bb21d4a2e3a7.zip
net-fs/davfs2: fix support for neon-0.32
Just making the configure script happy. Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Closes: https://bugs.gentoo.org/816294 Closes: https://github.com/gentoo/gentoo/pull/22490 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/davfs2/davfs2-1.6.0.ebuild7
-rw-r--r--net-fs/davfs2/files/davfs2-1.6.0-neon-0.32-support.patch13
2 files changed, 20 insertions, 0 deletions
diff --git a/net-fs/davfs2/davfs2-1.6.0.ebuild b/net-fs/davfs2/davfs2-1.6.0.ebuild
index f967945cae1e..67767035ccb4 100644
--- a/net-fs/davfs2/davfs2-1.6.0.ebuild
+++ b/net-fs/davfs2/davfs2-1.6.0.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
HOMEPAGE="https://savannah.nongnu.org/projects/davfs2"
SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
@@ -26,6 +28,10 @@ RDEPEND="${RDEPEND}
acct-user/davfs2
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-neon-0.32-support.patch
+)
+
src_prepare() {
local f
@@ -35,6 +41,7 @@ src_prepare() {
done < <(find "${S}"/man -type f -name 'Makefile.in' -print0)
default
+ eautoreconf
}
src_configure() {
diff --git a/net-fs/davfs2/files/davfs2-1.6.0-neon-0.32-support.patch b/net-fs/davfs2/files/davfs2-1.6.0-neon-0.32-support.patch
new file mode 100644
index 000000000000..3a7c316e374b
--- /dev/null
+++ b/net-fs/davfs2/files/davfs2-1.6.0-neon-0.32-support.patch
@@ -0,0 +1,13 @@
+# Gentoo bug https://bugs.gentoo.org/816294
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -36,7 +36,7 @@ AC_PROG_LN_S
+ # Checks for libraries.
+ AM_GNU_GETTEXT_VERSION(0.19.8)
+ AM_GNU_GETTEXT([external])
+-NE_REQUIRE_VERSIONS([0], [27 28 29 30 31])
++NE_REQUIRE_VERSIONS([0], [27 28 29 30 31 32])
+ DAV_CHECK_NEON
+
+ # Checks for header files.