summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 21:04:14 +0100
committerSam James <sam@gentoo.org>2022-10-28 21:09:26 +0100
commit946bede45a68e5c82f1665fdccf16dc13bc01f47 (patch)
tree3fac6676812d8dc954421084027f26be1009f937 /net-fs
parentnet-dialup/rp-pppoe: drop 3.15 (diff)
downloadgentoo-946bede45a68e5c82f1665fdccf16dc13bc01f47.tar.gz
gentoo-946bede45a68e5c82f1665fdccf16dc13bc01f47.tar.bz2
gentoo-946bede45a68e5c82f1665fdccf16dc13bc01f47.zip
net-fs/libnfs: drop 5.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/libnfs/Manifest1
-rw-r--r--net-fs/libnfs/files/libnfs-5.0.1-pthread-configure.patch34
-rw-r--r--net-fs/libnfs/libnfs-5.0.1.ebuild60
3 files changed, 0 insertions, 95 deletions
diff --git a/net-fs/libnfs/Manifest b/net-fs/libnfs/Manifest
index b4273017697e..a49346135177 100644
--- a/net-fs/libnfs/Manifest
+++ b/net-fs/libnfs/Manifest
@@ -1,2 +1 @@
-DIST libnfs-5.0.1.tar.gz 279550 BLAKE2B d27e97f3dce1385cabd8076b673d2bbfe339ff5a34295ca13bfea2f9c2048f4c6dd07a0b54b7cc7e44aecda58dd21520732dc6ee82260f0694a01fec59875a6a SHA512 71f2dcfa8945c1cb6402f5fca10b1f7a4720f7589807d6130eb55361f05ef4684f9cc9a177ece4e13d3847ac6606924115fac7b27749cecc2f5aca6fa9c63ebf
DIST libnfs-5.0.2.tar.gz 281154 BLAKE2B 9de3d02e5ae4d41eacda152678e6552708b33d4e88cc6fc5f7b16c887f911fc5a5e834952505438220c961f71a8b70540be3254d5889a4336200d5633dce313e SHA512 6dcf4ea8a01b35beb53694625d20fbebd858a88725c2742671878ad6fe7877999f93d262fb58a435b00c283c3e6fb6fa7222d04bb4540bf674b7ce196e9424f5
diff --git a/net-fs/libnfs/files/libnfs-5.0.1-pthread-configure.patch b/net-fs/libnfs/files/libnfs-5.0.1-pthread-configure.patch
deleted file mode 100644
index 91c3781389b4..000000000000
--- a/net-fs/libnfs/files/libnfs-5.0.1-pthread-configure.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://github.com/sahlberg/libnfs/pull/380
-
-From af37ac6d766755185dc023b940cfe78a176170a0 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sun, 3 Apr 2022 04:22:04 +0100
-Subject: [PATCH] autotools: fix syntax error in configure when pthreads
- disabled
-
-Avoids this warning/syntax error in configure when pthreads aren't
-enabled (default):
-```
-checking for special C compiler options needed for large files... no
-checking for _FILE_OFFSET_BITS value needed for large files... no
-./configure: 14227: test: =: unexpected operator
-checking whether SO_BINDTODEVICE is available... yes
-checking whether getpwnam() is available... yes
-```
-
-The LHS of the test will be blank, so use an 'x' to give a dummy
-value, like we do elsewhere.
-
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/configure.ac
-+++ b/configure.ac
-@@ -88,7 +88,7 @@ if test x"$libnfs_cv_HAVE_PTHREAD" = x"yes"; then
- AC_DEFINE(HAVE_MULTITHREADING,1,[Whether we have multithreading support])
- fi
- fi
--AM_CONDITIONAL([HAVE_PTHREAD], [test $libnfs_cv_HAVE_PTHREAD = yes])
-+AM_CONDITIONAL([HAVE_PTHREAD], [test x$libnfs_cv_HAVE_PTHREAD = xyes])
-
- AC_MSG_CHECKING(whether SO_BINDTODEVICE is available)
- AC_TRY_COMPILE([#include <net/if.h>], [
-
diff --git a/net-fs/libnfs/libnfs-5.0.1.ebuild b/net-fs/libnfs/libnfs-5.0.1.ebuild
deleted file mode 100644
index 04425c5f0208..000000000000
--- a/net-fs/libnfs/libnfs-5.0.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
-else
- SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 x86"
- S="${WORKDIR}"/${PN}-${P}
-fi
-
-DESCRIPTION="Client library for accessing NFS shares over a network"
-HOMEPAGE="https://github.com/sahlberg/libnfs"
-
-LICENSE="LGPL-2.1 GPL-3"
-SLOT="0/14" # sub-slot matches SONAME major
-IUSE="examples static-libs utils"
-
-# net-libs/rpcsvc-proto for rpcgen called in build system
-BDEPEND="net-libs/rpcsvc-proto
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/libnfs-5.0.1-pthread-configure.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-werror
- $(use_enable static-libs static)
- $(use_enable utils)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- if use examples; then
- # --enable-examples configure switch just compiles them
- # better install sources instead
- exeinto /usr/share/doc/${PF}/examples/
- for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
- doexe examples/${program}.c
- done
- fi
-
- find "${ED}" -name "*.la" -delete || die
-}