summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-09-14 01:27:44 +0200
committerTobias Klausmann <klausman@gentoo.org>2021-09-14 22:15:04 +0200
commit3434fdb7c1eba3721771dece9523b70d9775bbe1 (patch)
treebd104f8f7aacb0ebb57926327e77ad501b72170d /net-ftp/atftp/atftp-0.7.5.ebuild
parentdev-db/timescaledb: Bump to 2.4.1 (diff)
downloadgentoo-3434fdb7c1eba3721771dece9523b70d9775bbe1.tar.gz
gentoo-3434fdb7c1eba3721771dece9523b70d9775bbe1.tar.bz2
gentoo-3434fdb7c1eba3721771dece9523b70d9775bbe1.zip
net-ftp/atftp: version bump to 0.7.5
Version 0.7.5 (Bugfix, Security Fix Release) fix many bugs, fix denial-of-service buffer overflow CVE-2021-41054 new feature: add an option to prevent the Sorcerer's Apprentice Syndrome Closes: https://bugs.gentoo.org/813079 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Diffstat (limited to 'net-ftp/atftp/atftp-0.7.5.ebuild')
-rw-r--r--net-ftp/atftp/atftp-0.7.5.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-ftp/atftp/atftp-0.7.5.ebuild b/net-ftp/atftp/atftp-0.7.5.ebuild
new file mode 100644
index 000000000000..001bba2e8253
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.7.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="https://sourceforge.net/projects/atftp/"
+SRC_URI="mirror://sourceforge/atftp/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="selinux tcpd readline pcre"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ readline? ( sys-libs/readline:0= )
+ pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}
+ !net-ftp/tftp-hpa
+ !net-ftp/uftpd
+ selinux? ( sec-policy/selinux-tftp )"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-CFLAGS.patch"
+)
+
+src_prepare() {
+ append-cppflags -D_REENTRANT -DRATE_CONTROL
+ # fix #561720 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tcpd libwrap) \
+ $(use_enable readline libreadline) \
+ $(use_enable pcre libpcre) \
+ --enable-mtftp
+}
+
+src_test() {
+ cd "${S}"/test || die
+ TEMPDIR=. ./test.sh || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
+
+ systemd_dounit "${FILESDIR}"/atftp.service
+ systemd_install_serviced "${FILESDIR}"/atftp.service.conf
+
+ dodoc README* BUGS FAQ Changelog INSTALL TODO
+ dodoc "${S}"/docs/*
+
+ docinto test
+ cd "${S}"/test || die
+ dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
+}