summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-01-04 19:09:08 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2018-01-04 19:25:06 +0100
commit5da91a0e7e87216d015732c88388b104e9b4a176 (patch)
treecfb8706f57cbd758244bd13255c4219c873e226a /net-ftp/filezilla
parentdev-libs/libfilezilla: drop old 0.11 (diff)
downloadgentoo-5da91a0e7e87216d015732c88388b104e9b4a176.tar.gz
gentoo-5da91a0e7e87216d015732c88388b104e9b4a176.tar.bz2
gentoo-5da91a0e7e87216d015732c88388b104e9b4a176.zip
net-ftp/filezilla: 3.29.0 bump
Closes: https://bugs.gentoo.org/636868 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.29.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index a51a64ec53d1..2237cdf034b6 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -1 +1,2 @@
DIST FileZilla_3.25.2_src.tar.bz2 4712781 BLAKE2B c4e346442596eb2c1c7f5b541dc1386be5be13a3564187d5d7f275b5e1223cf1c95e11e27120c98276ea550d0b1c65122ffd62b5471a886faf1ebea0ab217522 SHA512 6c6feeec0b1bd15ff2c3fecbec22bca9c79f4263e0d1855c6d27a3df54128cfd837f0a546d1540b87b4645e620b57961b8ac0f01bd52748832f5625139c39764
+DIST FileZilla_3.29.0_src.tar.bz2 4832040 BLAKE2B b956ac69d22c3ec5ef32827594ad70aaeeef8c9359f557162a95aba053fafbf13621ba34fd73201b0b15529e7379b77c18d808c304a6c398f8927f8f903e2e53 SHA512 d1906cb18cfebb0ac9f92b1b97e11ffe2f5bf1b70d9cf1454e627f141a0fe9b3d1ba473a0464d5727e8fccf992643a64cfb729d93187a010fcb4f59603589349
diff --git a/net-ftp/filezilla/filezilla-3.29.0.ebuild b/net-ftp/filezilla/filezilla-3.29.0.ebuild
new file mode 100644
index 000000000000..85207f6b65be
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.29.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+
+inherit autotools eutils flag-o-matic gnome2-utils multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.10.0
+ >=dev-libs/pugixml-1.7
+ net-dns/libidn
+ >=net-libs/gnutls-3.4.0
+ >=x11-libs/wxGTK-3.0.3:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-pugixml=system \
+ --disable-autoupdatecheck
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}