summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-ftp/yafc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-ftp/yafc')
-rw-r--r--net-ftp/yafc/Manifest1
-rw-r--r--net-ftp/yafc/metadata.xml12
-rw-r--r--net-ftp/yafc/yafc-1.2.6.ebuild46
3 files changed, 59 insertions, 0 deletions
diff --git a/net-ftp/yafc/Manifest b/net-ftp/yafc/Manifest
new file mode 100644
index 000000000000..33667fd4cbfd
--- /dev/null
+++ b/net-ftp/yafc/Manifest
@@ -0,0 +1 @@
+DIST yafc-1.2.6.tar.xz 367408 SHA256 96bd46c4dbfbff5d83cb0cec0809b2d1d73c66aff6b30fdd44a291267325b617 SHA512 155339f04eb17e63383e35573497e4838a09ac6f6608c07e8639b0e163c755c40a426f0ade941efd8ba774c6b577358dac6fd18c56bbea7d1fec57b00cb05d35 WHIRLPOOL 673ebaba7e816f3901b696004dddfa0727344aec3f6a4edd86f8dd69058d1dcbe607334a942974e7b8180519292961ce44dc5b656024eb6aa73120f9cec41947
diff --git a/net-ftp/yafc/metadata.xml b/net-ftp/yafc/metadata.xml
new file mode 100644
index 000000000000..7bd2aa1c49f0
--- /dev/null
+++ b/net-ftp/yafc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>page@cubata.homelinux.net</email>
+ <name>Carles Pagès</name>
+ </maintainer>
+ <use>
+ <flag name="ssh">Build with SFTP support</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-ftp/yafc/yafc-1.2.6.ebuild b/net-ftp/yafc/yafc-1.2.6.ebuild
new file mode 100644
index 000000000000..3d89d53cab6c
--- /dev/null
+++ b/net-ftp/yafc/yafc-1.2.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="Console ftp client with a lot of nifty features"
+HOMEPAGE="http://www.yafc-ftp.com/"
+SRC_URI="http://www.yafc-ftp.com/upload/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="ipv6 readline kerberos socks5 ssh"
+
+DEPEND="dev-libs/openssl:0
+ readline? ( >=sys-libs/readline-6 )
+ kerberos? ( virtual/krb5 )
+ socks5? ( net-proxy/dante )
+ ssh? ( net-libs/libssh )"
+RDEPEND="${DEPEND}"
+
+DOCS=( BUGS NEWS README THANKS TODO )
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ export ac_cv_ipv6=$(usex ipv6)
+ econf \
+ $(use_with readline readline /usr) \
+ $(use_with socks5 socks /usr) \
+ $(use_with socks5 socks5 /usr) \
+ $(use_with kerberos krb5) \
+ $(use_with ssh) \
+ --with-bash-completion="$(get_bashcompdir)" \
+ --without-krb4
+}
+
+src_install() {
+ default
+ dodoc -r samples
+}