summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-09-24 23:40:29 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-09-24 23:40:29 +0200
commit6bc92a41afe5447193e01e382ffbcfcd52b5397d (patch)
tree20cc5781cc01308ca043432fa32a27899c7545a1 /net-ftp
parentdev-libs/libfilezilla: 0.18.2 bump (diff)
downloadgentoo-6bc92a41afe5447193e01e382ffbcfcd52b5397d.tar.gz
gentoo-6bc92a41afe5447193e01e382ffbcfcd52b5397d.tar.bz2
gentoo-6bc92a41afe5447193e01e382ffbcfcd52b5397d.zip
net-ftp/filezilla: 3.45.0 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.45.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index b1ca30803fe5..7f6ab89e9152 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -3,3 +3,4 @@ DIST FileZilla_3.42.1_src.tar.bz2 4987250 BLAKE2B 8cc6fd0a0cec336f34793520fe4be5
DIST FileZilla_3.43.0_src.tar.bz2 4544635 BLAKE2B 13c99918dd7674fe3f2f0217b39ebe7aa89effe411e3cf90e08c9177278ce143ac84a021e49be0bc0772af29a5c34c33b03ce93d54f0b9918e4ea1001875ea48 SHA512 12c518616508e1cbd7ab60f1b94f8c876c885bc4399674c4b2df34235141fde1297a1edc686078c0f93b040ea6e42984c22ace00c4da201c7f99b4c9b71f5bc1
DIST FileZilla_3.44.1_src.tar.bz2 4606669 BLAKE2B 407697467d7f9511b1b4e2e11505cf8815dd950609eabf242e283918e577d70f9b732fef930bbe97ba60fdffa484d77e0f7d74bb3ade8d1fcd0296ce91384301 SHA512 fa2e8c65621c7c6003e45f99f5153177e507ca34dde49d86d6f59e8b985abdeb80b779d71e554fc6acb891a695a0ef4c275bf0950af1b4cb67ff5ddb4c51e3b7
DIST FileZilla_3.44.2_src.tar.bz2 4619337 BLAKE2B 11d61b14fcf464706dabe491fa8cbfa28fb516c3e1aafd887679ed6f1a80ba835dc43403c32b1344854f00f5b56f7e27c72bbca197cfadc92e69d92ebb0b1458 SHA512 9d4678a3a06f0ecac5ecfbae33f83df5f07e26da4f4a7e922fe5b00a5e59d5728af028667f6fa56210a23ecaa1c2a661d1874b218c2511a783644ed2b03e36ad
+DIST FileZilla_3.45.0_src.tar.bz2 4647043 BLAKE2B 9fd164ccbcd80e8d2369420bd00d6e082525ece5e4bd9e0d612f9f2482b080f1c41c250163769539b063207bf038d1cdce9ae3b2588eeae31c6ec2bb1cf296d7 SHA512 4e9683c1ab0fbb2fa1e03e46bbf11564ef9482dad0c302b5d13e083cd5d966662c6c620c24d7eb295e41df36b1d0bd15572fe2a14c194e2245f326c8b6a1d238
diff --git a/net-ftp/filezilla/filezilla-3.45.0.ebuild b/net-ftp/filezilla/filezilla-3.45.0.ebuild
new file mode 100644
index 000000000000..4f7a1a0848d7
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.45.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.18.2
+ <dev-libs/libfilezilla-0.19.0
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( >=dev-util/cppunit-1.13.0 )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}