summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-23 13:40:19 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-23 21:49:17 +0200
commitdcd1a43f1d94f02a3935b8ebbd112173b4177a5a (patch)
tree2275e99a29ab34ad45f36205ff1682d556a15e9a /net-ftp
parentacct-user/ftp: drop old version (diff)
downloadgentoo-dcd1a43f1d94f02a3935b8ebbd112173b4177a5a.tar.gz
gentoo-dcd1a43f1d94f02a3935b8ebbd112173b4177a5a.tar.bz2
gentoo-dcd1a43f1d94f02a3935b8ebbd112173b4177a5a.zip
net-ftp/ftpbase: add zeroconf support
Also dropped old blocker, which are ancient. Closes: https://bugs.gentoo.org/261910 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpbase/files/ftp.service10
-rw-r--r--net-ftp/ftpbase/ftpbase-0.01-r5.ebuild39
-rw-r--r--net-ftp/ftpbase/metadata.xml3
3 files changed, 52 insertions, 0 deletions
diff --git a/net-ftp/ftpbase/files/ftp.service b/net-ftp/ftpbase/files/ftp.service
new file mode 100644
index 000000000000..9194b45a8364
--- /dev/null
+++ b/net-ftp/ftpbase/files/ftp.service
@@ -0,0 +1,10 @@
+<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
+<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
+
+<service-group>
+ <name replace-wildcards="yes">File Transfer Protocol (FTP) on %h</name>
+ <service>
+ <port>21</port>
+ <type>_ftp._tcp</type>
+ </service>
+</service-group>
diff --git a/net-ftp/ftpbase/ftpbase-0.01-r5.ebuild b/net-ftp/ftpbase/ftpbase-0.01-r5.ebuild
new file mode 100644
index 000000000000..526756b0ee02
--- /dev/null
+++ b/net-ftp/ftpbase/ftpbase-0.01-r5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam
+
+DESCRIPTION="File Transfer Protocol (FTP) base layout"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="pam zeroconf"
+
+DEPEND="
+ pam? ( sys-libs/pam )
+ zeroconf? ( net-dns/avahi )
+"
+
+RDEPEND="
+ acct-group/ftp
+ acct-user/ftp
+"
+
+src_install() {
+ # The ftpusers file is a list of people who are NOT allowed
+ # to use the ftp service.
+ insinto /etc
+ doins "${FILESDIR}/ftpusers"
+
+ use pam && newpamd "${FILESDIR}"/ftp-pamd-include ftp
+
+ if use zeroconf; then
+ insinto /etc/avahi/services
+ doins "${FILESDIR}/ftp.service"
+ fi
+}
diff --git a/net-ftp/ftpbase/metadata.xml b/net-ftp/ftpbase/metadata.xml
index debde3ef6ae3..ecab8ef815c6 100644
--- a/net-ftp/ftpbase/metadata.xml
+++ b/net-ftp/ftpbase/metadata.xml
@@ -6,4 +6,7 @@
<name>Conrad Kostecki</name>
</maintainer>
<stabilize-allarches/>
+ <use>
+ <flag name="zeroconf">Enable support for zero-configuration networking via Avahi.</flag>
+ </use>
</pkgmetadata>