summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-03-28 19:11:53 +0200
committerJeroen Roovers <jer@gentoo.org>2016-03-28 19:24:46 +0200
commitde2497f634a09037b9fd8f3b3a96a25ebad5030a (patch)
tree35e3e744d61ddc7998648f3be3807caa8d801176 /net-ftp
parentkde-frameworks/breeze-icons: Remove old (diff)
downloadgentoo-de2497f634a09037b9fd8f3b3a96a25ebad5030a.tar.gz
gentoo-de2497f634a09037b9fd8f3b3a96a25ebad5030a.tar.bz2
gentoo-de2497f634a09037b9fd8f3b3a96a25ebad5030a.zip
net-ftp/lftp: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/Manifest1
-rw-r--r--net-ftp/lftp/files/lftp-4.7.0-gettext.patch11
-rw-r--r--net-ftp/lftp/lftp-4.7.0.ebuild91
3 files changed, 103 insertions, 0 deletions
diff --git a/net-ftp/lftp/Manifest b/net-ftp/lftp/Manifest
index 1f096fc47449..1aefdae5edc4 100644
--- a/net-ftp/lftp/Manifest
+++ b/net-ftp/lftp/Manifest
@@ -1,2 +1,3 @@
DIST lftp-4.6.4.tar.xz 1508952 SHA256 1e7cb674c83ace48172263f86847ed04bb6ab2f24116b11a8505f70a15e8805c SHA512 998050c0e69fc590233df8b400664c1165dfa80d7b3844aa307be33e004c3dd3e049df8f288ad7079257a31dc4adcdb07a57b8f28cd0adf7e3cf94c41d38b9dc WHIRLPOOL d79849970ff72eda2f5dccd3ce16b619e37661b60152363d96c13d94e4045d24e568b265bb27c8ef809fbfb18c6e31884ae28dba0d0bf6fc252c87ea82ca1396
DIST lftp-4.6.5.tar.xz 1514644 SHA256 1fd0920a1791ce0e9e39ffce77ae6619e5dc665f16e9380bafbfc69411eeb71e SHA512 a22faa3a6901160460f1103c19c5276f603c154908ec2e34804a6eb48452b59ba495993e6824f57d114285ddc80a64dccd0069465cc0593f34f435ac181250c0 WHIRLPOOL 088598ed9395cd8f9ed79be26e0833593e733cf87bbd51e5d008ce4de2b9924e62add20789c098a866d82dc3f168a373c4874de264d669950524a9a255e1e028
+DIST lftp-4.7.0.tar.xz 1621592 SHA256 9a0b3580b222a7f9cc17c6c85d6ac8ec227357ca5050301171fd9564aae73f44 SHA512 9d20b78a8ae33ef7337ce2699d5ff682b45fd3015d5a9b40e87ca6c426a1ce22ab13778110e8120da8c5087c5de9fe203b7192e2e80296e9d84d267c4b2b5de6 WHIRLPOOL 3df4ef7e89c3499811ed90d0775c5eed48a7698cc26475cd9c545af66ffa1e355e93c8bf579d24885fee301d044f39fe92de7a5afc48a4700910fa9959050725
diff --git a/net-ftp/lftp/files/lftp-4.7.0-gettext.patch b/net-ftp/lftp/files/lftp-4.7.0-gettext.patch
new file mode 100644
index 000000000000..c2d6b805478e
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.7.0-gettext.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2016-03-28 18:28:34.834007550 +0200
++++ configure.ac 2016-03-28 19:03:32.455125971 +0200
+@@ -138,7 +138,7 @@
+
+ ALL_LINGUAS="de es fr it ja ko pl pt_BR ru uk zh_CN zh_TW zh_HK cs"
+ AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.15])
++AM_GNU_GETTEXT_VERSION([0.19])
+ test "$MSGFMT" = "no" && MSGFMT ="$missing_dir/missing msgfmt"
+ test "$GMSGFMT" = "no" && GMSGFMT ="$missing_dir/missing msgfmt"
+ test "$XGETTEXT" = ":" && XGETTEXT="$missing_dir/missing xgettext"
diff --git a/net-ftp/lftp/lftp-4.7.0.ebuild b/net-ftp/lftp/lftp-4.7.0.ebuild
new file mode 100644
index 000000000000..fc291443e393
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.7.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils libtool
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="${HOMEPAGE}ftp/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="convert-mozilla-cookies +gnutls idn ipv6 nls openssl socks5 +ssl verify-file"
+LFTP_LINGUAS=( cs de es fr it ja ko pl pt_BR ru uk zh_CN zh_HK zh_TW )
+IUSE+=" ${LFTP_LINGUAS[@]/#/linguas_}"
+
+REQUIRED_USE="
+ ssl? ( ^^ ( openssl gnutls ) )
+"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1:=
+ >=sys-libs/readline-5.1:=
+ dev-libs/expat
+ sys-libs/zlib
+ convert-mozilla-cookies? ( dev-perl/DBI )
+ idn? ( net-dns/libidn )
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam
+ )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ openssl? ( dev-libs/openssl:0 )
+ )
+ verify-file? (
+ dev-perl/string-crc32
+ virtual/perl-Digest-MD5
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ =sys-devel/libtool-2*
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.19 )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ BUGS ChangeLog FAQ FEATURES MIRRORS NEWS README README.debug-levels
+ README.dnssec README.modules THANKS TODO
+)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.0.2.91-lafile.patch \
+ "${FILESDIR}"/${PN}-4.5.5-am_config_header.patch \
+ "${FILESDIR}"/${PN}-4.7.0-gettext.patch
+
+ eautoreconf
+ elibtoolize # for Darwin bundles
+
+ # bug #536036
+ printf 'set fish:auto-confirm no\nset sftp:auto-confirm no\n' >> ${PN}.conf || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_enable ipv6) \
+ $(use_with openssl openssl "${EPREFIX}"/usr) \
+ $(use_with socks5 socksdante "${EPREFIX}"/usr) \
+ --enable-packager-mode \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-modules \
+ --without-included-regex
+}
+
+src_install() {
+ default
+ local script
+ for script in {convert-mozilla-cookies,verify-file}; do
+ use ${script} || { rm "${ED}"/usr/share/${PN}/${script} || die ;}
+ done
+}