summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-01-20 15:59:44 -0500
committerTim Harder <radhermit@gentoo.org>2017-01-20 16:00:35 -0500
commitf488b698d3c4e4a34cbb7fa0b9ba275b9e2e7836 (patch)
treeafc6062ea772e0b23a433c3af3340a6914f94447 /net-im/bitlbee/bitlbee-9999.ebuild
parentwww-client/google-chrome-beta: automated update (56.0.2924.67) (diff)
downloadgentoo-f488b698d3c4e4a34cbb7fa0b9ba275b9e2e7836.tar.gz
gentoo-f488b698d3c4e4a34cbb7fa0b9ba275b9e2e7836.tar.bz2
gentoo-f488b698d3c4e4a34cbb7fa0b9ba275b9e2e7836.zip
net-im/bitlbee: version bump to 3.5
Diffstat (limited to 'net-im/bitlbee/bitlbee-9999.ebuild')
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index ae09048b8d8f..d0101436617e 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit user systemd
+inherit user systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
inherit git-r3
else
- SRC_URI="http://get.bitlbee.org/src/${P}.tar.gz"
+ SRC_URI="https://get.bitlbee.org/src/${P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
fi
DESCRIPTION="irc to IM gateway that support multiple IM protocols"
-HOMEPAGE="http://www.bitlbee.org/"
+HOMEPAGE="https://www.bitlbee.org/"
LICENSE="GPL-2"
SLOT="0"
@@ -41,7 +41,7 @@ COMMON_DEPEND="
!libressl? ( dev-libs/openssl:0= )
)
)
- "
+"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
selinux? ( sec-policy/selinux-bitlbee )
@@ -57,7 +57,12 @@ pkg_setup() {
}
src_prepare() {
- [[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${P}-systemd-user.patch
+ if [[ ${PV} != "9999" ]]; then
+ eapply \
+ "${FILESDIR}"/${P}-systemd-user.patch \
+ "${FILESDIR}"/${P}-verbose-build.patch
+ fi
+
eapply_user
}
@@ -112,6 +117,7 @@ src_configure() {
--systemdsystemunitdir=$(systemd_get_systemunitdir) \
--doc=1 \
--strip=0 \
+ --verbose=1 \
"${myconf[@]}" || die
sed -i \
@@ -119,6 +125,10 @@ src_configure() {
Makefile.settings || die
}
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)"
+}
+
src_install() {
emake DESTDIR="${D}" install install-etc install-doc install-dev install-systemd