summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/choqok
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/choqok')
-rw-r--r--net-im/choqok/Manifest1
-rw-r--r--net-im/choqok/choqok-1.5.ebuild48
-rw-r--r--net-im/choqok/metadata.xml11
3 files changed, 60 insertions, 0 deletions
diff --git a/net-im/choqok/Manifest b/net-im/choqok/Manifest
new file mode 100644
index 000000000000..de6e26fd8e2a
--- /dev/null
+++ b/net-im/choqok/Manifest
@@ -0,0 +1 @@
+DIST choqok-1.5.tar.xz 1068516 SHA256 5cb97ac4cdf9db4699bb7445a9411393073d213fea649ab0713f659f1308efe4 SHA512 fbb31abedd07ea1c674a7d59b4a18808ca03812ac37c60ea67d2d641668be4a9137e9f4573eda1e19425123601e9536971170e3948c1e5098b220991571a2cf3 WHIRLPOOL c4f869bab6a23a2ffa2e8e071414a6c7170816269e6e9f77df4269b94b627248fd259eb3c24217a2a838f74162ba6c198ff5549371b61f516fb142b8690cdce0
diff --git a/net-im/choqok/choqok-1.5.ebuild b/net-im/choqok/choqok-1.5.ebuild
new file mode 100644
index 000000000000..e26f35e3cde9
--- /dev/null
+++ b/net-im/choqok/choqok-1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fa fi fr ga gl
+hr hu is it ja km lt mr ms nb nds nl pa pl pt pt_BR ro ru sk sl sq sv tr ug
+uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Free/Open Source micro-blogging client for KDE"
+HOMEPAGE="http://choqok.gnufolks.org/"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="amd64 ~ppc x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+IUSE="ayatana debug telepathy"
+
+RDEPEND="
+ dev-libs/libattica
+ dev-libs/qjson
+ >=dev-libs/qoauth-1.0.1
+ ayatana? ( dev-libs/libindicate-qt )
+ telepathy? ( net-libs/telepathy-qt[qt4] )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS README TODO changelog )
+
+src_prepare(){
+ local mycmakeargs=(
+ $(cmake-utils_use !ayatana QTINDICATE_DISABLE)
+ $(cmake-utils_use_find_package telepathy TelepathyQt4)
+ )
+
+ kde4-base_src_prepare
+}
diff --git a/net-im/choqok/metadata.xml b/net-im/choqok/metadata.xml
new file mode 100644
index 000000000000..4ccecd71210f
--- /dev/null
+++ b/net-im/choqok/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="telepathy">Enable support for the real-time communication framework telepathy</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">choqok</remote-id>
+ </upstream>
+</pkgmetadata>