summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-04-24 21:00:03 +0200
committerUlrich Müller <ulm@gentoo.org>2017-04-24 21:01:48 +0200
commit53b929fa6e8cad9c94cd8c3e684eeb510f25a29c (patch)
treee5acf8ad09a1c6ebf522a787e7823216fec9816f /net-im/openmittsu/openmittsu-0.9.2.106.ebuild
parentsys-cluster/gasnet: don't build ibv backend (bug #616514) (diff)
downloadgentoo-53b929fa6e8cad9c94cd8c3e684eeb510f25a29c.tar.gz
gentoo-53b929fa6e8cad9c94cd8c3e684eeb510f25a29c.tar.bz2
gentoo-53b929fa6e8cad9c94cd8c3e684eeb510f25a29c.zip
net-im/openmittsu: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-im/openmittsu/openmittsu-0.9.2.106.ebuild')
-rw-r--r--net-im/openmittsu/openmittsu-0.9.2.106.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-im/openmittsu/openmittsu-0.9.2.106.ebuild b/net-im/openmittsu/openmittsu-0.9.2.106.ebuild
new file mode 100644
index 000000000000..14478f6de9ab
--- /dev/null
+++ b/net-im/openmittsu/openmittsu-0.9.2.106.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils
+
+DESCRIPTION="An open source chat client for Threema-style end-to-end encrypted chat networks"
+HOMEPAGE="https://www.openmittsu.de/"
+# git-archive-all.sh snapshot of https://github.com/blizzard4591/openMittsu.git
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-libs/libsodium-1.0.11:=
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtgui-5.7.1:5=
+ >=dev-qt/qtmultimedia-5.7.1:5=
+ >=dev-qt/qtnetwork-5.7.1:5=
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]
+ >=dev-qt/qtwidgets-5.7.1:5=
+ >=media-gfx/qrencode-3.4.4-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}"/${PN}-cxx14.patch)
+
+DOCS=(
+ README.md
+ Example-client-configuration-file.ini
+ Example-contacts-file.txt
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # set version manually, since autodetection works only with git
+ "-DOPENMITTSU_CUSTOM_VERSION_STRING=${PV%.*}-${PV##*.}-00000000"
+ "-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ local my_pn="openMittsu"
+ cmake-utils_src_install
+ newicon resources/icon.png ${my_pn}.png
+ make_desktop_entry ${my_pn} ${my_pn} ${my_pn}
+ rm "${ED}"/usr/bin/${my_pn}VersionInfo || die
+}