summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-18 09:49:25 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-18 09:49:25 -0600
commitacfdb643c375bdd99768a8b66fea8116d87e2b62 (patch)
tree2686b208e3e4e151e048c4eba8931a78bda8498e /net-im/slack-bin
parentnet-wireless/unifi: fix subslot on 5.10 series, and drop old (diff)
downloadgentoo-acfdb643c375bdd99768a8b66fea8116d87e2b62.tar.gz
gentoo-acfdb643c375bdd99768a8b66fea8116d87e2b62.tar.bz2
gentoo-acfdb643c375bdd99768a8b66fea8116d87e2b62.zip
net-im/slack-bin: 3.3.7 bump
more glibc fixes? (release notes may have some duplication) Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-im/slack-bin')
-rw-r--r--net-im/slack-bin/Manifest1
-rw-r--r--net-im/slack-bin/slack-bin-3.3.7.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-im/slack-bin/Manifest b/net-im/slack-bin/Manifest
index 7f5370b0fdf5..dbb410224739 100644
--- a/net-im/slack-bin/Manifest
+++ b/net-im/slack-bin/Manifest
@@ -4,3 +4,4 @@ DIST slack-desktop-3.1.1-amd64.deb 60320286 BLAKE2B 3054e8283b41d5b8b45323131b2a
DIST slack-desktop-3.3.1-amd64.deb 54172074 BLAKE2B 88402ce58e02e20a2c5a90358b979bb4acc0409eb32da87a517ebd8631be88e716033d3047a98462c50e8d31f177bae9bfe3e25404a7d3add320c157b381569b SHA512 9b284ba60c1a9dd9fbd489d34438dc343b5cf6d458ef7968a2d7bd65514f24c9a21f0824771ebffbf23c877fc191be19602e62ac5bcf8543e78156ba95c575f6
DIST slack-desktop-3.3.3-amd64.deb 54203216 BLAKE2B 93f72a2a7ead75682b9ef9bd9f9b5ec19a5954d20e4ef3da214154eb53fd21533fac4e07893d883b7f9a51fd3af4e53f4b7102a0bee060d23f98b15bbc9207e9 SHA512 bb773ddc9cb13f520143412f73d47e308410d861fa63ca13a986d2c390900c59827b2cca6c55175a2778b341c534b0aab49841a4506f63d11359cada57473b67
DIST slack-desktop-3.3.4-amd64.deb 56404428 BLAKE2B 15e39e88f287a296f3f11a15f35602d2103263b2886f037674e4b8fc0f7b533980ab835de3862a92434b63eb0a466f1f6ee4db4e41026e2c609d6e52dd392463 SHA512 1c2f889ed6194191adf8892bb288ee2e53476b78bc7dbb48c9e5c516f010e47b486059ab1dad87ff41e747e74a10a43398027dfb3cb971103e70f00f58e6bd4c
+DIST slack-desktop-3.3.7-amd64.deb 56596720 BLAKE2B d463172b6528a98366b61b2e23c0bbfb8f7285387f7c0815b28977602f1b05954f1a89cae0ecf127acd79b771655ea5c7551bb0d7207b07b0e7790886c21e7d6 SHA512 b61f32a7f9ee4c40c10dbc70e0ab1c4371fd63610217348b2177c48f9ec17500e34ca5a09f38812543b62fd888cbc0344ad258d37d0b570fa91e4c262451e18a
diff --git a/net-im/slack-bin/slack-bin-3.3.7.ebuild b/net-im/slack-bin/slack-bin-3.3.7.ebuild
new file mode 100644
index 000000000000..b9d292138549
--- /dev/null
+++ b/net-im/slack-bin/slack-bin-3.3.7.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop gnome2-utils multilib-build pax-utils unpacker xdg-utils
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="http://www.slack.com/"
+SRC_URI="https://downloads.slack-edge.com/linux_releases/${MY_PN}-desktop-${PV}-amd64.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="ayatana gnome-keyring pax_kernel"
+RESTRICT="bindist mirror"
+
+RDEPEND="dev-libs/atk:0[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ gnome-base/gconf:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ net-misc/curl:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libXi:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrender:0[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver:0[${MULTILIB_USEDEP}]
+ x11-libs/libXtst:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]
+ ayatana? ( dev-libs/libappindicator:3[${MULTILIB_USEDEP}] )
+ gnome-keyring? ( app-crypt/libsecret:0[${MULTILIB_USEDEP}] )"
+
+QA_PREBUILT="opt/slack/slack
+ opt/slack/resources/app.asar.unpacked/node_modules/*
+ opt/slack/libnode.so
+ opt/slack/libffmpeg.so
+ opt/slack/libCallsCore.so"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ if use ayatana ; then
+ sed -i '/Exec/s|=|=env XDG_CURRENT_DESKTOP=Unity |' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for slack.desktop"
+ fi
+}
+
+src_install() {
+ doicon usr/share/pixmaps/slack.png
+ doicon -s 512 usr/share/pixmaps/slack.png
+ domenu usr/share/applications/slack.desktop
+
+ insinto /opt/slack
+ doins -r usr/lib/slack/.
+ fperms +x /opt/slack/slack
+ dosym ../../opt/slack/slack usr/bin/slack
+
+ use pax_kernel && pax-mark -m "${ED%/}"/opt/slack/slack
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}