summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-02 11:12:31 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-02 11:14:28 -0800
commit9486b04d33201e1b0b03d88e24838336ee0fe046 (patch)
tree99017c23d92d82bf7a2e316f998e6e78121be076 /net-im/telegram-desktop
parentwww-plugins/chrome-binary-plugins: automated update (86.0.4240.183) (diff)
downloadgentoo-9486b04d33201e1b0b03d88e24838336ee0fe046.tar.gz
gentoo-9486b04d33201e1b0b03d88e24838336ee0fe046.tar.bz2
gentoo-9486b04d33201e1b0b03d88e24838336ee0fe046.zip
net-im/telegram-desktop: bump to 2.4.6
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im/telegram-desktop')
-rw-r--r--net-im/telegram-desktop/Manifest1
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.4.6.ebuild169
2 files changed, 170 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index 1e06d771c941..dc22cd7ef09a 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,3 +1,4 @@
DIST tdesktop-2.1.13-full.tar.gz 36549505 BLAKE2B 48514be8add4ad4491c8e81a868f140228787ee489de7cd90faf31dbee959b0fb87cf2c844bf98c5b62fd6de8e32f504a6d19b071c56e6a4c0cd489d7b283818 SHA512 f28ae7c8c9a9eb8094fc52784742b470235234a3df7487902152858bc7c297b2dcfe5c8b939cdb9653a356b3835609e7289f53cdf7d5fb3f009823d3dbeb1bd8
DIST tdesktop-2.2.0-full.tar.gz 36612169 BLAKE2B dcc9d81da5d99552bea3139d595c7f1aca75464a19be34c880a93d27ddd8a58a01510efe8fde31104b13d50e34e944b05406e21bc96995e85cb95283ff8de08a SHA512 2aeca83be7bc385bd7537d56ecf66996facedd0af588e743fedbb08c3158fc76436d6cf3b1fb5dd7c8d37b4471f739872ca54ba300aa1d0e0202e87c005703fd
DIST tdesktop-2.4.5-full.tar.gz 36354189 BLAKE2B cdf31b5bc1c90e0714fe648929ee18aed29c3ff2b5e6f9dc96b4e9741267aae092415fd1b304a54b98e462a90375f8087d727d067b4865c7a8b3a89a68a59189 SHA512 d0c792fcd890a95b24233f37cdfc34008e814f6f0730722a41916e25d2efff405fd472bd6b45bbfc79787ed117dc5f87271c438d92ec1ce29335cabe76a1062e
+DIST tdesktop-2.4.6-full.tar.gz 36355592 BLAKE2B 9481158301cec5518182da9cf9739d82126aa2d0941d51eee840d94bc7b561103d6e65439347f6b15ce17970f68e335f177126db0a7fdf81ac6e668f14a3e3db SHA512 922b9d00a90866899c2817aaa24273b2ac8525bb18543598c8f203846d2e2e3849485cfcbce081d4dfbd45ebafe40dd57434f08849781a4f1d011b3518d03a6b
diff --git a/net-im/telegram-desktop/telegram-desktop-2.4.6.ebuild b/net-im/telegram-desktop/telegram-desktop-2.4.6.ebuild
new file mode 100644
index 000000000000..28d77efd6cf8
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-2.4.6.ebuild
@@ -0,0 +1,169 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit cmake desktop flag-o-matic ninja-utils python-any-r1 xdg-utils
+
+MY_P="tdesktop-${PV}-full"
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="+dbus enchant +gtk +hunspell libressl lto pulseaudio +spell +webrtc +X"
+
+RDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ app-arch/xz-utils
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ dev-libs/xxhash
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[dbus?,jpeg,png,wayland,X(-)?]
+ dev-qt/qtimageformats:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5[png,X(-)?]
+ media-fonts/open-sans
+ media-libs/alsa-lib
+ media-libs/fontconfig:=
+ ~media-libs/libtgvoip-2.4.4_p20201030[pulseaudio=]
+ media-libs/openal[alsa]
+ media-libs/opus:=
+ media-video/ffmpeg:=[alsa,opus]
+ sys-libs/zlib[minizip]
+ virtual/libiconv
+ x11-libs/libxcb:=
+ dbus? (
+ dev-qt/qtdbus:5
+ dev-libs/libdbusmenu-qt[qt5(+)]
+ )
+ enchant? ( app-text/enchant:= )
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2[jpeg,X?]
+ x11-libs/gtk+:3[X?]
+ x11-libs/libX11
+ )
+ hunspell? ( >=app-text/hunspell-1.7:= )
+ !pulseaudio? ( media-sound/apulse[sdk] )
+ pulseaudio? ( media-sound/pulseaudio )
+ webrtc? (
+ media-libs/libjpeg-turbo:=
+ ~media-libs/tg_owt-0_pre20201030[pulseaudio=]
+ )
+"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+ dev-cpp/range-v3
+ =dev-cpp/ms-gsl-3*
+"
+
+BDEPEND="
+ >=dev-util/cmake-3.16
+ virtual/pkgconfig
+ amd64? ( dev-lang/yasm )
+"
+
+REQUIRED_USE="
+ spell? (
+ ^^ ( enchant hunspell )
+ )
+ webrtc? ( !libressl )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # conditional patching is bad, but we want vanilla telegram with webrtc.
+ use webrtc || local PATCHES=( "${FILESDIR}/no-webrtc-build.patch" )
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycxxflags=(
+ -Wno-deprecated-declarations
+ -Wno-error=deprecated-declarations
+ -Wno-switch
+ -Wno-unknown-warning-option
+ )
+
+ append-cxxflags "${mycxxflags[@]}"
+
+ # TODO: unbundle header-only libs, ofc telegram uses git versions...
+ # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
+ # EXPECTED VARIANT
+ # gtk is really needed for image copy-paste due to https://bugreports.qt.io/browse/QTBUG-56595
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_rlottie=ON # it does not build with system one, prevent automagic.
+ -DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON # header only lib, some git version. prevents warnings.
+ -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
+ -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
+ -DDESKTOP_APP_USE_PACKAGED=ON
+ -DDESKTOP_APP_USE_PACKAGED_FONTS=ON
+ -DTDESKTOP_DISABLE_GTK_INTEGRATION="$(usex gtk OFF ON)"
+ -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
+ -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
+ -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)" # enables hunspell (recommended)
+ -DDESKTOP_APP_DISABLE_WEBRTC_INTEGRATION="$(usex webrtc OFF ON)"
+ -DDESKTOP_APP_USE_ENCHANT="$(usex enchant ON OFF)" # enables enchant and disables hunspell
+ $(usex lto "-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON" '')
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ use gtk || einfo "enable 'gtk' useflag if you have image copy-paste problems"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}