summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2017-09-28 15:07:43 -0700
committerDaniel Campbell <zlg@gentoo.org>2017-09-28 15:07:43 -0700
commit675810158cfecff172c501b898ff379db0051af3 (patch)
treefbab8040ef5adff31c86270759bca718873fb100 /net-im/toxic
parentnet-analyzer/wireshark: Stable for HPPA too. (diff)
downloadgentoo-675810158cfecff172c501b898ff379db0051af3.tar.gz
gentoo-675810158cfecff172c501b898ff379db0051af3.tar.bz2
gentoo-675810158cfecff172c501b898ff379db0051af3.zip
net-im/toxic: correct version string in package
Upstream's first commit after the Release fixes this. This is a quick fix that will need to be removed for the next version bump, assuming upstream remembers to update the string before tagging a release. No input or review was received for over two weeks, leaving me with little choice but to push, as it works for me. Thanks to Dennis New for reporting. Closes: https://bugs.gentoo.org/630370 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/toxic-0.8.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/net-im/toxic/toxic-0.8.0.ebuild b/net-im/toxic/toxic-0.8.0.ebuild
index c8827675bcf8..4758d0bbde4b 100644
--- a/net-im/toxic/toxic-0.8.0.ebuild
+++ b/net-im/toxic/toxic-0.8.0.ebuild
@@ -35,6 +35,15 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
}
+src_prepare() {
+ default
+ # bug 630370: version string correction 0.7.2 -> 0.8.0
+ # REMOVE THIS FOR toxic != 0.8.0
+ sed -i \
+ -e 's/^\(TOXIC_VERSION =\).*$/\1 0.8.0/' \
+ cfg/global_vars.mk || die "Version string correction failed."
+}
+
src_configure() {
if ! use av; then
export DISABLE_AV=1