summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2016-10-28 00:58:46 -0700
committerDaniel Campbell <zlg@gentoo.org>2016-10-28 00:58:46 -0700
commit93f1ff22265f65a700fd788b3a5b0c3b27c41fbf (patch)
tree2479f0f09a65043e6a1da274efc130569aff580e /net-im/toxic
parentmedia-video/smtube: version bump (diff)
downloadgentoo-93f1ff22265f65a700fd788b3a5b0c3b27c41fbf.tar.gz
gentoo-93f1ff22265f65a700fd788b3a5b0c3b27c41fbf.tar.bz2
gentoo-93f1ff22265f65a700fd788b3a5b0c3b27c41fbf.zip
net-im/toxic: new package
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/Manifest1
-rw-r--r--net-im/toxic/metadata.xml22
-rw-r--r--net-im/toxic/toxic-0.7.1.ebuild48
3 files changed, 71 insertions, 0 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
new file mode 100644
index 000000000000..ecea0ac23e50
--- /dev/null
+++ b/net-im/toxic/Manifest
@@ -0,0 +1 @@
+DIST toxic-0.7.1.tar.gz 1137112 SHA256 414ca2cd369e277872c7248c43f82afa0ac2f6c8fa5fc8e93f7c3e8ab6d11b9c SHA512 c304b07a67ed27a25394590eb8759b5dd957605be4eb9e64590d4580da0977e1cd201e8b95ae1b31e995772560510ceb0643028696e2df69e1f5d0dff575b553 WHIRLPOOL 228193bb78bf38bd5f5f5ff371a87f12561edcb5729337b58198df36e5ec55b99f2c2ca84f5b471846e7f84445f1c5181c5fa71ff287f62d5e34f833a45747d6
diff --git a/net-im/toxic/metadata.xml b/net-im/toxic/metadata.xml
new file mode 100644
index 000000000000..4032c8812a4f
--- /dev/null
+++ b/net-im/toxic/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zlg@gentoo.org</email>
+ <name>Daniel Campbell</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>jfreegman@tox.chat</email>
+ <name>JFreegman</name>
+ </maintainer>
+ <remote-id type="github">jfreegman/toxic</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ An ncurses-based Tox client written in C. Supports audio calling, file sharing, and desktop notifications.
+ </longdescription>
+ <use>
+ <flag name="notifications">Enables desktop notifications with libnotify</flag>
+ <flag name="av">Enables audio calling and/or audio notifications</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-im/toxic/toxic-0.7.1.ebuild b/net-im/toxic/toxic-0.7.1.ebuild
new file mode 100644
index 000000000000..f4e6509f0b00
--- /dev/null
+++ b/net-im/toxic/toxic-0.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A curses-based client for Tox."
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X +av notifications"
+
+RDEPEND="
+ net-libs/tox[av?]
+ dev-libs/libconfig
+ media-gfx/qrencode
+ net-misc/curl
+ sys-libs/ncurses:0=
+ av? ( media-libs/openal media-libs/freealut )
+ notifications? ( x11-libs/libnotify )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ if ! use av; then
+ export DISABLE_AV=1
+ export DISABLE_SOUND_NOTIFY=1
+ fi
+ if ! use X; then
+ export DISABLE_X11=1
+ fi
+ if ! use notifications; then
+ export DISABLE_DESKTOP_NOTIFY=1
+ fi
+ sed -i \
+ -e "s,/usr/local,${EPREFIX}/usr,g" \
+ cfg/global_vars.mk || die "PREFIX sed failed"
+}
+
+src_install() {
+ default
+ if ! use av; then
+ rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sound dir"
+ fi
+}