summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-28 14:21:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-16 20:29:13 +0100
commitdb033dd933f18541081407d66ea3af478ce82613 (patch)
treeee9faf3a6a9e8dd4d21137b73c5ad21dcb139e37 /net-im/yowsup
parentapp-benchmarks/stress-ng: drop old version (diff)
downloadgentoo-db033dd933f18541081407d66ea3af478ce82613.tar.gz
gentoo-db033dd933f18541081407d66ea3af478ce82613.tar.bz2
gentoo-db033dd933f18541081407d66ea3af478ce82613.zip
net-im/yowsup: bump to EAPI=7
Also changed order of metadata.xml. Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10263 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im/yowsup')
-rw-r--r--net-im/yowsup/metadata.xml8
-rw-r--r--net-im/yowsup/yowsup-2.5.7-r1.ebuild31
2 files changed, 35 insertions, 4 deletions
diff --git a/net-im/yowsup/metadata.xml b/net-im/yowsup/metadata.xml
index dc32909be69f..8494fa26c3e1 100644
--- a/net-im/yowsup/metadata.xml
+++ b/net-im/yowsup/metadata.xml
@@ -9,10 +9,6 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
- <upstream>
- <bugs-to>https://github.com/tgalal/yowsup/issues</bugs-to>
- <remote-id type="github">tgalal/yowsup</remote-id>
- </upstream>
<longdescription>
Yowsup is a Python library that enables you to build applications,
which use the WhatsApp service. Yowsup has been used to create two clients:
@@ -20,4 +16,8 @@
which was in use by more than 200K users.
2) Another fully featured unofficial client for Blackberry 10.
</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/tgalal/yowsup/issues</bugs-to>
+ <remote-id type="github">tgalal/yowsup</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-im/yowsup/yowsup-2.5.7-r1.ebuild b/net-im/yowsup/yowsup-2.5.7-r1.ebuild
new file mode 100644
index 000000000000..7c53464c30fc
--- /dev/null
+++ b/net-im/yowsup/yowsup-2.5.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="readline"
+
+inherit distutils-r1
+
+DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
+HOMEPAGE="https://github.com/tgalal/yowsup"
+SRC_URI="https://github.com/tgalal/yowsup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/python-axolotl-curve25519[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/fix_newer_six_version.patch" )