summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-07-08 00:09:43 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 09:30:48 +0100
commitfd508becba0b70ce9d11b04a57196e413a67d57a (patch)
tree7a380a895163246c578b87b372619378f06dc370 /net-im/yowsup
parentx11-misc/mugshot: New package (diff)
downloadgentoo-fd508becba0b70ce9d11b04a57196e413a67d57a.tar.gz
gentoo-fd508becba0b70ce9d11b04a57196e413a67d57a.tar.bz2
gentoo-fd508becba0b70ce9d11b04a57196e413a67d57a.zip
net-im/yowsup: New package
Closes: https://bugs.gentoo.org/652258 Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9102 Closes: https://bugs.gentoo.org/652258
Diffstat (limited to 'net-im/yowsup')
-rw-r--r--net-im/yowsup/Manifest1
-rw-r--r--net-im/yowsup/files/fix_newer_six_version.patch30
-rw-r--r--net-im/yowsup/metadata.xml23
-rw-r--r--net-im/yowsup/yowsup-2.5.7.ebuild29
4 files changed, 83 insertions, 0 deletions
diff --git a/net-im/yowsup/Manifest b/net-im/yowsup/Manifest
new file mode 100644
index 000000000000..e767fd6b5198
--- /dev/null
+++ b/net-im/yowsup/Manifest
@@ -0,0 +1 @@
+DIST yowsup-2.5.7.tar.gz 125732 BLAKE2B 31896cfef601bfe4b65df3518ce6812ad66a98902ec7c8ca5b2ffda15c48c9390010fce58e1158f6ddc325911fd78d1be2bc708d499ab11b725835c5cd5ea246 SHA512 e64e119e8301d6cd9244a24ce960fdd00a5372a7766cf2f52dfd7610828358086e6c4f77fba6f962c1b84f6b28fa6b6d4d708bbb50c281e5a6563b99634b9495
diff --git a/net-im/yowsup/files/fix_newer_six_version.patch b/net-im/yowsup/files/fix_newer_six_version.patch
new file mode 100644
index 000000000000..d1bfb27ce295
--- /dev/null
+++ b/net-im/yowsup/files/fix_newer_six_version.patch
@@ -0,0 +1,30 @@
+--- a/setup.py 2017-12-30 00:12:35.000000000 +0100
++++ b/setup.py 2018-04-29 20:51:23.000000000 +0200
+@@ -5,7 +5,7 @@
+ import platform
+ import sys
+
+-deps = ['python-dateutil', 'argparse', 'python-axolotl>=0.1.39', 'six==1.10']
++deps = ['python-dateutil', 'python-axolotl>=0.1.39', 'six']
+
+ if sys.version_info < (2,7):
+ deps += ['importlib', "protobuf==3.4.0"]
+--- a/yowsup/env/env.py 2017-12-30 00:12:35.000000000 +0100
++++ b/yowsup/env/env.py 2018-04-29 20:51:44.000000000 +0200
+@@ -13,7 +13,6 @@
+ super(YowsupEnvType, cls).__init__(name, bases, dct)
+
+ class YowsupEnv(with_metaclass(YowsupEnvType, object)):
+- __metaclass__ = YowsupEnvType
+ __ENVS = {}
+ __CURR = None
+
+--- a/yowsup/layers/protocol_media/picture.py 2017-12-30 00:12:35.000000000 +0100
++++ b/yowsup/layers/protocol_media/picture.py 2018-04-29 20:52:30.000000000 +0200
+@@ -1,5 +1,5 @@
+ from yowsup.layers import YowLayer
+-from yowsup import ProtocolTreeNode
++from yowsup.structs import ProtocolTreeNode
+ from .mediadownloader import MediaDownloader
+ import shutil, os, logging
+ logger = logging.getLogger(__name__)
diff --git a/net-im/yowsup/metadata.xml b/net-im/yowsup/metadata.xml
new file mode 100644
index 000000000000..dc32909be69f
--- /dev/null
+++ b/net-im/yowsup/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/tgalal/yowsup/issues</bugs-to>
+ <remote-id type="github">tgalal/yowsup</remote-id>
+ </upstream>
+ <longdescription>
+ Yowsup is a Python library that enables you to build applications,
+ which use the WhatsApp service. Yowsup has been used to create two clients:
+ 1) An unofficial WhatsApp client Nokia N9 through the Wazapp project
+ which was in use by more than 200K users.
+ 2) Another fully featured unofficial client for Blackberry 10.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-im/yowsup/yowsup-2.5.7.ebuild b/net-im/yowsup/yowsup-2.5.7.ebuild
new file mode 100644
index 000000000000..862206fd28dd
--- /dev/null
+++ b/net-im/yowsup/yowsup-2.5.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="readline"
+
+inherit distutils-r1
+
+DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
+HOMEPAGE="https://github.com/tgalal/yowsup"
+SRC_URI="https://github.com/tgalal/yowsup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/python-axolotl-curve25519[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/fix_newer_six_version.patch" )