summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-02 16:48:09 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-02 17:21:47 -0500
commit867818b4326f4f77344ec8c26d50232a9b82e740 (patch)
treea294f3e5b0e647d9a376e0e6d1e63e1bade7a80f /net-im
parentnet-mail/courier-imap: remove old ebuilds (diff)
downloadgentoo-867818b4326f4f77344ec8c26d50232a9b82e740.tar.gz
gentoo-867818b4326f4f77344ec8c26d50232a9b82e740.tar.bz2
gentoo-867818b4326f4f77344ec8c26d50232a9b82e740.zip
net-im/reaim: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-im')
-rw-r--r--net-im/reaim/files/reaim4
-rw-r--r--net-im/reaim/reaim-0.8-r2.ebuild37
2 files changed, 39 insertions, 2 deletions
diff --git a/net-im/reaim/files/reaim b/net-im/reaim/files/reaim
index f10cd7edcab4..71bafae11136 100644
--- a/net-im/reaim/files/reaim
+++ b/net-im/reaim/files/reaim
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-im/reaim/reaim-0.8-r2.ebuild b/net-im/reaim/reaim-0.8-r2.ebuild
new file mode 100644
index 000000000000..778f9c2f6421
--- /dev/null
+++ b/net-im/reaim/reaim-0.8-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="AIM transport proxy over NAT firewalls"
+HOMEPAGE="http://reaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/reaim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="net-firewall/iptables"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e 's/gcc/$(CC) $(CFLAGS) $(LDFLAGS)/' \
+ -e 's/ -g / /' Makefile || die "sed failed" #365863
+ default
+}
+
+src_install() {
+ local HTML_DOCS=( html )
+ einstalldocs
+ doman reaim.8
+ dosbin reaim
+ doinitd "${FILESDIR}"/reaim
+}