summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.bugzilla.2012@r123.de>2018-02-27 10:03:56 +0100
committerAmy Liffey <amynka@gentoo.org>2018-03-01 09:48:53 +0100
commit8eec5778e51bb73919915f20989746ec4b00f08b (patch)
tree8b417deb216bc4c629e767571e4597abd610ec6a /net-im
parentdev-java/zemberek: Dekeyword *-fbsd (diff)
downloadgentoo-8eec5778e51bb73919915f20989746ec4b00f08b.tar.gz
gentoo-8eec5778e51bb73919915f20989746ec4b00f08b.tar.bz2
gentoo-8eec5778e51bb73919915f20989746ec4b00f08b.zip
net-im/signal-desktop-bin: new version 1.5.0
Diffstat (limited to 'net-im')
-rw-r--r--net-im/signal-desktop-bin/Manifest1
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-1.5.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
index dd205f3b2edd..839707749519 100644
--- a/net-im/signal-desktop-bin/Manifest
+++ b/net-im/signal-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST signal-desktop_1.3.0_amd64.deb 65763880 BLAKE2B 2bea33c5792d3f66066314dd6d36a0f639c0e75f5c1a86ac1d7f95dd7f3047c93b56f000f29a3cfb234ab1cbf03ccccd1a801fad02176a243ebebeaf110bb163 SHA512 3dd3b1457fe584f90a70aae4bea07e1cc111d43d93d382d966b912d8e10ad18858521550dbe4588c6075a0c64f2a6eda938dbc92c684f4f305776d4e83d27131
+DIST signal-desktop_1.5.0_amd64.deb 65858954 BLAKE2B 60234d1cb98dd233ffc769c93bafd509ffc40eaf34cc76c3e8dfa8de1229a05e1f29291b1a57212163588a53990b1c24c1ba29486429ad63c0424049b79384c5 SHA512 36bcf67c5815bf4f001649f0bfe2a01217415fbc4b63688026ec5aba946a8a3df7e08021aa4255590fdc5820bdcd9e2d43b42798e7d8c5eb0186c351f9b10780
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-1.5.0.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-1.5.0.ebuild
new file mode 100644
index 000000000000..49c5f56fefba
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-1.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+
+inherit gnome2-utils unpacker xdg-utils pax-utils
+
+DESCRIPTION="Signal Desktop"
+HOMEPAGE="https://signal.org/ https://github.com/WhisperSystems/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/main/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ayatana"
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ gnome-base/gconf:2
+ dev-libs/nss
+ x11-libs/libXtst
+ net-print/cups
+ ayatana? ( dev-libs/libappindicator:3 )
+ "
+
+QA_PREBUILT="opt/Signal/signal-desktop
+ opt/Signal/libnode.so
+ opt/Signal/libffmpeg.so"
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+ fperms +x /opt/Signal/signal-desktop
+ pax-mark m opt/Signal/signal-desktop
+
+ dosym ../../opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}