summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-19 16:47:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-21 19:55:20 +0100
commite02b71c5a95c6cfb13247574b531bb4442c3dba9 (patch)
tree1a52153f784129ba0b2503c006b8791597005456 /net-im
parentnet-libs/nodejs: Remove -O3 injection in deps/v8 (bug #594638 by Jan Chren (r... (diff)
downloadgentoo-e02b71c5a95c6cfb13247574b531bb4442c3dba9.tar.gz
gentoo-e02b71c5a95c6cfb13247574b531bb4442c3dba9.tar.bz2
gentoo-e02b71c5a95c6cfb13247574b531bb4442c3dba9.zip
profiles: Remove last-rited packages
Closes: https://bugs.gentoo.org/634386 Closes: https://bugs.gentoo.org/634382 Closes: https://bugs.gentoo.org/634388 Closes: https://bugs.gentoo.org/634384 Closes: https://bugs.gentoo.org/579518 Closes: https://bugs.gentoo.org/623928
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutim/Manifest1
-rw-r--r--net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch151
-rw-r--r--net-im/qutim/files/qutim-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch26
-rw-r--r--net-im/qutim/metadata.xml42
-rw-r--r--net-im/qutim/qutim-0.3.3_p1.ebuild170
5 files changed, 0 insertions, 390 deletions
diff --git a/net-im/qutim/Manifest b/net-im/qutim/Manifest
deleted file mode 100644
index a1bb80a3f073..000000000000
--- a/net-im/qutim/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST qutim-0.3.3.p_1.tar.xz 8708952 SHA256 945dc03d25ccd985b8c0d0d4ef2c98e3731428135c60df4a0deaf9c9b1a8f2e3 SHA512 658c0d114a6771cd7ae9f3090e6ab6deba8e92465b9cd966d7ab4d4626dbb7335a712d7c0f64c886d7bcb7a3fbcd0b18398946a366ec1e150a9e2ae5e4e638e9 WHIRLPOOL 05c3360134fd41f8dabad232cef42db2222f1973bee32dcf02d1784634b6c0163066f739c15c7ad1b46af9a8f9b0d90b9e4e9cf79f72f6f754af2f50b95f8d5c
diff --git a/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch b/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch
deleted file mode 100644
index dd1aba82891c..000000000000
--- a/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch
+++ /dev/null
@@ -1,151 +0,0 @@
-From bb8654db870d983d5b6558d9f16b22f443315eaf Mon Sep 17 00:00:00 2001
-From: Alexander Golubev <fatzer2@gmail.com>
-Date: Mon, 3 Nov 2014 16:30:27 +0300
-Subject: [PATCH 3/3] protocol/astral: migrate to qt-telepaphy API v0.9
-
----
- protocols/astral/src/astralaccount.cpp | 12 ++++++------
- protocols/astral/src/astralaccount.h | 14 +++++++-------
- protocols/astral/src/astralcontact.h | 6 +++---
- protocols/astral/src/astralplugin.cpp | 6 +++---
- protocols/astral/src/astralroster.cpp | 14 +++++++-------
- protocols/astral/src/astralsession.h | 4 ++--
- 6 files changed, 28 insertions(+), 28 deletions(-)
-
-diff --git a/protocols/astral/src/astralaccount.cpp b/protocols/astral/src/astralaccount.cpp
-index 1d51707..e9bf729 100644
---- a/protocols/astral/src/astralaccount.cpp
-+++ b/protocols/astral/src/astralaccount.cpp
-@@ -26,9 +26,9 @@
- #include "astralprotocol.h"
- #include "astralroster.h"
- #include "astralsessionmanager.h"
--#include <TelepathyQt4/Account>
--#include <TelepathyQt4/AccountManager>
--#include <TelepathyQt4/PendingChannel>
-+#include <TelepathyQt/Account>
-+#include <TelepathyQt/AccountManager>
-+#include <TelepathyQt/PendingChannel>
- #include <QDebug>
-
- struct AstralAccountPrivate
-@@ -146,14 +146,14 @@ void AstralAccount::onNewChannels(const Tp::ChannelDetailsList &channels)
- qDebug() << "AstralAccount::onNewChannels";
- foreach (const Tp::ChannelDetails &details, channels)
- {
-- QString channelType = details.properties.value(QLatin1String(TELEPATHY_INTERFACE_CHANNEL ".ChannelType")).toString();
-- bool requested = details.properties.value(QLatin1String(TELEPATHY_INTERFACE_CHANNEL ".Requested")).toBool();
-+ QString channelType = details.properties.value(TP_QT_IFACE_CHANNEL + QLatin1String(".ChannelType")).toString();
-+ bool requested = details.properties.value(TP_QT_IFACE_CHANNEL + QLatin1String(".Requested")).toBool();
- qDebug() << " channelType:" << channelType;
- qDebug() << " requested :" << requested;
- qDebug() << " channelPath:" << details.channel.path();
- qDebug() << " properties :" << details.properties;
-
-- if (channelType == TELEPATHY_INTERFACE_CHANNEL_TYPE_TEXT && !requested)
-+ if (channelType == TP_QT_IFACE_CHANNEL_TYPE_TEXT && !requested)
- {
- TextChannelPtr channel = TextChannel::create(p->conn,
- details.channel.path(),
-diff --git a/protocols/astral/src/astralaccount.h b/protocols/astral/src/astralaccount.h
-index 2781fb9..6e4378d 100644
---- a/protocols/astral/src/astralaccount.h
-+++ b/protocols/astral/src/astralaccount.h
-@@ -26,13 +26,13 @@
- #define ASTRALACCOUNT_H
-
- #include <qutim/account.h>
--#include <TelepathyQt4/ConnectionManager>
--#include <TelepathyQt4/Connection>
--#include <TelepathyQt4/TextChannel>
--#include <TelepathyQt4/AccountManager>
--#include <TelepathyQt4/PendingConnection>
--#include <TelepathyQt4/PendingOperation>
--#include <TelepathyQt4/PendingReady>
-+#include <TelepathyQt/ConnectionManager>
-+#include <TelepathyQt/Connection>
-+#include <TelepathyQt/TextChannel>
-+#include <TelepathyQt/AccountManager>
-+#include <TelepathyQt/PendingConnection>
-+#include <TelepathyQt/PendingOperation>
-+#include <TelepathyQt/PendingReady>
-
- #include "astralroster.h"
-
-diff --git a/protocols/astral/src/astralcontact.h b/protocols/astral/src/astralcontact.h
-index ce0e9dd..5adfb07 100644
---- a/protocols/astral/src/astralcontact.h
-+++ b/protocols/astral/src/astralcontact.h
-@@ -26,9 +26,9 @@
- #define ASTRALCONTACT_H
-
- #include <qutim/contact.h>
--#include <TelepathyQt4/Types>
--#include <TelepathyQt4/Contact>
--#include <TelepathyQt4/Connection>
-+#include <TelepathyQt/Types>
-+#include <TelepathyQt/Contact>
-+#include <TelepathyQt/Connection>
-
- using namespace Tp;
- using namespace qutim_sdk_0_3;
-diff --git a/protocols/astral/src/astralplugin.cpp b/protocols/astral/src/astralplugin.cpp
-index e907866..d79642e 100644
---- a/protocols/astral/src/astralplugin.cpp
-+++ b/protocols/astral/src/astralplugin.cpp
-@@ -24,9 +24,9 @@
- ****************************************************************************/
- #include "astralplugin.h"
- #include <QtCore/QtDebug>
--#include <TelepathyQt4/Debug>
--#include <TelepathyQt4/Constants>
--#include <TelepathyQt4/Types>
-+#include <TelepathyQt/Debug>
-+#include <TelepathyQt/Constants>
-+#include <TelepathyQt/Types>
- //#include <TelepathyQt4/ConnectionInterfaceAvatarsInterface>
-
- AstralPlugin::AstralPlugin()
-diff --git a/protocols/astral/src/astralroster.cpp b/protocols/astral/src/astralroster.cpp
-index 9eb209f..588cc55 100644
---- a/protocols/astral/src/astralroster.cpp
-+++ b/protocols/astral/src/astralroster.cpp
-@@ -24,13 +24,13 @@
- ****************************************************************************/
- #include "astralroster.h"
- #include "astralaccount.h"
--#include <TelepathyQt4/Types>
--#include <TelepathyQt4/Contact>
--#include <TelepathyQt4/ContactManager>
--#include <TelepathyQt4/PendingConnection>
--#include <TelepathyQt4/PendingContacts>
--#include <TelepathyQt4/PendingOperation>
--#include <TelepathyQt4/PendingReady>
-+#include <TelepathyQt/Types>
-+#include <TelepathyQt/Contact>
-+#include <TelepathyQt/ContactManager>
-+#include <TelepathyQt/PendingConnection>
-+#include <TelepathyQt/PendingContacts>
-+#include <TelepathyQt/PendingOperation>
-+#include <TelepathyQt/PendingReady>
-
- struct AstralRosterPrivate
- {
-diff --git a/protocols/astral/src/astralsession.h b/protocols/astral/src/astralsession.h
-index fa78e45..a5dd1c3 100644
---- a/protocols/astral/src/astralsession.h
-+++ b/protocols/astral/src/astralsession.h
-@@ -26,8 +26,8 @@
- #define ASTRALSESSION_H
-
- #include <qutim/chatunit.h>
--#include <TelepathyQt4/TextChannel>
--#include <TelepathyQt4/Message>
-+#include <TelepathyQt/TextChannel>
-+#include <TelepathyQt/Message>
-
- using namespace qutim_sdk_0_3;
- using namespace Tp;
---
-2.0.4
-
diff --git a/net-im/qutim/files/qutim-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch b/net-im/qutim/files/qutim-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch
deleted file mode 100644
index 955fd0dc5e17..000000000000
--- a/net-im/qutim/files/qutim-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Fix issues caused by turning on -std=c++14 by default in gcc.6.1+.
-See Gentoo-Bug #623572.
-Upstream commit 7453ef49e8fb64b05cfe7b8c0622bf00eba3080f "Turned on -std=c++11 by default " does the same changes.
-
-diff --git a/protocols/irc/src/irccommandalias.cpp b/protocols/irc/src/irccommandalias.cpp
-index cfe8a620e..41282f15f 100644
---- a/protocols/irc/src/irccommandalias.cpp
-+++ b/protocols/irc/src/irccommandalias.cpp
-@@ -148,7 +148,7 @@ QString IrcPingAlias::generate(IrcCommandAlias::Type aliasType, const QStringLis
- }
-
- #define ADD_BAN_CMD(MODE, TYPE, NAME, TITLE, ADDITIONALCMD) \
-- cmd = new IrcCommandAlias(NAME, "MODE %n +b "MODE ADDITIONALCMD, IrcCommandAlias::Participant); \
-+ cmd = new IrcCommandAlias(NAME, "MODE %n +b " MODE ADDITIONALCMD, IrcCommandAlias::Participant); \
- gen = new IrcActionGenerator(QIcon(), TITLE, cmd); \
- gen->setType(TYPE); \
- MenuController::addAction<IrcChannelParticipant>(gen, kickBanGroup);
-@@ -172,7 +172,7 @@ QString IrcPingAlias::generate(IrcCommandAlias::Type aliasType, const QStringLis
- REGISTER_CTCP_CMD(TITLE)
-
- #define ADD_MODE(MODE, PRIORITY, NAME, TITLE)\
-- cmd = new IrcCommandAlias(NAME, "MODE %n "MODE" %o", IrcCommandAlias::Participant);\
-+ cmd = new IrcCommandAlias(NAME, "MODE %n " MODE " %o", IrcCommandAlias::Participant);\
- gen = new IrcActionGenerator(QIcon(), TITLE, cmd);\
- gen->setPriority(PRIORITY);\
- MenuController::addAction<IrcChannelParticipant>(gen, modesGroup);\
diff --git a/net-im/qutim/metadata.xml b/net-im/qutim/metadata.xml
deleted file mode 100644
index a8922ddd4abf..000000000000
--- a/net-im/qutim/metadata.xml
+++ /dev/null
@@ -1,42 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>fatzer2@gmail.com</email>
- <name>Alexander Golubev</name>
- <description>Proxied maintainer. Assign bugs on him</description>
-</maintainer>
-<maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
-</maintainer>
-<upstream>
- <maintainer>
- <email>euroelessar@yandex.ru</email>
- <name>Ruslan Nigmatullin</name>
- </maintainer>
- <bugs-to>https://github.com/euroelessar/qutim/issues</bugs-to>
-</upstream>
-<use>
- <flag name="aspell">Enable spellchecking using <pkg>app-text/aspell</pkg></flag>
- <flag name="awn">Enable integration with gnome-extra/avant-window-navigator</flag>
- <flag name="crypt">Enable AES crypto plugin</flag>
- <flag name="histman">Enable history importer plugin</flag>
- <flag name="hunspell">Enable spellchecking using <pkg>app-text/hunspell</pkg></flag>
- <flag name="irc">Enable IRC protocol support</flag>
- <flag name="mrim">Enable mail.ru protocol support</flag>
- <flag name="otr">Enable plugin for encrypted conversations (Off-The-Record messaging)</flag>
- <flag name="phonon">Add sound support via <pkg>media-libs/phonon</pkg></flag>
- <flag name="purple">Enable libpurple-based protocol support</flag>
- <flag name="qml">Enable QtQuick-based chat plugin</flag>
- <flag name="sdl">Add sound support via <pkg>media-libs/sdl-mixer</pkg></flag>
- <flag name="vkontakte">Enable vkontakte protocol support</flag>
- <flag name="webkit">Enable Adium-like WebView plugin</flag>
- <flag name="xscreensaver">Use X screensaver protocol extension to monitor idle/active status based on mouse/keyboard events</flag>
- <flag name="tools">Enable some extra tools for qt developers</flag>
- <flag name="telepathy">Enable to connect various IMs through <pkg>net-libs/telepathy-qt</pkg></flag>
- <flag name="antiboss">Enable support for the antiboss plugin</flag>
- <flag name="espionage">!!Not recomended, contains privacy risk!! Enable control plugin that controls user by sending messages and roster to remote server</flag>
- <flag name="plugman">Enable downloadable content management with <pkg>dev-libs/libattica</pkg></flag>
-</use>
-</pkgmetadata>
diff --git a/net-im/qutim/qutim-0.3.3_p1.ebuild b/net-im/qutim/qutim-0.3.3_p1.ebuild
deleted file mode 100644
index 998b0b5189c1..000000000000
--- a/net-im/qutim/qutim-0.3.3_p1.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-LANGS="ar be bg cs de en_GB es fr he nds ru sk uk uz zh_CN"
-
-inherit qt4-r2 cmake-utils
-
-MY_PV="${PV/_p/.p_}"
-DESCRIPTION="Qt4-based multi-protocol instant messenger"
-HOMEPAGE="https://www.qutim.org"
-SRC_URI="https://www.qutim.org/dwnl/80/${PN}-${MY_PV}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# general USE
-IUSE="doc +sound tools"
-# protocol uses
-IUSE="$IUSE telepathy irc xmpp mrim oscar purple vkontakte"
-# plugins
-IUSE="$IUSE antiboss aspell ayatana awn crypt dbus debug -espionage histman hunspell
- otr plugman phonon purple qml sdl +ssl +xscreensaver webkit"
-
-REQUIRED_USE="
- oscar? ( ssl )
- qml? ( webkit )
-"
-
-# Minimum Qt version required
-QT_PV="4.7.0:4"
-
-CDEPEND="
- x11-libs/libqxt
- >=dev-qt/qtcore-${QT_PV}[ssl?]
- >=dev-qt/qtgui-${QT_PV}
- >=dev-qt/qtscript-${QT_PV}
- >=dev-qt/qtdeclarative-${QT_PV}
-
- telepathy? ( >=net-libs/telepathy-qt-0.3 )
- xmpp? (
- app-crypt/qca:2[qt4(+)]
- >=net-libs/jreen-1.2.0[qt4]
- )
- oscar? ( app-crypt/qca:2[qt4(+)] )
- purple? ( net-im/pidgin )
- vkontakte? ( >=dev-qt/qtwebkit-${QT_PV} )
-
- aspell? ( app-text/aspell )
- awn? ( >=dev-qt/qtdbus-${QT_PV} )
- crypt? ( app-crypt/qca:2[qt4(+)] )
- dbus? ( >=dev-qt/qtdbus-${QT_PV} )
- espionage? ( app-crypt/qca:2[qt4(+)] )
- histman? ( >=dev-qt/qtsql-${QT_PV} )
- ayatana? ( >=dev-libs/libindicate-qt-0.2.2 )
- hunspell? ( app-text/hunspell )
- otr? ( >=net-libs/libotr-4.0.0 )
- phonon? ( media-libs/phonon[qt4] )
- plugman? (
- dev-libs/libattica
- app-arch/libarchive
- )
- qml? (
- >=dev-qt/qtopengl-${QT_PV}
- )
- sdl? ( media-libs/sdl-mixer )
- xscreensaver? ( x11-libs/libXScrnSaver )
- webkit? ( >=dev-qt/qtwebkit-${QT_PV} )
-"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-RDEPEND="${CDEPEND}
- xmpp? ( app-crypt/qca:2[gpg] )
- oscar? ( app-crypt/qca:2[ssl] )
- kde-frameworks/oxygen-icons
-"
-
-DOCS=( AUTHORS ChangeLog )
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.2-astral-migrate-qt-telepaphy.patch"
- "${FILESDIR}/${PN}-0.3.3-fix-build-with-gcc-6.1.0-and-above.patch"
-)
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
- # fix automagic dep on libXScrnSaver
- if ! use xscreensaver; then
- sed -i -e '/XSS xscrnsaver/d' \
- core/src/corelayers/idledetector/CMakeLists.txt || die
- fi
-
- # remove unwanted translations
- local lang
- for lang in ${LANGS}; do
- use linguas_${lang} || rm -f translations/modules/*/${lang}.{po,ts}
- done
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSYSTEM_JREEN=ON
- $(cmake-utils_use_with doc DOXYGEN)
- $(cmake-utils_use doc QUTIM_GENERATE_DOCS)
- $(cmake-utils_use sound QUTIM_INSTALL_SOUND_THEME )
- $(cmake-utils_use tools QUTIM_DEVELOPER_BUILD )
-
- # protocols
- $(cmake-utils_use telepathy ASTRAL )
- $(cmake-utils_use irc )
- $(cmake-utils_use xmpp JABBER )
- $(cmake-utils_use mrim )
- $(cmake-utils_use oscar )
- $(cmake-utils_use purple QUETZAL )
- $(cmake-utils_use vkontakte )
-
- # plugins
- $(cmake-utils_use webkit ADIUMWEBVIEW )
- $(cmake-utils_use crypt AESCRYPTO )
- $(cmake-utils_use antiboss ANTIBOSS )
- $(cmake-utils_use aspell ASPELLER )
- $(cmake-utils_use awn AWN )
- $(cmake-utils_use espionage CONTROL ) # Also requires -DENABLE_ESPIONAGE=ON (see bellow)
- $(cmake-utils_use dbus DBUSAPI )
- $(cmake-utils_use dbus DBUSNOTIFICATIONS )
- $(cmake-utils_use histman HISTMAN )
- $(cmake-utils_use hunspell HUNSPELLER )
- $(cmake-utils_use ayatana INDICATOR )
- $(cmake-utils_use qml KINETICPOPUPS )
- $(cmake-utils_use phonon PHONONSOUND )
- $(cmake-utils_use plugman PLUGMAN )
- $(cmake-utils_use debug LOGGER )
- $(cmake-utils_use dbus NOWPLAYING )
- $(cmake-utils_use otr OFFTHERECORD )
- $(cmake-utils_use qml QMLCHAT )
- $(cmake-utils_use sdl SDLSOUND )
- $(cmake-utils_use_enable espionage )
- -DLINUXINTEGRATION=ON
- -DDOCKTILE=OFF # QtDockTile currenly supports only unity;
- # consider to make it optional if it also support kde or whatever
- -DUPDATER=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_QtMobility=ON # required dependency last-rited
- -DKDEINTEGRATION=OFF # bug 631122
- )
- # NOTE: Integration plugins are autodisabled:
- # symbianintegration macintegration maemo5integration haikunotifications meegointegration winintegration
-
- cmake-utils_src_configure
-}
-
-pkg_postinst () {
- elog "Next qutim plugins are enabled by default:"
- elog " antispam autopaster autoreply birthdayreminder blogimprover clconf"
- elog " emoedit floaties formula highlighter imagepub massmessaging"
- elog " oldcontactdelegate qrcicons screenshoter scriptapi unreadmessageskeeper urlpreview"
- elog " weather webhistory yandexnarod"
- elog "If you have strong reasons to make their build optional feel free to fill bugrepot."
-
- if use espionage; then
- ewarn "You have enabled the control (espionage) plugin. It may "
- ewarn "deal negative security impact on the privacy of your client."
- fi
-}