summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-02-13 10:09:36 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-02-13 13:14:42 +0100
commit721b824f4837111b0d11af6c99fc7862cbe03d96 (patch)
tree99f431b8e50a323331cbe7e3213cf5d295777b77 /net-irc/hexchat
parentdev-util/qdevicemonitor: disable warnings as errors (diff)
downloadgentoo-721b824f4837111b0d11af6c99fc7862cbe03d96.tar.gz
gentoo-721b824f4837111b0d11af6c99fc7862cbe03d96.tar.bz2
gentoo-721b824f4837111b0d11af6c99fc7862cbe03d96.zip
net-irc/hexchat: Bump to version 2.16.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-irc/hexchat')
-rw-r--r--net-irc/hexchat/Manifest1
-rw-r--r--net-irc/hexchat/hexchat-2.16.1.ebuild132
2 files changed, 133 insertions, 0 deletions
diff --git a/net-irc/hexchat/Manifest b/net-irc/hexchat/Manifest
index 4b08e04813e1..f634ca07b754 100644
--- a/net-irc/hexchat/Manifest
+++ b/net-irc/hexchat/Manifest
@@ -1,4 +1,5 @@
DIST hexchat-2.14.3.tar.xz 1292072 BLAKE2B 22bc8a0857b3ec26452843dd85c046cde055e719ce7dc23e4ec5ae33eb16251379ed84856c1812dc855a1e8d5d422c01e9352e2259f075a538226e1fcd79edd7 SHA512 c265921f2cb02c5d273bcdbb20a44a5c9f38b0f8cbba4fd56b177b676fc5d1dfd05bf80fcfa3706c7981f712f2f6c9aaaf80bccf3be0f6d96068dd393f3a7cb5
DIST hexchat-2.16.0.tar.xz 1348320 BLAKE2B d5c6da74152e7ca08b629ee86cc45acb8232fbdad3d508cf56aba0c09d558b77644b704b5489e5f08a70133813f37c12e45b1529162e41b62acc9f61bca0b108 SHA512 4802f6efe0883f48d3d56ee949be1fc224b76a3c76956dcba3f913679e91424ba53c5c0d68bb4e0e790b16a08689111098958ead4c83c35cddf39855fe07c207
+DIST hexchat-2.16.1.tar.xz 1349536 BLAKE2B 6e1d9f7c36affc94356e0124ea445f019d8f00b643896ec004af17059befadfcd8fc1b75ef9fba277542dcf8593e8e4683a709a4c4cbaaaf4f3122d8488dc6ce SHA512 9e6baa30ec8c3ce4fb56e2c82625da63295040eaf93a542aec8a4a18a6a3c95d69d1d4ffabc952bcdcd7b754afef234b348f296143991fafd0550342db95ce0e
DIST hexchat-add-libera-chat.patch 696 BLAKE2B cd5f0736abd7895d017e835335a6ff9a0f6301cba7e7b8c2a4e9da7047885aac2f8b7b25b0723966bd103118c99d833d3e99481865bf20d202b0f95c0a9131bb SHA512 e3cc7df3f114a2374c1653c4ab7262dad87191f74ca759c41beecd731472478e8bdc929b0a13475a1248ed045ee1faf93cd80a225b6ed670f449d4495d4ab2ae
DIST hexchat-default-network.patch 1423 BLAKE2B b11982d50abb4fb7d8aab4758195cbfea1691cd7c6487ca56f995e449ff0445e2427a68064c0d8ee4b4b4e7764e438bfd68bb5402a266624cb6cfb93fbfdb30b SHA512 2691786d360278b4334e9129912ca0abde7b98f0d72f5e530b34e109eaf624d8e7280e137490dab218bacfb5bed952b2d7827640777ad73da5585517de308f42
diff --git a/net-irc/hexchat/hexchat-2.16.1.ebuild b/net-irc/hexchat/hexchat-2.16.1.ebuild
new file mode 100644
index 000000000000..426793497d86
--- /dev/null
+++ b/net-irc/hexchat/hexchat-2.16.1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit lua-single meson mono-env python-single-r1 xdg
+
+DESCRIPTION="Graphical IRC client based on XChat"
+HOMEPAGE="https://hexchat.github.io/"
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ # We need to empty SRC_URI or else mono-env breaks the live ebuild
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://dl.hexchat.net/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+fi
+
+LICENSE="GPL-2 plugin-fishlim? ( MIT )"
+SLOT="0"
+IUSE="dbus debug +gtk libcanberra lua perl plugin-checksum plugin-fishlim plugin-sysinfo python ssl theme-manager"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dbus? ( dev-libs/dbus-glib )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ )
+ libcanberra? ( media-libs/libcanberra )
+ lua? ( ${LUA_DEPS} )
+ perl? ( dev-lang/perl:= )
+ plugin-sysinfo? ( sys-apps/pciutils )
+ python? (
+ ${PYTHON_DEPS}
+ virtual/python-cffi
+ )
+ ssl? ( dev-libs/openssl:0= )
+ theme-manager? (
+ || (
+ ( dev-lang/mono[minimal] dev-dotnet/libgdiplus )
+ dev-lang/mono[-minimal]
+ )
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ app-arch/xz-utils
+ app-text/iso-codes
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+ if use theme-manager ; then
+ mono-env_pkg_setup
+ export XDG_CACHE_HOME="${T}/.cache"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddbus-service-use-appid=false
+ -Dinstall-appdata=false
+ -Dplugin=true
+ $(meson_feature dbus)
+ $(meson_feature libcanberra)
+ $(meson_feature ssl tls)
+ $(meson_use gtk gtk-frontend)
+ $(meson_use !gtk text-frontend)
+ $(meson_use theme-manager)
+
+ $(meson_use plugin-checksum with-checksum)
+ $(meson_use plugin-fishlim with-fishlim)
+ -Dwith-lua="$(usex lua "${ELUA}" false)"
+ -Dwith-perl="$(usex perl "${EPREFIX}"/usr/bin/perl false)"
+ -Dwith-python="$(usex python "${EPYTHON/.*}" false)"
+ $(meson_use plugin-sysinfo with-sysinfo)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc readme.md
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ if use gtk ; then
+ xdg_pkg_preinst
+ fi
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ xdg_pkg_postinst
+ else
+ elog "You have disabled the gtk USE flag. This means you don't have"
+ elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
+ fi
+
+ if use theme-manager ; then
+ elog "Themes are available at:"
+ elog " https://hexchat.github.io/themes.html"
+ fi
+
+ elog
+ elog "optional dependencies:"
+ elog " media-sound/sox (sound playback if you don't have libcanberra"
+ elog " enabled)"
+ elog " x11-themes/sound-theme-freedesktop (default BEEP sound,"
+ elog " needs libcanberra enabled)"
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ xdg_pkg_postrm
+ fi
+}