summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/ircii
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/ircii')
-rw-r--r--net-irc/ircii/Manifest2
-rw-r--r--net-irc/ircii/files/ircii-20110228-glibc.patch29
-rw-r--r--net-irc/ircii/ircii-20110228.ebuild39
-rw-r--r--net-irc/ircii/ircii-20111115.ebuild35
-rw-r--r--net-irc/ircii/metadata.xml5
5 files changed, 110 insertions, 0 deletions
diff --git a/net-irc/ircii/Manifest b/net-irc/ircii/Manifest
new file mode 100644
index 000000000000..205b0458fc7f
--- /dev/null
+++ b/net-irc/ircii/Manifest
@@ -0,0 +1,2 @@
+DIST ircii-20110228.tar.bz2 558483 SHA256 4fc77ddaf473e35817f55945e6275b1501b7d95585b49a44e0fe998382d72fb2 SHA512 df27f098ad9c134335b7d97a25a07ef5fd9d14063b2e079a707a472d2582a1451d7697f3123508296c76afdb78257ad6dc358a2ec5af584ab53872c765b01782 WHIRLPOOL 2ea4dfa1f1b64152373e4c6f79216bfca803980715745e40c2c72e6f4f8facccee93657a9a1ca40d952e5b69d5522b7034041dc706ef9dc39ae4810de0c1831d
+DIST ircii-20111115.tar.bz2 555731 SHA256 5c6b4390b8ed04cf3b08a3ba72f41eba9b125d0fc09c637f7c7f81eb6bdd91e6 SHA512 6f282debbd27865414a2ef9148b23373f83a051b2917432d9fdc2f153c111f8e592286d42a5ad34fd0cdc155e39938094e140910fbf38be494e3ed3da4cd0b6e WHIRLPOOL dfb1b7326c5ee22c480ff85a3821af9ebb6f832da512f3f2b821ed3ed1437494cc1a7ca93794435e42f58cb3fe0a226105fb085fcf81425334a3e8ff4d209748
diff --git a/net-irc/ircii/files/ircii-20110228-glibc.patch b/net-irc/ircii/files/ircii-20110228-glibc.patch
new file mode 100644
index 000000000000..291bf3219eb2
--- /dev/null
+++ b/net-irc/ircii/files/ircii-20110228-glibc.patch
@@ -0,0 +1,29 @@
+From: Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+
+Support glibc systems where SIGRTMAX and SIGRTMIN macros can only be fully expanded at runtime.
+
+--- a/source/mksiginc.c
++++ b/source/mksiginc.c
+@@ -191,12 +191,18 @@
+ signames[SIGRETRACT] = "RETRACT";
+ #endif
+
+-#if defined(SIGRTMAX) && SIGRTMAX < MY_MAXSIG
+- signames[SIGRTMAX] = "RTMAX";
++#if defined(SIGRTMAX)
++ /*
++ * In recent glibc, SIGRTMAX and SIGRTMIN macros are runtime
++ * function calls into libc and must be evaluated at runtime.
++ */
++ if (SIGRTMAX < MY_MAXSIG)
++ signames[SIGRTMAX] = "RTMAX";
+ #endif
+
+-#if defined(SIGRTMIN) && SIGRTMIN < MY_MAXSIG
+- signames[SIGRTMIN] = "RTMIN";
++#if defined(SIGRTMIN)
++ if (SIGRTMIN < MY_MAXSIG)
++ signames[SIGRTMIN] = "RTMIN";
+ #endif
+
+ #if defined(SIGSAK) && SIGSAK < MY_MAXSIG
diff --git a/net-irc/ircii/ircii-20110228.ebuild b/net-irc/ircii/ircii-20110228.ebuild
new file mode 100644
index 000000000000..240ab9ac891b
--- /dev/null
+++ b/net-irc/ircii/ircii-20110228.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2"
+HOMEPAGE="http://www.eterna.com.au/ircii/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6"
+
+DEPEND="sys-libs/ncurses
+ virtual/libiconv"
+# This and irc-client both install /usr/bin/irc #247987
+RDEPEND="${DEPEND}
+ !!net-irc/irc-client"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc.patch
+}
+
+src_configure() {
+ tc-export CC
+ use elibc_glibc || append-libs -liconv
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc ChangeLog INSTALL NEWS README \
+ doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
+}
diff --git a/net-irc/ircii/ircii-20111115.ebuild b/net-irc/ircii/ircii-20111115.ebuild
new file mode 100644
index 000000000000..2461cf7e0c2e
--- /dev/null
+++ b/net-irc/ircii/ircii-20111115.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2
+ ftp://ircii.warped.com/pub/ircII/old/${P}.tar.bz2"
+HOMEPAGE="http://eterna.com.au/ircii/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6"
+
+DEPEND="sys-libs/ncurses
+ virtual/libiconv"
+# This and irc-client both install /usr/bin/irc #247987
+RDEPEND="${DEPEND}
+ !!net-irc/irc-client"
+
+src_configure() {
+ tc-export CC
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc ChangeLog INSTALL NEWS README \
+ doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
+}
diff --git a/net-irc/ircii/metadata.xml b/net-irc/ircii/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/ircii/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>