summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/onis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/onis')
-rw-r--r--net-irc/onis/Manifest1
-rw-r--r--net-irc/onis/files/0.6.0-nochdir.patch11
-rw-r--r--net-irc/onis/metadata.xml5
-rw-r--r--net-irc/onis/onis-0.8.2.ebuild47
4 files changed, 64 insertions, 0 deletions
diff --git a/net-irc/onis/Manifest b/net-irc/onis/Manifest
new file mode 100644
index 000000000000..e06941a4fbc7
--- /dev/null
+++ b/net-irc/onis/Manifest
@@ -0,0 +1 @@
+DIST onis-0.8.2.tar.bz2 100135 SHA256 fc7e164ae16757457a0971f3f08936920736cedbb5b7a03e72ec5d10e5ff214a SHA512 f0b7f49fc65c77953956d4ba8c699d9f30967586514f79047282be2a0ea19e69224989937e4abc9a868c556776e579f68d58e541ad81b071b6575579ea29f928 WHIRLPOOL 9403affe0ac05e2f0352dd48c83be0f4229489abe0590bdf0f358728119a75bdbac1511a67d3272bb76e995760696409a8e5b29d5bdb3ecf128a83d0ca988e5d
diff --git a/net-irc/onis/files/0.6.0-nochdir.patch b/net-irc/onis/files/0.6.0-nochdir.patch
new file mode 100644
index 000000000000..06bd40a001ab
--- /dev/null
+++ b/net-irc/onis/files/0.6.0-nochdir.patch
@@ -0,0 +1,11 @@
+--- onis.orig 2004-03-15 00:48:07.874308008 +0100
++++ onis 2004-03-15 00:48:17.110903832 +0100
+@@ -15,8 +15,6 @@
+
+ BEGIN
+ {
+- if ($0 =~ m#^(.*)[/\\]#) { chdir ($1); }
+-
+ unshift (@INC, 'lib');
+
+ # 0x0010 Language (make not-translated lines red/yellow)
diff --git a/net-irc/onis/metadata.xml b/net-irc/onis/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/onis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>
diff --git a/net-irc/onis/onis-0.8.2.ebuild b/net-irc/onis/onis-0.8.2.ebuild
new file mode 100644
index 000000000000..d564a9f4e462
--- /dev/null
+++ b/net-irc/onis/onis-0.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="onis not irc stats"
+HOMEPAGE="http://verplant.org/onis/"
+SRC_URI="http://verplant.org/${PN}/${P}.tar.bz2"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/0.6.0-nochdir.patch
+
+ sed -i -e s:lang/:/usr/share/onis/lang/: onis.conf || die "sed failed"
+}
+
+src_install () {
+ eval $(perl -V:installprivlib)
+
+ dobin onis || die "dobin failed"
+
+ insinto "${installprivlib}"
+ doins -r lib/Onis || die "doins failed"
+
+ insinto /usr/share/onis
+ doins -r lang reports/* || die "doins failed"
+
+ dodoc CHANGELOG README THANKS onis.conf users.conf
+}
+
+pkg_postinst() {
+ elog
+ elog "The onis themes have been installed in /usr/share/onis/*-theme"
+ elog "You can find a compressed sample configuration at /usr/share/doc/${PF}/config"
+ elog
+}