summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-08-31 12:25:11 +0200
committerJeroen Roovers <jer@gentoo.org>2017-08-31 12:25:11 +0200
commit9648b653f7890632e09948954418ae97fb51f2a8 (patch)
treebba77f59a036ac0507e4ad96741ab782922f266b /net-irc/sic
parentx11-misc/slock: Whitespace. (diff)
downloadgentoo-9648b653f7890632e09948954418ae97fb51f2a8.tar.gz
gentoo-9648b653f7890632e09948954418ae97fb51f2a8.tar.bz2
gentoo-9648b653f7890632e09948954418ae97fb51f2a8.zip
net-irc/sic: EAPI=6.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-irc/sic')
-rw-r--r--net-irc/sic/sic-1.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/sic/sic-1.2-r1.ebuild b/net-irc/sic/sic-1.2-r1.ebuild
new file mode 100644
index 000000000000..2056ef616516
--- /dev/null
+++ b/net-irc/sic/sic-1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="An extremly simple IRC client"
+HOMEPAGE="https://tools.suckless.org/sic"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
+ -e '/^CC/d' \
+ -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
+ config.mk || die
+ sed -i \
+ -e 's|@${CC}|$(CC)|g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}