summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-06-06 21:02:23 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-06-06 21:04:09 -0700
commitd46701e63c9db0cc6fa2b526129d48db7b6d16b0 (patch)
tree1528b73c4cddf7fd5d725dd68ba9de3826dbe359 /net-irc
parentsys-fs/fatcat: new package (diff)
downloadgentoo-d46701e63c9db0cc6fa2b526129d48db7b6d16b0.tar.gz
gentoo-d46701e63c9db0cc6fa2b526129d48db7b6d16b0.tar.bz2
gentoo-d46701e63c9db0cc6fa2b526129d48db7b6d16b0.zip
net-irc/weechat: bump to 2.5
removed libdir hack, pass -DLIBDIR removed missing tanslations renamed aspell plugins to SPELL moved doc generating deps to BDEPEND Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/Manifest1
-rw-r--r--net-irc/weechat/weechat-2.5.ebuild155
2 files changed, 156 insertions, 0 deletions
diff --git a/net-irc/weechat/Manifest b/net-irc/weechat/Manifest
index 9872ed898396..ff45f12e29dd 100644
--- a/net-irc/weechat/Manifest
+++ b/net-irc/weechat/Manifest
@@ -1,2 +1,3 @@
DIST weechat-2.3.tar.xz 2025652 BLAKE2B 74c5d81a77f164c51bee01ff1be5731455ad85178005a360269ffa4ac59554c58dc97175fcb3fa62841b79e7711c1dc41876a839a9d1e4a1f4ce359bac1d6689 SHA512 0de827850de5c70c528e1a8cfa44220c3d48d6767df61a8a6283123173ba63b4c8554d5334a8b14976d19602c36bbc27d89ebbd201ccd8c048d50edc3a4ea19b
DIST weechat-2.4.tar.xz 2044448 BLAKE2B d1893de3465f8d19ae5faea0638454839e640a7480f8cae4ee517c090aab68789224865ce2c371a0e8f4f8a44fb86382ab53f51b50042db3488efbf10d62de05 SHA512 012eca03e56eea64b3e50ee1e8b7c1cc636ad779be01268b3c9ee05e3bd149bc58b09eb6952e965061782da5f9d33d7a835056c6bb43c1fdca998cfc463fd068
+DIST weechat-2.5.tar.xz 2067180 BLAKE2B 5ef2a20d0f4e72958f8523c46eac4acf8223d70efbadc78a1a5623b0e63e11acbe1c8e5ec739f56764c6825393902626e234269646031971a0f58fbd314f8918 SHA512 af0135009b799d40790c09da5419c950a6c750264a556de418b0ba4f396ecbde2aadeae5cbea3f2e98fc9926f07439e28beac00cb0019dc6752c1a5640a9834e
diff --git a/net-irc/weechat/weechat-2.5.ebuild b/net-irc/weechat/weechat-2.5.ebuild
new file mode 100644
index 000000000000..bebadfe887e0
--- /dev/null
+++ b/net-irc/weechat/weechat-2.5.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit cmake-utils python-single-r1 xdg-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/weechat/weechat.git"
+else
+ SRC_URI="https://weechat.org/files/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Portable and multi-interface IRC client"
+HOMEPAGE="https://weechat.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+NETWORKS="+irc"
+PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spell +trigger +xfer"
+# dev-lang/v8 was dropped from Gentoo so we can't enable javascript support
+SCRIPT_LANGS="guile lua +perl php +python ruby tcl"
+LANGS=" cs de es fr it ja pl ru"
+IUSE="doc man nls +ssl test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ net-misc/curl[ssl]
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ charset? ( virtual/libiconv )
+ guile? ( >=dev-scheme/guile-2.0 )
+ lua? ( dev-lang/lua:0[deprecated] )
+ nls? ( virtual/libintl )
+ perl? ( dev-lang/perl:= )
+ php? ( >=dev-lang/php-7.0:* )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( || ( dev-lang/ruby:2.6 dev-lang/ruby:2.5 dev-lang/ruby:2.4 ) )
+ ssl? ( net-libs/gnutls )
+ spell? ( app-text/aspell )
+ tcl? ( >=dev-lang/tcl-8.4.15:0= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cpputest )
+"
+
+BDEPEND="
+ doc? ( >=dev-ruby/asciidoctor-1.5.4 )
+ man? ( >=dev-ruby/asciidoctor-1.5.4 )
+ nls? ( >=sys-devel/gettext-0.15 )
+"
+
+DOCS="AUTHORS.adoc ChangeLog.adoc Contributing.adoc ReleaseNotes.adoc README.adoc"
+
+# tests need to be fixed to not use system plugins if weechat is already installed
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # install only required translations
+ local i
+ for i in ${LANGS} ; do
+ if ! has ${i} ${LINGUAS-${i}} ; then
+ sed -i \
+ -e "/${i}.po/d" \
+ po/CMakeLists.txt || die
+ fi
+ done
+
+ # install only required documentation ; en always
+ for i in $(grep add_subdirectory doc/CMakeLists.txt \
+ | sed -e 's/.*add_subdirectory(\(..\)).*/\1/' -e '/en/d'); do
+ if ! has ${i} ${LINGUAS-${i}} ; then
+ sed -i \
+ -e '/add_subdirectory('${i}')/d' \
+ doc/CMakeLists.txt || die
+ fi
+ done
+
+ # install docs in correct directory
+ sed -i "s#\${SHAREDIR}/doc/\${PROJECT_NAME}#\0-${PV}/html#" doc/*/CMakeLists.txt || die
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ # fix linking error on Darwin
+ sed -i "s/+ get_config_var('LINKFORSHARED')//" \
+ cmake/FindPython.cmake || die
+ # allow to find the plugins by default
+ sed -i 's/".so,.dll"/".bundle,.so,.dll"/' \
+ src/core/wee-config.c || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBDIR=$(get_libdir)
+ -DENABLE_JAVASCRIPT=OFF
+ -DENABLE_LARGEFILE=ON
+ -DENABLE_NCURSES=ON
+ -DENABLE_ALIAS=$(usex alias)
+ -DENABLE_BUFLIST=$(usex buflist)
+ -DENABLE_CHARSET=$(usex charset)
+ -DENABLE_DOC=$(usex doc)
+ -DENABLE_EXEC=$(usex exec)
+ -DENABLE_FIFO=$(usex fifo)
+ -DENABLE_FSET=$(usex fset)
+ -DENABLE_GNUTLS=$(usex ssl)
+ -DENABLE_GUILE=$(usex guile)
+ -DENABLE_IRC=$(usex irc)
+ -DENABLE_LOGGER=$(usex logger)
+ -DENABLE_LUA=$(usex lua)
+ -DENABLE_MAN=$(usex man)
+ -DENABLE_NLS=$(usex nls)
+ -DENABLE_PERL=$(usex perl)
+ -DENABLE_PHP=$(usex php)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_RELAY=$(usex relay)
+ -DENABLE_RUBY=$(usex ruby)
+ -DENABLE_SCRIPT=$(usex scripts)
+ -DENABLE_SCRIPTS=$(usex scripts)
+ -DENABLE_SPELL=$(usex spell)
+ -DENABLE_TCL=$(usex tcl)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_TRIGGER=$(usex trigger)
+ -DENABLE_XFER=$(usex xfer)
+ )
+
+ if use python; then
+ python_export PYTHON_LIBPATH
+ mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_LIBRARY="${PYTHON_LIBPATH}"
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}