summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-10-09 10:27:34 +0200
committerMichael Weber <xmw@gentoo.org>2015-10-09 10:32:59 +0200
commitc87cd17a2839186f475d4543b37be385b26f62b5 (patch)
tree5f8ad53aeda6019f595bc25e143e4ec7eb887f65 /net-libs/enet/enet-1.3.13.ebuild
parentdev-lang/crystal: Introduce new package (diff)
downloadgentoo-c87cd17a2839186f475d4543b37be385b26f62b5.tar.gz
gentoo-c87cd17a2839186f475d4543b37be385b26f62b5.tar.bz2
gentoo-c87cd17a2839186f475d4543b37be385b26f62b5.zip
net-libs/enet: Version bump (thanks Mr. Bones)
Package-Manager: portage-2.2.21
Diffstat (limited to 'net-libs/enet/enet-1.3.13.ebuild')
-rw-r--r--net-libs/enet/enet-1.3.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/enet/enet-1.3.13.ebuild b/net-libs/enet/enet-1.3.13.ebuild
new file mode 100644
index 000000000000..ff7aaaa1a2d7
--- /dev/null
+++ b/net-libs/enet/enet-1.3.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base
+
+DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.3/7"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="!${CATEGORY}/${PN}:0"
+
+DOCS=( "ChangeLog" "README" )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ base_src_install
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+}