summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-17 16:50:06 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-17 16:58:15 +0200
commit5186623d9c3387cadf79957dde43c13cdf725d8e (patch)
tree1a6ab2a63424d37c6a4d445f63b9c1f367ec1acf /net-libs/farstream
parentmedia-gfx/colorhug-client: Drop old (diff)
downloadgentoo-5186623d9c3387cadf79957dde43c13cdf725d8e.tar.gz
gentoo-5186623d9c3387cadf79957dde43c13cdf725d8e.tar.bz2
gentoo-5186623d9c3387cadf79957dde43c13cdf725d8e.zip
net-libs/farstream: Build more plugins (#592154 by Joakim Tjernlund)
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-libs/farstream')
-rw-r--r--net-libs/farstream/farstream-0.2.8-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-libs/farstream/farstream-0.2.8-r1.ebuild b/net-libs/farstream/farstream-0.2.8-r1.ebuild
new file mode 100644
index 000000000000..1229752675b2
--- /dev/null
+++ b/net-libs/farstream/farstream-0.2.8-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="https://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+introspection test upnp"
+SLOT="0.2/5" # .so version
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
+COMMONDEPEND="
+ >=media-libs/gstreamer-1.4:1.0
+ >=media-libs/gst-plugins-base-1.4:1.0
+ >=dev-libs/glib-2.32:2
+ >=net-libs/libnice-0.1.8
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11:= )
+ upnp? ( >=net-libs/gupnp-igd-0.2:= )
+"
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-1.4:1.0
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ media-plugins/gst-plugins-libnice:1.0
+"
+DEPEND="${COMMONDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.18
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-base:1.0[vorbis]
+ media-libs/gst-plugins-good:1.0 )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsmsnconference,fsrtpxdata,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #539224
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ addpredict /dev
+ gnome2_src_compile
+}