summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/gnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/gnet')
-rw-r--r--net-libs/gnet/Manifest1
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-check-usage-update.patch35
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-context-leak.patch32
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-define-location.patch20
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-fix-pkgconfig-abuse.patch16
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-network-tests.patch32
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-test-existing-domain.patch32
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-unittest-build.patch22
-rw-r--r--net-libs/gnet/files/gnet-2.0.8-unittest-service.patch31
-rw-r--r--net-libs/gnet/gnet-2.0.8-r2.ebuild68
-rw-r--r--net-libs/gnet/metadata.xml5
11 files changed, 294 insertions, 0 deletions
diff --git a/net-libs/gnet/Manifest b/net-libs/gnet/Manifest
new file mode 100644
index 000000000000..38280452b983
--- /dev/null
+++ b/net-libs/gnet/Manifest
@@ -0,0 +1 @@
+DIST gnet-2.0.8.tar.bz2 514019 SHA256 14034c7ef571a93f2aca21b2280fa86b35ef5730541d3eb57557dd42d7cc506b SHA512 b52ce73c62eb93d7f68a124128780dcf6c6795e82436d0882469dd7873d482c6b87c77d4efa9f69838a58313d7d958abad5b41a89620014c239030d0294cf11f WHIRLPOOL f259f28194b9932f30a72cfe9cbd7a645dbf18a0d02b8b3a506e4bf90ffb77a76f45500142d0b7b2e2c370f0da2f40e99710f5599336ff7d1080de108a60cbfd
diff --git a/net-libs/gnet/files/gnet-2.0.8-check-usage-update.patch b/net-libs/gnet/files/gnet-2.0.8-check-usage-update.patch
new file mode 100644
index 000000000000..0ca2156b791d
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-check-usage-update.patch
@@ -0,0 +1,35 @@
+From a61601a487394cbd5970c3b736aea71bf277ecc1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim.muller@collabora.co.uk>
+Date: Sat, 16 Oct 2010 20:13:52 +0100
+Subject: [PATCH] tests: require check >= 0.9.7 for unit tests, and fix for new API
+
+The check API changed slightly. Fix things for the new API.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=632258
+---
+ tests/check/gnetcheck.h | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tests/check/gnetcheck.h b/tests/check/gnetcheck.h
+index aeb9f68..14b6c28 100644
+--- a/tests/check/gnetcheck.h
++++ b/tests/check/gnetcheck.h
+@@ -311,11 +311,11 @@ int main (int argc, char **argv) \
+ gboolean _gnet_check_run_test_func (const gchar * func_name);
+
+ static inline void
+-__gnet_tcase_add_test (TCase * tc, TFun tf, const gchar * func_name,
+- int sig, int start, int end)
++__gnet_tcase_add_test (TCase * tc, TFun tf, const char * fname, int signal,
++ int allowed_exit_value, int start, int end)
+ {
+- if (_gnet_check_run_test_func (func_name)) {
+- _tcase_add_test (tc, tf, func_name, sig, start, end);
++ if (_gnet_check_run_test_func (fname)) {
++ _tcase_add_test (tc, tf, fname, signal, allowed_exit_value, start, end);
+ }
+ }
+
+--
+1.7.3.1
+
diff --git a/net-libs/gnet/files/gnet-2.0.8-context-leak.patch b/net-libs/gnet/files/gnet-2.0.8-context-leak.patch
new file mode 100644
index 000000000000..a56e549edccf
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-context-leak.patch
@@ -0,0 +1,32 @@
+From d6997987ce7f3e84d1125715b17502452d085073 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tpm@src.gnome.org>
+Date: Tue, 13 May 2008 07:10:28 +0000
+Subject: [PATCH] Don't leak main context ref when one was set. Spotted by Kuang-Chun Cheng.
+
+ * src/conn.c: (gnet_conn_unref):
+ Don't leak main context ref when one was set.
+ Spotted by Kuang-Chun Cheng.
+
+
+svn path=/trunk/; revision=495
+---
+ src/conn.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/conn.c b/src/conn.c
+index f4de415..9d41fa6 100644
+--- a/src/conn.c
++++ b/src/conn.c
+@@ -305,6 +305,9 @@ gnet_conn_unref (GConn* conn)
+ if (conn->inetaddr)
+ gnet_inetaddr_delete (conn->inetaddr);
+
++ if (conn->context)
++ g_main_context_unref (conn->context);
++
+ g_free (conn->buffer);
+
+ g_free (conn);
+--
+1.7.3.1
+
diff --git a/net-libs/gnet/files/gnet-2.0.8-define-location.patch b/net-libs/gnet/files/gnet-2.0.8-define-location.patch
new file mode 100644
index 000000000000..1ce6bcac06af
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-define-location.patch
@@ -0,0 +1,20 @@
+--- a/tests/check/gnetcheck.h 2009-11-22 23:17:25.000000000 +0100
++++ b/tests/check/gnetcheck.h 2009-11-22 23:18:19.000000000 +0100
+@@ -310,6 +310,8 @@
+
+ gboolean _gnet_check_run_test_func (const gchar * func_name);
+
++#define _tcase_add_test __gnet_tcase_add_test
++
+ static inline void
+ __gnet_tcase_add_test (TCase * tc, TFun tf, const gchar * func_name,
+ int sig_, int start_, int end_)
+@@ -319,8 +321,6 @@
+ }
+ }
+
+-#define _tcase_add_test __gnet_tcase_add_test
+-
+ G_END_DECLS
+
+ #endif /* __GNET_CHECK_H__ */
diff --git a/net-libs/gnet/files/gnet-2.0.8-fix-pkgconfig-abuse.patch b/net-libs/gnet/files/gnet-2.0.8-fix-pkgconfig-abuse.patch
new file mode 100644
index 000000000000..9c85b72d8e29
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-fix-pkgconfig-abuse.patch
@@ -0,0 +1,16 @@
+Bug-Debian: http://bugs.debian.org/652165
+Author: Julien Cristau <jcristau@debian.org>
+
+use pkg-config to get the glib include path, not hardcode it.
+
+--- gnet-2.0.8.orig/gnet-2.0.pc.in
++++ gnet-2.0.8/gnet-2.0.pc.in
+@@ -6,5 +6,6 @@
+ Name: Gnet
+ Description: A network compatibility layer library
+ Version: @VERSION@
+-Libs: -L${libdir} -lgnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ @GLIB_LIBS@ @GTHREAD_LIBS@
+-Cflags: -I${includedir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ -I${libdir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@/include/ @GLIB_CFLAGS@ @GTHREAD_CFLAGS@
++Libs: -L${libdir} -lgnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@
++Requires.private: glib-2.0 gthread-2.0
++Cflags: -I${includedir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@ -I${libdir}/gnet-@GNET_MAJOR_VERSION@.@GNET_MINOR_VERSION@/include/
diff --git a/net-libs/gnet/files/gnet-2.0.8-network-tests.patch b/net-libs/gnet/files/gnet-2.0.8-network-tests.patch
new file mode 100644
index 000000000000..7bb7cefd133c
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-network-tests.patch
@@ -0,0 +1,32 @@
+From 576f6de12bf4a509882af0bbe4727e27e8bc9373 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 16 Nov 2010 14:18:08 +0100
+Subject: [PATCH] Do not build network related tests if not enabled
+
+---
+ tests/check/gnet/gnetconn.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/tests/check/gnet/gnetconn.c b/tests/check/gnet/gnetconn.c
+index 739b467..0558e28 100644
+--- a/tests/check/gnet/gnetconn.c
++++ b/tests/check/gnet/gnetconn.c
+@@ -25,6 +25,7 @@
+
+ #include <string.h>
+
++#ifdef GNET_ENABLE_NETWORK_TESTS
+ static void
+ conn_fail_cb (GConn * conn, GConnEvent * event, gpointer data)
+ {
+@@ -243,6 +244,7 @@ GNET_START_TEST (test_conn_new_socket)
+ g_main_loop_unref (loop);
+ }
+ GNET_END_TEST;
++#endif
+
+ static Suite *
+ gnetconn_suite (void)
+--
+1.7.3.1
+
diff --git a/net-libs/gnet/files/gnet-2.0.8-test-existing-domain.patch b/net-libs/gnet/files/gnet-2.0.8-test-existing-domain.patch
new file mode 100644
index 000000000000..b75258e38d02
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-test-existing-domain.patch
@@ -0,0 +1,32 @@
+From 1825f69b1a149cd3f2daa5f6c3333a32f0470f0a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim.muller@collabora.co.uk>
+Date: Sat, 16 Oct 2010 23:10:15 +0100
+Subject: tests: update GConnHttp unit test to not use inactive domains
+
+www.gnetlibrary.org has been abandoned.
+
+diff --git a/tests/check/gnet/gnetconnhttp.c b/tests/check/gnet/gnetconnhttp.c
+index b1cecce..4316f74 100644
+--- a/tests/check/gnet/gnetconnhttp.c
++++ b/tests/check/gnet/gnetconnhttp.c
+@@ -487,7 +487,7 @@ GNET_END_TEST;
+
+ GNET_START_TEST (test_gnet_http_get)
+ {
+- const gchar *urls[] = {"http://www.gnetlibrary.org/src/",
++ const gchar *urls[] = {"http://www.gnome.org/",
+ "http://www.heise.de" };
+ guint i;
+
+@@ -514,7 +514,7 @@ GNET_END_TEST;
+
+ GNET_START_TEST (test_get_binary)
+ {
+- gchar *uris[] = { "http://www.gnetlibrary.org/gnet.png" };
++ gchar *uris[] = { "http://www.gnome.org/img/logo/foot-16.png" };
+ guint i;
+
+ for (i = 0; i < G_N_ELEMENTS (uris); ++i) {
+--
+cgit v0.10.1
+
diff --git a/net-libs/gnet/files/gnet-2.0.8-unittest-build.patch b/net-libs/gnet/files/gnet-2.0.8-unittest-build.patch
new file mode 100644
index 000000000000..9527dbe5da65
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-unittest-build.patch
@@ -0,0 +1,22 @@
+Fix build failure with newer releases of check library.
+
+--- a/tests/check/gnetcheck.h 2014-09-27 15:32:17.088312230 +0200
++++ b/tests/check/gnetcheck.h 2014-09-27 15:32:35.728239492 +0200
+@@ -281,7 +281,7 @@
+ _gnet_check_expecting_log = TRUE; \
+ _gnet_check_raised_critical = FALSE; \
+ code; \
+- _fail_unless (_gnet_check_raised_critical, __FILE__, __LINE__, \
++ (_gnet_check_raised_critical) ? _mark_point(__FILE__, __LINE__) : _ck_assert_failed (__FILE__, __LINE__, \
+ "Expected g_critical, got nothing", NULL); \
+ _gnet_check_expecting_log = FALSE; \
+ } G_STMT_END
+@@ -291,7 +291,7 @@
+ _gnet_check_expecting_log = TRUE; \
+ _gnet_check_raised_warning = FALSE; \
+ code; \
+- _fail_unless (_gnet_check_raised_warning, __FILE__, __LINE__, \
++ (_gnet_check_raised_warning) ? _mark_point(__FILE__, __LINE__) : _ck_assert_failed (__FILE__, __LINE__, \
+ "Expected g_warning, got nothing", NULL); \
+ _gnet_check_expecting_log = FALSE; \
+ } G_STMT_END
diff --git a/net-libs/gnet/files/gnet-2.0.8-unittest-service.patch b/net-libs/gnet/files/gnet-2.0.8-unittest-service.patch
new file mode 100644
index 000000000000..f2946aaf438c
--- /dev/null
+++ b/net-libs/gnet/files/gnet-2.0.8-unittest-service.patch
@@ -0,0 +1,31 @@
+Disable unittests requiring a running HTTP server on port 80.
+
+--- a/tests/check/gnet/gnetinetaddr.c.old 2014-09-27 17:56:51.130350306 +0200
++++ b/tests/check/gnet/gnetinetaddr.c 2014-09-27 17:57:23.396114568 +0200
+@@ -443,7 +443,7 @@
+
+ GNET_START_TEST (test_inetaddr_list_async)
+ {
+- do_test_inetaddr_list_async ("localhost");
++/* do_test_inetaddr_list_async ("localhost"); */
+ /* FIXME: these might not work right yet because of the timings in the test
+ #ifdef GNET_ENABLE_NETWORK_TESTS
+ do_test_inetaddr_list_async ("www.google.com");
+@@ -573,7 +573,7 @@
+
+ GNET_START_TEST (test_inetaddr_name_async)
+ {
+- do_test_inetaddr_name_async ("localhost");
++/* do_test_inetaddr_name_async ("localhost"); */
+
+ /* FIXME: these might not work right yet because of the timings in the test
+ #ifdef GNET_ENABLE_NETWORK_TESTS
+@@ -798,7 +798,7 @@
+
+ GNET_START_TEST (test_inetaddr_reverse_async)
+ {
+- do_test_inetaddr_reverse_async ("localhost");
++/* do_test_inetaddr_reverse_async ("localhost"); */
+
+ #ifdef GNET_ENABLE_NETWORK_TESTS
+ do_test_inetaddr_reverse_async ("gabe.freedesktop.org");
diff --git a/net-libs/gnet/gnet-2.0.8-r2.ebuild b/net-libs/gnet/gnet-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..c86b795e148b
--- /dev/null
+++ b/net-libs/gnet/gnet-2.0.8-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A simple network library"
+HOMEPAGE="http://live.gnome.org/GNetLibrary"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+# FIXME: automagic use of valgrind
+RDEPEND=">=dev-libs/glib-2.6:2"
+DEPEND="${RDEPEND}
+ >=dev-libs/check-0.9.11
+ >=dev-util/gtk-doc-am-1.2
+ virtual/pkgconfig
+"
+# FIXME: check should only be needed with USE 'test', bug #349301
+# test? ( >=dev-libs/check-0.9.7 )"
+
+src_prepare() {
+ # Do not leak main context reference, from master
+ epatch "${FILESDIR}"/${PN}-2.0.8-context-leak.patch
+
+ # Fix usage of check framework, bug #296849, from master
+ epatch "${FILESDIR}"/${PN}-2.0.8-check-usage-update.patch
+
+ # ifdef around network tests code, refs. bug #320759
+ epatch "${FILESDIR}"/${PN}-2.0.8-network-tests.patch
+
+ # Do not hardcode glib patch in pkgconfig file, debian bug #652165
+ epatch "${FILESDIR}"/${PN}-2.0.8-fix-pkgconfig-abuse.patch
+
+ # Compatibility with recent check releases, bug #498046
+ epatch "${FILESDIR}"/${PN}-2.0.8-unittest-build.patch
+
+ # gnetlibrary.org has been adandoned, from master
+ epatch "${FILESDIR}"/${PN}-2.0.8-test-existing-domain.patch
+
+ # Do not depend on a running HTTP server on port 80 for unittest
+ epatch "${FILESDIR}"/${PN}-2.0.8-unittest-service.patch
+
+ # Do not pass silly cflags with USE=debug, bug #320759
+ sed -i \
+ -e 's:-Werror::' \
+ -e '/AM_PROG_CC_STDC/d' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' \
+ configure.ac || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README* TODO"
+ # Do not enable network tests in an ebuild environment
+ gnome2_src_configure \
+ --disable-static \
+ --disable-network-tests
+}
diff --git a/net-libs/gnet/metadata.xml b/net-libs/gnet/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-libs/gnet/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>