summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-01 22:05:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-01 22:43:09 +0200
commit5d77e9543c460f403fdae1832cd47b5505b02aa3 (patch)
treefde196c0b59cea3e1362d2ef531686b1a5724e49 /net-libs/libssh
parentapp-text/poppler: Drop 0.77.0 (diff)
downloadgentoo-5d77e9543c460f403fdae1832cd47b5505b02aa3.tar.gz
gentoo-5d77e9543c460f403fdae1832cd47b5505b02aa3.tar.bz2
gentoo-5d77e9543c460f403fdae1832cd47b5505b02aa3.zip
net-libs/libssh: Drop 0.8.6 and 0.8.7
Package-Manager: Portage-2.3.74, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libssh')
-rw-r--r--net-libs/libssh/Manifest2
-rw-r--r--net-libs/libssh/files/libssh-0.8.3-strict-overflow.patch21
-rw-r--r--net-libs/libssh/libssh-0.8.6.ebuild110
-rw-r--r--net-libs/libssh/libssh-0.8.7.ebuild117
4 files changed, 0 insertions, 250 deletions
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index 5364d75e205a..9d1285b15bfc 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,3 +1 @@
-DIST libssh-0.8.6.tar.xz 433680 BLAKE2B f222e67676a90a2d2431463dc71859ad336a23a519b54e08fe368efe6322d0b9c8e393ec92d5246cb4721cd57bb955856fa6a2d92ffe71b6c35e2c94cde28762 SHA512 e91d1f4c1343aa232ade0fe4b5e9a92ca65e3716f4ebe2ec25b04def4fae5a3774349f05a6919836551f66fb0288ed6a3e19e0ab786c081616218be973356522
-DIST libssh-0.8.7.tar.xz 430104 BLAKE2B 8ad9455d81120726434a418abb74bfee53279040541cda50117909d43088ea992b9dbc7164b079dbe970b4348b967ed0d3f6352df98f60d1e6d9f14a086b5a40 SHA512 13c3dccad81d521edf29c8a5e2c5f7fdd90507a0eda652b2b040a0a17bab88860873e089a46e181907ea3f449ca1847b1c84453b1960f456e391eefe5be983c5
DIST libssh-0.9.0.tar.xz 487628 BLAKE2B 43c9c889160089f8ab4ce9d486e1892ef9fb7941d7473baf2c27e3fe05da0299bd8a7fa5c4392f24411ec0970f61fc302fbe18b8c807efe07d65f6fc326467e3 SHA512 8c91b31e49652d93c295ca62c2ff1ae30f26c263195a8bc2390e44f6e688959507f609125d342ee8180fc03cec2d73258ac72f864696281b53ba9ad244060865
diff --git a/net-libs/libssh/files/libssh-0.8.3-strict-overflow.patch b/net-libs/libssh/files/libssh-0.8.3-strict-overflow.patch
deleted file mode 100644
index 93b15ec061b8..000000000000
--- a/net-libs/libssh/files/libssh-0.8.3-strict-overflow.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Neither i nor j are ever counted downward for the array pointers, so assume
-they were intended to be signed integers.
-
-Fixes a compiler warning on HPPA triggering an error because of
--Werror=strict-overflow -Wstrict-overflow=2:
-
-src/connect.c:509:7: error: assuming signed overflow does not occur when
-simplifying conditional to constant [-Werror=strict-overflow]
- if(j != 0)
- ^
---- a/src/connect.c
-+++ b/src/connect.c
-@@ -471,7 +471,7 @@
- fd_set *readfds, struct timeval *timeout) {
- fd_set origfds;
- socket_t fd;
-- int i,j;
-+ unsigned int i,j;
- int rc;
- int base_tm, tm;
- struct ssh_timestamp ts;
diff --git a/net-libs/libssh/libssh-0.8.6.ebuild b/net-libs/libssh/libssh-0.8.6.ebuild
deleted file mode 100644
index 65d029e138f0..000000000000
--- a/net-libs/libssh/libssh-0.8.6.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${PN}-${PV/_rc/rc}"
-inherit cmake-multilib
-
-DESCRIPTION="Access a working SSH implementation by means of a library"
-HOMEPAGE="https://www.libssh.org/"
-
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
-else
- SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${MY_P}.tar.xz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0/4" # subslot = soname major version
-IUSE="debug doc examples gcrypt gssapi libressl mbedtls pcap server +sftp static-libs test zlib"
-# Maintainer: check IUSE-defaults at DefineOptions.cmake
-
-REQUIRED_USE="?? ( gcrypt mbedtls ) test? ( static-libs )"
-
-RDEPEND="
- !gcrypt? (
- !mbedtls? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
- )
- )
- gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
- gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
- mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
- test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
-"
-
-DOCS=( AUTHORS README ChangeLog )
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.8.0-tests.patch"
- "${FILESDIR}/${PN}-0.8.3-strict-overflow.patch"
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # just install the examples, do not compile them
- cmake_comment_add_subdirectory examples
-
- # keyfile torture test is currently broken
- sed -i \
- -e '/torture_keyfiles/d' \
- tests/unittests/CMakeLists.txt || die
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DUNIT_TESTING="$(usex test)"
- -DWITH_DEBUG_CALLTRACE="$(usex debug)"
- -DWITH_DEBUG_CRYPTO="$(usex debug)"
- -DWITH_GCRYPT="$(usex gcrypt)"
- -DWITH_GSSAPI="$(usex gssapi)"
- -DWITH_MBEDTLS="$(usex mbedtls)"
- -DWITH_NACL=no
- -DWITH_PCAP="$(usex pcap)"
- -DWITH_SERVER="$(usex server)"
- -DWITH_SFTP="$(usex sftp)"
- -DWITH_STACK_PROTECTOR=OFF
- -DWITH_STACK_PROTECTOR_STRONG=OFF
- -DWITH_STATIC_LIB="$(usex static-libs)"
- -DWITH_ZLIB="$(usex zlib)"
- )
-
- multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
-
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile docs
-}
-
-multilib_src_install() {
- cmake-utils_src_install
- use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
-
- # compatibility symlink until all consumers have been updated
- # to no longer use libssh_threads.so
- dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
-}
-
-multilib_src_install_all() {
- use mbedtls && DOCS+=( README.mbedtls )
- einstalldocs
-
- if use examples; then
- docinto examples
- dodoc examples/*.{c,h,cpp}
- fi
-}
diff --git a/net-libs/libssh/libssh-0.8.7.ebuild b/net-libs/libssh/libssh-0.8.7.ebuild
deleted file mode 100644
index a2353f90c6bd..000000000000
--- a/net-libs/libssh/libssh-0.8.7.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${PN}-${PV/_rc/rc}"
-inherit cmake-multilib
-
-DESCRIPTION="Access a working SSH implementation by means of a library"
-HOMEPAGE="https://www.libssh.org/"
-
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
-else
- SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0/4" # subslot = soname major version
-IUSE="debug doc examples gcrypt gssapi libressl mbedtls pcap server +sftp static-libs test zlib"
-# Maintainer: check IUSE-defaults at DefineOptions.cmake
-
-REQUIRED_USE="?? ( gcrypt mbedtls ) test? ( static-libs )"
-
-RDEPEND="
- !gcrypt? (
- !mbedtls? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
- )
- )
- gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
- gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
- mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
- test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
-"
-
-DOCS=( AUTHORS README ChangeLog )
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.8.0-tests.patch"
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # just install the examples, do not compile them
- cmake_comment_add_subdirectory examples
-
- # keyfile torture test is currently broken
- sed -i \
- -e '/torture_keyfiles/d' \
- tests/unittests/CMakeLists.txt || die
-
- # disable tests that take too long (bug #677006)
- if use sparc; then
- sed -i \
- -e '/torture_threads_pki_rsa/d' \
- -e '/torture_pki_dsa/d' \
- tests/unittests/CMakeLists.txt || die
- fi
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DUNIT_TESTING="$(usex test)"
- -DWITH_DEBUG_CALLTRACE="$(usex debug)"
- -DWITH_DEBUG_CRYPTO="$(usex debug)"
- -DWITH_GCRYPT="$(usex gcrypt)"
- -DWITH_GSSAPI="$(usex gssapi)"
- -DWITH_MBEDTLS="$(usex mbedtls)"
- -DWITH_NACL=no
- -DWITH_PCAP="$(usex pcap)"
- -DWITH_SERVER="$(usex server)"
- -DWITH_SFTP="$(usex sftp)"
- -DWITH_STACK_PROTECTOR=OFF
- -DWITH_STACK_PROTECTOR_STRONG=OFF
- -DWITH_STATIC_LIB="$(usex static-libs)"
- -DWITH_ZLIB="$(usex zlib)"
- )
-
- multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
-
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile docs
-}
-
-multilib_src_install() {
- cmake-utils_src_install
- use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
-
- # compatibility symlink until all consumers have been updated
- # to no longer use libssh_threads.so
- dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
-}
-
-multilib_src_install_all() {
- use mbedtls && DOCS+=( README.mbedtls )
- einstalldocs
-
- if use examples; then
- docinto examples
- dodoc examples/*.{c,h,cpp}
- fi
-}