summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-04-04 09:53:26 +0200
committerJakov Smolić <jsmolic@gentoo.org>2023-04-04 09:59:13 +0200
commitc4286a6222203cc151877c8200a7f5563a2ffec4 (patch)
treed0d43de15ac7ea82e25b95707c7494b95a230256 /net-libs/libyang/libyang-2.1.55.ebuild
parentsys-process/daemontools: fix build w/ clang 16 (diff)
downloadgentoo-c4286a6222203cc151877c8200a7f5563a2ffec4.tar.gz
gentoo-c4286a6222203cc151877c8200a7f5563a2ffec4.tar.bz2
gentoo-c4286a6222203cc151877c8200a7f5563a2ffec4.zip
net-libs/libyang: add 2.1.55
Bug: https://bugs.gentoo.org/903756 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs/libyang/libyang-2.1.55.ebuild')
-rw-r--r--net-libs/libyang/libyang-2.1.55.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/libyang/libyang-2.1.55.ebuild b/net-libs/libyang/libyang-2.1.55.ebuild
new file mode 100644
index 000000000000..76927273f0fa
--- /dev/null
+++ b/net-libs/libyang/libyang-2.1.55.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="YANG data modeling language library"
+HOMEPAGE="https://github.com/CESNET/libyang"
+SRC_URI="https://github.com/CESNET/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/libpcre2"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r doc/.
+}