summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-03-18 22:22:44 +0100
committerDavid Seifert <soap@gentoo.org>2023-03-18 22:22:44 +0100
commit686d9515136b4e06bcd234438ec28aa2ffafc866 (patch)
treea6783fe8063cbe92bef067ef54ac861ed49a8e29 /net-libs/netwib/netwib-5.39.0.ebuild
parentpackage.mask: Last rite net-analyzer/bigeye (diff)
downloadgentoo-686d9515136b4e06bcd234438ec28aa2ffafc866.tar.gz
gentoo-686d9515136b4e06bcd234438ec28aa2ffafc866.tar.bz2
gentoo-686d9515136b4e06bcd234438ec28aa2ffafc866.zip
net-libs/netwib: fix build with clang 16
Closes: https://bugs.gentoo.org/710626 Closes: https://bugs.gentoo.org/828721 Closes: https://bugs.gentoo.org/879735 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/netwib/netwib-5.39.0.ebuild')
-rw-r--r--net-libs/netwib/netwib-5.39.0.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/net-libs/netwib/netwib-5.39.0.ebuild b/net-libs/netwib/netwib-5.39.0.ebuild
deleted file mode 100644
index c73eb6097f01..000000000000
--- a/net-libs/netwib/netwib-5.39.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# NOTE: netwib, netwox and netwag go together, bump all or bump none
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
-HOMEPAGE="
- http://www.laurentconstantin.com/en/netw/netwib/
- http://ntwib.sourceforge.net/
-"
-SRC_URI="mirror://sourceforge/ntwib/${P}-src.tgz
- doc? ( mirror://sourceforge/ntwib/${P}-doc_html.tgz )"
-S="${WORKDIR}/${P}-src/src"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc x86"
-IUSE="doc"
-
-DEPEND="
- net-libs/libnet:1.1
- net-libs/libpcap
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
-
- sed -i \
- -e 's:/man$:/share/man:g' \
- -e "s:/lib:/$(get_libdir):" \
- -e "s:/usr/local:/usr:" \
- -e "s:=ar:=$(tc-getAR):" \
- -e "s:=ranlib:=$(tc-getRANLIB):" \
- -e "s:=gcc:=$(tc-getCC):" \
- -e "s:-O2:${CFLAGS}:" \
- config.dat || die
-}
-
-src_configure() {
- sh genemake || die
-}
-
-src_install() {
- default
- dodoc ../README.TXT
- if use doc; then
- mkdir "${ED}"/usr/share/doc/${PF}/html || die
- mv "${WORKDIR}"/${P}-doc_html/{index.html,${PN}} \
- "${ED}"/usr/share/doc/${PF}/html || die
- fi
-
- cd "${S}"/.. || die
- dodoc \
- doc/{changelog.txt,credits.txt,integration.txt} \
- doc/{problemreport.txt,problemusageunix.txt,todo.txt}
-}