summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-20 13:11:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-20 13:11:26 +0100
commit6c91a928a8464a211d4a0fe3da76a031f128b704 (patch)
tree19e9c0ed30daa38880b641828ce63bc11fa17745 /net-libs/nghttp2/nghttp2-9999.ebuild
parentnet-libs/nghttp2: Bump to version 1.29.0 (diff)
downloadgentoo-6c91a928a8464a211d4a0fe3da76a031f128b704.tar.gz
gentoo-6c91a928a8464a211d4a0fe3da76a031f128b704.tar.bz2
gentoo-6c91a928a8464a211d4a0fe3da76a031f128b704.zip
net-libs/nghttp2: Synced live ebuild.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-libs/nghttp2/nghttp2-9999.ebuild')
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index f340b41cdaf2..f7c762907e06 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -44,24 +44,24 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --disable-examples \
- --disable-failmalloc \
- --disable-werror \
- --without-cython \
- --disable-python-bindings \
- --without-spdylay \
- $(use_enable cxx asio-lib) \
- $(use_enable debug) \
- $(multilib_native_use_enable hpack-tools) \
- $(use_enable static-libs static) \
- $(use_enable threads) \
- $(multilib_native_use_enable utils app) \
- $(multilib_native_use_with jemalloc) \
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-werror
+ --without-cython
+ --disable-python-bindings
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
$(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
- use static-libs || find "${ED}" -name '*.la' -delete
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
}