summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-21 11:54:25 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-21 11:55:37 +0200
commit61b53f1a340a1c60c82b5d03124e4b148f9a4267 (patch)
treec1c38b896b41cb164f4651622532d70383ff1563 /net-libs/nodejs/nodejs-99999999.ebuild
parentnet-libs/nodejs: Version 12.13.0 (diff)
downloadgentoo-61b53f1a340a1c60c82b5d03124e4b148f9a4267.tar.gz
gentoo-61b53f1a340a1c60c82b5d03124e4b148f9a4267.tar.bz2
gentoo-61b53f1a340a1c60c82b5d03124e4b148f9a4267.zip
net-libs/nodejs: Update live ebuild
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/nodejs/nodejs-99999999.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index 098bb9968f85..31b2a891cb11 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
PYTHON_REQ_USE="threads"
inherit bash-completion-r1 flag-o-matic git-r3 pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -20,10 +20,10 @@ REQUIRED_USE="
"
RDEPEND="
- >=dev-libs/libuv-1.30.1:=
+ >=dev-libs/libuv-1.33.1:=
>=net-dns/c-ares-1.15.0
>=net-libs/http-parser-2.9.0:=
- >=net-libs/nghttp2-1.39.1
+ >=net-libs/nghttp2-1.39.2
sys-libs/zlib
icu? ( >=dev-libs/icu-64.2:= )
ssl? ( >=dev-libs/openssl-1.1.1:0= )
@@ -57,7 +57,6 @@ src_prepare() {
# make sure we use python2.* while using gyp
sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
- sed -i -e "s/|| 'python2'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
# less verbose install output (stating the same as portage, basically)
sed -i -e "/print/d" tools/install.py || die