summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-03-06 10:15:23 -0800
committerMike Frysinger <vapier@gentoo.org>2017-03-06 10:15:33 -0800
commitf56569afdbbf7331d42c20ff34a7895e88680196 (patch)
tree60e99126eae552ca3fb2fb7001abbc4dbf475904 /net-libs/ntirpc/ntirpc-1.4.1.ebuild
parentsci-mathematics/glpk: fix configure typo per bug #611694, revbump to apply to... (diff)
downloadgentoo-f56569afdbbf7331d42c20ff34a7895e88680196.tar.gz
gentoo-f56569afdbbf7331d42c20ff34a7895e88680196.tar.bz2
gentoo-f56569afdbbf7331d42c20ff34a7895e88680196.zip
net-libs/ntirpc: initial ebuild from Chromium OS
Diffstat (limited to 'net-libs/ntirpc/ntirpc-1.4.1.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-1.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-1.4.1.ebuild b/net-libs/ntirpc/ntirpc-1.4.1.ebuild
new file mode 100644
index 000000000000..61ddf68d5d6f
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-1.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/linuxbox2/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="app-crypt/mit-krb5
+ rdma? ( sys-fabric/librdmacm )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-city-header.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use gssapi GSS)
+ $(cmake-utils_use_use rdma RPC_RDMA)
+ )
+ cmake-utils_src_configure
+}