summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-14 14:16:44 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-14 18:36:03 +0100
commitfbd3af9cd1ddf39dbc1e9ecff66ac67795f7ad47 (patch)
tree01b154fe6de187fe9a33968abb61021e38403aad /net-libs/ntirpc/ntirpc-4.0.ebuild
parentsys-block/fio: Switch to rdma-core for rdma support (diff)
downloadgentoo-fbd3af9cd1ddf39dbc1e9ecff66ac67795f7ad47.tar.gz
gentoo-fbd3af9cd1ddf39dbc1e9ecff66ac67795f7ad47.tar.bz2
gentoo-fbd3af9cd1ddf39dbc1e9ecff66ac67795f7ad47.zip
net-libs/ntirpc: Switch to rdma-core for rdma support
Closes: https://bugs.gentoo.org/831008 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs/ntirpc/ntirpc-4.0.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-4.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/net-libs/ntirpc/ntirpc-4.0.ebuild b/net-libs/ntirpc/ntirpc-4.0.ebuild
deleted file mode 100644
index 8688e4cc9382..000000000000
--- a/net-libs/ntirpc/ntirpc-4.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
-HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
-SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gssapi rdma"
-
-# Since the GSS option only controls some extra files to be enabled,
-# there's nothing to list in the depend string for it.
-RDEPEND="
- dev-libs/userspace-rcu
- rdma? ( sys-fabric/librdmacm )
-"
-DEPEND="
- ${RDEPEND}
-"
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_GSS="$(usex gssapi)"
- -DUSE_RPC_RDMA="$(usex rdma)"
- )
- cmake_src_configure
-}