summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-10-26 15:08:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-10-26 15:10:02 +0200
commit4252e08fe5e9bc389f16274f62d6d65e1169c86f (patch)
treeaa0cfed94c2fdb4d7cfbfa9afa1a8a1747a9c10e /net-libs/ntirpc
parentnet-im/telegram-desktop-bin: fix Icon in .desktop file (diff)
downloadgentoo-4252e08fe5e9bc389f16274f62d6d65e1169c86f.tar.gz
gentoo-4252e08fe5e9bc389f16274f62d6d65e1169c86f.tar.bz2
gentoo-4252e08fe5e9bc389f16274f62d6d65e1169c86f.zip
net-libs/ntirpc: Bump to version 1.7.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs/ntirpc')
-rw-r--r--net-libs/ntirpc/Manifest1
-rw-r--r--net-libs/ntirpc/ntirpc-1.7.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index a8116621fa1d..3d738281c85e 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1,2 +1,3 @@
DIST ntirpc-1.6.1.tar.gz 397485 BLAKE2B 2dcc4c3a14eff55b4db52f297b65a48d5dff46ef4b1659912c65ca9104958cca02d542bb3b72f2ce63993414c5d53bb9716b1b1d4ce4b335735ee99da77f3770 SHA512 d176fbe71f1f66e5ee477c1ec2722b77742d36d67856eb4029f1b01474b08349171779a9943c0039d2a30e05debc9ab389d92ea137eabb4d7737fc91e47b0b24
DIST ntirpc-1.7.0.tar.gz 373195 BLAKE2B 5cfb6c16d1fa3569d37a6b8f51990dd18e713aaaf0f6e6309c36fb8b0bdb6fa0dfcfa81f0e9e185c18dac5b6d422bd9d1b796b245b3dfa519b0f53300ce5c725 SHA512 84fdf62b8a72bcf1b90854536df3c1e3f06c58858d7a2403ee6c085f8585a5d389921a2feb9e0f27ef238dea3a36a9c94b66ea582f290168a8ed21405a452723
+DIST ntirpc-1.7.1.tar.gz 373327 BLAKE2B 55d71932e35b844e382409593b5dead30246d0cbaa27d3d49ad94d09435acb8abb34b945ba90ab7ba9733a955b4184ad839ba202aa82f97eeecbcc502cb88bf0 SHA512 9a98d83db94b4775940584cd08a1105b79263412d44309f91d1e86c609e6d56a482ac239efaaa73ccc1c2f4cabb8b597ccb8931514f33b8b2fd5c2a11b731106
diff --git a/net-libs/ntirpc/ntirpc-1.7.1.ebuild b/net-libs/ntirpc/ntirpc-1.7.1.ebuild
new file mode 100644
index 000000000000..07720adb2490
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-1.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="app-crypt/mit-krb5
+ net-libs/libnsl
+ rdma? ( sys-fabric/librdmacm )"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}