summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2018-02-06 13:59:14 +0000
committerTony Vroon <chainsaw@gentoo.org>2018-02-06 13:59:26 +0000
commit647c7328cecb9d4296f5e7b346152cacb32fc615 (patch)
treee6a3ba0572ac00523744754d7eb2239bc3ca9c85 /net-libs/pjproject
parentdev-qt/qtmultimedia: revision bump avoids adding unrequested CFLAGS (diff)
downloadgentoo-647c7328cecb9d4296f5e7b346152cacb32fc615.tar.gz
gentoo-647c7328cecb9d4296f5e7b346152cacb32fc615.tar.bz2
gentoo-647c7328cecb9d4296f5e7b346152cacb32fc615.zip
net-libs/pjproject: Add 2.7.1 release
As pointed out by Alexander Wetzel, the --enable-ssl vs --disable-ssl logic in the upstream configure script leaves to be desired. If we delete the silly wrapper and move some files, we can even use eautoreconf. Closes: https://bugs.gentoo.org/609702 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-libs/pjproject')
-rw-r--r--net-libs/pjproject/Manifest1
-rw-r--r--net-libs/pjproject/files/pjproject-2.7.1-ssl-flipflop.patch103
-rw-r--r--net-libs/pjproject/pjproject-2.7.1.ebuild110
3 files changed, 214 insertions, 0 deletions
diff --git a/net-libs/pjproject/Manifest b/net-libs/pjproject/Manifest
index 635b8513252..ee5cb59e30f 100644
--- a/net-libs/pjproject/Manifest
+++ b/net-libs/pjproject/Manifest
@@ -1,2 +1,3 @@
DIST pjproject-2.5.1.tar.bz2 4180967 BLAKE2B 1c7d00ad1eddd0b2b53591927a2cdd9dedfdf61b6e9ab88dba41d3916a3adc5e889ebc2e3e2518368378990929ced580917d990b4b8649e137e03953a7d77ee9 SHA512 7722980e5afa4b541614c4117462b0df3fff2bfec45ca5da18a7c3fce2a5dd6c628ed0bb2412da6086abd59c5ba2844bea9466f49737dbc9ca85d32ef67a2628
DIST pjproject-2.6.tar.bz2 4933273 BLAKE2B cb41f00b81da5069a85a8facde14e77a3cf13b50d9f5131fe04e15a4538cbc2bac026429d386938501b4715c584cd497d31a9ba4f3579f96b7b1b8cf363c99e1 SHA512 48be9a80f90b1cb292c6eb0d071d889f6027f56bdd75095c510d9be2d6b5f1df5a6371617009371525ac5797dc61f5814dcc1cc11d14105e5a2576539f89293f
+DIST pjproject-2.7.1.tar.bz2 4880007 BLAKE2B 33fca89f07abc0b9662b1070c96b903c236a60149734755286dad3111411dbeef5779077a77d21112be6db2957cb7e18c5c833b3c5fd32c26be44d4550fb215e SHA512 cd15afee2a02659668ff228b2652d2bd179393e3b5031afae1c326354fb9676babc08eb689e466165536abc360684299b4fdb41dbb1148aed89afe1ce7e5d979
diff --git a/net-libs/pjproject/files/pjproject-2.7.1-ssl-flipflop.patch b/net-libs/pjproject/files/pjproject-2.7.1-ssl-flipflop.patch
new file mode 100644
index 00000000000..fd1dc5caa1e
--- /dev/null
+++ b/net-libs/pjproject/files/pjproject-2.7.1-ssl-flipflop.patch
@@ -0,0 +1,103 @@
+--- pjproject-2.7.1.ORIG/aconfigure.ac 2018-02-06 11:34:20.973411193 +0000
++++ pjproject-2.7.1/aconfigure.ac 2018-02-06 13:33:31.525015674 +0000
+@@ -1551,57 +1551,56 @@
+ enable_ssl=no
+ fi
+
+-dnl # Include SSL support
++dnl # Correct --enable vs --disable SSL flipflop logic
+ AC_SUBST(ac_no_ssl)
+ AC_SUBST(ac_ssl_has_aes_gcm,0)
+ AC_ARG_ENABLE(ssl,
+ AS_HELP_STRING([--disable-ssl],
+ [Exclude SSL support the build (default: autodetect)])
+- ,
+- [
+- if test "$enable_ssl" = "no"; then
+- [ac_no_ssl=1]
+- AC_MSG_RESULT([Checking if SSL support is disabled... yes])
+- fi
+- ],
+- [
+- AC_MSG_RESULT([checking for OpenSSL installations..])
+- if test "x$with_ssl" != "xno" -a "x$with_ssl" != "x"; then
+- CFLAGS="$CFLAGS -I$with_ssl/include"
+- LDFLAGS="$LDFLAGS -L$with_ssl/lib"
+- AC_MSG_RESULT([Using SSL prefix... $with_ssl])
+- fi
+- AC_SUBST(openssl_h_present)
+- AC_SUBST(libssl_present)
+- AC_SUBST(libcrypto_present)
+- AC_CHECK_HEADER(openssl/ssl.h,[openssl_h_present=1])
+- AC_CHECK_LIB(crypto,ERR_load_BIO_strings,[libcrypto_present=1 && LIBS="-lcrypto $LIBS"])
+- AC_CHECK_LIB(ssl,SSL_CTX_new,[libssl_present=1 && LIBS="-lssl $LIBS"])
+- if test "x$openssl_h_present" = "x1" -a "x$libssl_present" = "x1" -a "x$libcrypto_present" = "x1"; then
+- AC_MSG_RESULT([OpenSSL library found, SSL support enabled])
+-
+- # Check if SRTP should be compiled with OpenSSL
+- # support, to enable cryptos such as AES GCM.
+-
+- # EVP_CIPHER_CTX is now opaque in OpenSSL 1.1.0, libsrtp 1.5.4 uses it as a transparent type.
+- # Update 2.7: our bundled libsrtp has been upgraded to 2.1.0,
+- # so we can omit EVP_CIPHER_CTX definition check now.
+- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <openssl/evp.h>]],
+- [EVP_CIPHER_CTX *ctx;EVP_aes_128_gcm();])],
+- [AC_CHECK_LIB(crypto,EVP_aes_128_gcm,[ac_ssl_has_aes_gcm=1])])
+- if test "x$ac_ssl_has_aes_gcm" = "x1"; then
+- AC_MSG_RESULT([OpenSSL has AES GCM support, SRTP will use OpenSSL])
+- else
+- AC_MSG_RESULT([OpenSSL AES GCM support not found, SRTP will only support AES CM cryptos])
+- fi
+-
+- # PJSIP_HAS_TLS_TRANSPORT setting follows PJ_HAS_SSL_SOCK
+- #AC_DEFINE(PJSIP_HAS_TLS_TRANSPORT, 1)
+- AC_DEFINE(PJ_HAS_SSL_SOCK, 1)
++ , [ac_no_ssl=1]
++)
++
++dnl # OpenSSL detection
++AC_MSG_CHECKING([OpenSSL installations])
++if test "x$ac_no_ssl" = "x1"; then
++ AC_MSG_RESULT([explicitly disabled])
++else
++ if test "x$with_ssl" != "xno" -a "x$with_ssl" != "x"; then
++ CFLAGS="$CFLAGS -I$with_ssl/include"
++ LDFLAGS="$LDFLAGS -L$with_ssl/lib"
++ AC_MSG_RESULT([Using SSL prefix... $with_ssl])
++ fi
++ AC_SUBST(openssl_h_present)
++ AC_SUBST(libssl_present)
++ AC_SUBST(libcrypto_present)
++ AC_CHECK_HEADER(openssl/ssl.h,[openssl_h_present=1])
++ AC_CHECK_LIB(crypto,ERR_load_BIO_strings,[libcrypto_present=1 && LIBS="-lcrypto $LIBS"])
++ AC_CHECK_LIB(ssl,SSL_CTX_new,[libssl_present=1 && LIBS="-lssl $LIBS"])
++ if test "x$openssl_h_present" = "x1" -a "x$libssl_present" = "x1" -a "x$libcrypto_present" = "x1"; then
++ AC_MSG_RESULT([OpenSSL library found, SSL support enabled])
++
++ # Check if SRTP should be compiled with OpenSSL
++ # support, to enable cryptos such as AES GCM.
++
++ # EVP_CIPHER_CTX is now opaque in OpenSSL 1.1.0, libsrtp 1.5.4 uses it as a transparent type.
++ # Update 2.7: our bundled libsrtp has been upgraded to 2.1.0,
++ # so we can omit EVP_CIPHER_CTX definition check now.
++ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <openssl/evp.h>]],
++ [EVP_CIPHER_CTX *ctx;EVP_aes_128_gcm();])],
++ [AC_CHECK_LIB(crypto,EVP_aes_128_gcm,[ac_ssl_has_aes_gcm=1])])
++ if test "x$ac_ssl_has_aes_gcm" = "x1"; then
++ AC_MSG_RESULT([OpenSSL has AES GCM support, SRTP will use OpenSSL])
+ else
+- AC_MSG_RESULT([** OpenSSL libraries not found, disabling SSL support **])
++ AC_MSG_RESULT([OpenSSL AES GCM support not found, SRTP will only support AES CM cryptos])
+ fi
+- ])
++
++ # PJSIP_HAS_TLS_TRANSPORT setting follows PJ_HAS_SSL_SOCK
++ #AC_DEFINE(PJSIP_HAS_TLS_TRANSPORT, 1)
++ AC_DEFINE(PJ_HAS_SSL_SOCK, 1)
++ else
++ AC_MSG_RESULT([** OpenSSL libraries not found, disabling SSL support **])
++ fi
++fi
+
+ dnl # Obsolete option --with-opencore-amrnb
+ AC_ARG_WITH(opencore-amrnb,
diff --git a/net-libs/pjproject/pjproject-2.7.1.ebuild b/net-libs/pjproject/pjproject-2.7.1.ebuild
new file mode 100644
index 00000000000..d2428b19f34
--- /dev/null
+++ b/net-libs/pjproject/pjproject-2.7.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Open source SIP, Media, and NAT Traversal Library"
+HOMEPAGE="http://www.pjsip.org/"
+SRC_URI="http://www.pjsip.org/release/${PV}/${P}.tar.bz2"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+CODEC_FLAGS="g711 g722 g7221 gsm ilbc speex l16"
+VIDEO_FLAGS="sdl ffmpeg v4l2 openh264 libyuv"
+SOUND_FLAGS="alsa oss portaudio"
+IUSE="amr debug doc epoll examples ipv6 opus resample silk ssl static-libs webrtc ${CODEC_FLAGS} ${VIDEO_FLAGS} ${SOUND_FLAGS}"
+
+PATCHES=( "${FILESDIR}"/${P}-ssl-flipflop.patch )
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ oss? ( media-libs/portaudio[oss] )
+ portaudio? ( media-libs/portaudio )
+
+ amr? ( media-libs/opencore-amr )
+ gsm? ( media-sound/gsm )
+ ilbc? ( dev-libs/ilbc-rfc3951 )
+ opus? ( media-libs/opus )
+ speex? ( media-libs/speex )
+
+ ffmpeg? ( virtual/ffmpeg:= )
+ sdl? ( media-libs/libsdl )
+ openh264? ( media-libs/openh264 )
+ resample? ( media-libs/libsamplerate )
+
+ ssl? ( dev-libs/openssl:= )
+
+ net-libs/libsrtp:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="?? ( ${SOUND_FLAGS} )"
+
+src_prepare() {
+ default
+ rm configure || die "Unable to remove unwanted wrapper"
+ mv aconfigure.ac configure.ac || die "Unable to rename configure script source"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ local videnable="--disable-video"
+ local t
+
+ use ipv6 && append-cflags -DPJ_HAS_IPV6=1
+ use debug || append-cflags -DNDEBUG=1
+
+ for t in ${CODEC_FLAGS}; do
+ myconf+=( $(use_enable ${t} ${t}-codec) )
+ done
+
+ for t in ${VIDEO_FLAGS}; do
+ myconf+=( $(use_enable ${t}) )
+ use "${t}" && videnable="--enable-video"
+ done
+
+ econf \
+ --enable-shared \
+ --with-external-srtp \
+ ${videnable} \
+ $(use_enable epoll) \
+ $(use_with gsm external-gsm) \
+ $(use_with speex external-speex) \
+ $(use_enable speex speex-aec) \
+ $(use_enable resample) \
+ $(use_enable resample libsamplerate) \
+ $(use_enable resample resample-dll) \
+ $(use_enable alsa sound) \
+ $(use_enable oss) \
+ $(use_with portaudio external-pa) \
+ $(use_enable portaudio ext-sound) \
+ $(use_enable amr opencore-amr) \
+ $(use_enable silk) \
+ $(use_enable opus) \
+ $(use_enable ssl) \
+ $(use_enable webrtc libwebrtc) \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ emake dep
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dodoc README.txt README-RTEMS
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins -r pjsip-apps/src/samples
+ fi
+
+ use static-libs || rm "${D}/usr/$(get_libdir)/*.a"
+}